Author Topic: [FF7PC-98] Installer Remake - Tom's Installer [Works on Windows 10!] (1.5.0)  (Read 31389 times)

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
Thats right, you heard it, a full FF7Inst.exe remake! Now released!

Introduction;
This is a completely new, non InstallShield based installer, yet remains 1:1 identical to the original installer.
Windows 10 users are able to *finnaly* install ff7 on their computers without having to downgrade to Windows 7 or 8!
And best of all, mod support can be included, however I need your opinions on this part.

Features:
- Compatible with Windows 10
- Install movies to hard drive automatically
- 1:1 Identical Emulation of original FF7Inst.exe
- Installs the game quite faster than the original installer
- Built in updater to easily update your game to 1.02 while installing, no hastle later trying to find files!
- Built in patcher to automatically Chocobo-Crash fix your game without the need for external patchers.
- Compatible with any Windows NT5 or higher OS capable or running the .NET framework 4.0

Download:
Update News! Massive update, 1.5.0 uses Installer Coordinator II and supports configs and install movies to hard drive automatically!
You can download the latest version (1.5.0) here: http://www.mediafire.com/download/pm233877lf2xfqs/Toms_Installer1.5.0.zip

IMPORTANT: Please open FF7Config AFTER installing and SET THE AUDIO DRIVER to something, the game will not start if the box is blank!
Support questions that have missed this critical step will be ignored!

You can still download the previous version (1.4.2) here if you encounter problems:
http://www.mediafire.com/download/au4dgzaq9jtchza/Toms_Installer1.4.2.zip

Information:
Requires Administrator permissions!
Requires .NET Framework 4.0
The ability to run 32 bit programs
Change the install path only if you know what you are doing what the consequences of doing so are! (Some mods won't work if you change it!)
If your Program Files directory is on D:\ or E:\ it WILL autodetect it, no need to change any settings.
When it starts up at first and asks your for a folder point it to your CD-ROM drive where you have your install disc! (Not game disc 1-3)
Keep both DLLs and Data ZIPs in the same folder as the installer .exe it is required!
Please do not remove discs from the CD tray unless instructed on the screen to do so.

Changelog:
Version 1.5.0 - Installer Coordinator II after about a year with no updates! (Last Edit: 2015-12-14 19:03:10)
+Installer Coordinator II
+CONFIG.INI configuration file lets you change the default options on your installer and create custom setup scripts that automatically install the game (Good for network installations?)
+Install Movies to hard drive option, called Maximum install! (Not selected by default)
+Variable Editor, lets you edit the variables of the program and create your own config.ini files
+If you select the wrong drive on a disc selection menu you can retry instead of being forced to quit
+A dialog before the final window asking you to restart or not was missing (forgotten perhaps?), it was added
*Graphical update, new graphical buttons and more exact text on the IC dialogs
*On the final window, clicking on the text next to the radio buttons changes the selection like in the original, previously you would have to click exactly on the radio button circle.
*Changes in internal code so less copy paste and more common shared modules
-Old style debug mode removed, its now a variable editor.

Version 1.4.2 - Sweeping the mess under the rug...
*Fixes a registry bug that could prevent the game from running
*Path select dialog now lets you select folders outside of Program Files (x86)

Version 1.4.1 - The second biggest Installer Coordinator update! (I really gotta come up with some more creative titles...)
+Program Folder listing in the window with Yuffie on it
+Program Folder name changing (on the window with Yuffie on it)
+More error handling via Installer Coordinator engine.
*Changed methods ChangeBackgroundImage(id) and RefreshCoordinatorButtons() to Subs since they don't return values (Could prevent a crash or two maybe?)
*The progress bar on the Vincent Install screen is *always* in front of the window now. (Prevents it from being hidden without a way to get it back!)

Version 1.4.0 - The biggest coordinated release yet!
*Major Change: Installer now uses my new Installer Coordinator (IC) install engine!
+Installer Coordinator (Fixes all WINE bugs)
+First time users get access to the tools I use to make the installer (Installer Coordinator)
+Robust Kernel and Variable Manager (Installer Coordinator)
+Robust Error handling (With custom icons via Installer Coordinator)
+Debug Mode lets you ignore errors that would otherwise halt the installer (Very dangerous but useful for Power Users!)
+Custom icon sets for buttons (Look for that Ignore error button, its pretty funny!)
+InstallShield Emulation (Hooking into actual installer scripts and functions!)
*Fixed Font in buttons so it no longer smooths the edges of the text. (To mimic the original text feel)
*Fixed a path error that would cause a Win32 error (File Not Found)

Version 1.3.4 - Ghost buster
*Fixes ghost installers remaining in memory after exit

Version 1.3.3 - Fine Wine
+Adds suport to run on Wine
+Console output
*Fixes a bug in the autodetection

Version 1.3.0 - The stable one!
+Adds automatic 1.02 updating
+Adds automatic chocobo-crash patching
+Cait Sith's picture frame appears when patching/updating
+You can now install the Yamaha SoftSynth
*Fixes crash when installing on an already existing install
*Fixes issue on last frame where it would appear  on the taskbar

Version 1.2.0 - The professional one!
+Adds shortcuts to the Start menu!
+Standard and Maximum install work (Previously installed Max no matter what you selected)
*Fixes registry bugs
*UI has been polished
*Current Operation: While installing reports the correct operation

Version 1.1.0 - The amateur one!
+Ask for Administrator when run
+Working cancel buttons!
*Changing path now works however you do so at your own risk and some mods and other installers don't like altered paths!
*Closing the Setup window now closes the big window in the background
*Minor Changes to prevent DLL errors in the first place
*Changed version formatting to something more familiar and used by other tools

Version 1.01
*Fixes a CustomControls DLL error

Version 1.00
+Techicnal Test Release
+GUI,Installer,Registry modules added

Screenshots:
Welcome Screen:

Select Components Screen:

Select Setup Type Screen:

(It does also have that progressbar/loader thingy on startup if you were wondering about that...)
(Also, the image in the background *does* change, as BackgroundID has been implemented)

Support - Questions: Moved to a next post, scroll down a bit!

Mod Compatibility:

All mods that work on 1998 version will work on this as the install is practically identical.

Aali's OpenGL Driver:
This is compatible with Aali's Mod however the driver must be installed AFTER you install the game using Tom's Installer and you MUST have update game to 1.02 selected on the components screen (Its selected by default).

NT Mod (New Threat):
If you changed the install path during setup the Installer for New Threat will have to be pointed to that path.  This also applies to any other mods with GUI installers.

Chocobo Patcher:
If you selected to install the chocobo races patch (Its selected by default), do not run the chocobo patcher as it is already installed.

FF7 1.02 Update:
If you selected to update your game to 1.02 don't use any other tools or methods to re update your game as they might break something.


I would like to hear any feedback about it, features you would want added or how your mod can work with this if you are a mod creator.
« Last Edit: 2016-09-08 09:35:42 by Tom »

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
Support - Questions:
0. Q: When it starts it asks me for a folder!
0. A: Point it to the CD Drive you have your Final Fantasy VII Install Disc (Not Game Discs 1-3).

1. Q: Will this work on my computer?
1. A: This works on any computer with .NET Framework 4.0 Installed. (Wine Mono does also work on Linux Wine and ReactOS (Mono is separate from Wine!))

2. Q: Do I have to download the .NET Framework to use this?
2. A: If you have Windows 8, 8.1 or 10 you do not have to do anything.

3. Q: If I have already installed the game can I use this?
3. A: Yes, if you want to 1.02 update or chocobo races fix your game. If you want to reinstall delete your C:\Program Files\Square Soft, Inc\ folder (THIS REMOVES YOUR SAVES UNLESS YOU BACKUP THE SAVE FOLDER)

4. Q: Error: You selected a source however that path does not contain game data!
4. A: Your path might be incorrect, it has to be your CD-ROM drive with FFVII disc in it! (Check if the path you selected has ff7.exe and ff7config.exe in it!)

5. Q: Error: You did not select the path to your Final Fantasy VII Install Disc!
5. A: You did not select a path and clicked cancel on the dialog, try again.

6. Q: I get an error while installing (On the screen with Vincent or Cait Sith on it)
6. A: Check if you have write permissions to the folder you are installing FF7 to.

7. Q: In Linux the application closes after I select a path
7. A: Please update your Installer to 1.3.4 or newer

8. Q: Yamaha SoftSynth installer does not work on my operating system
8. A: The Yamaha installer might not work because it also needs a remake, which is a work in progress.  Yamaha SoftSynth does not work *at all* on 64 bit systems.

9. Q: Do I need to uncheck or check "Install DirectX" and "Install DirectShow"
9. A: Your computer already has DirectX and DirectShow, so these options won't make a difference.

10. Q: If I just spam the "Next" button the whole way through the installer will it install everything ready to be modded?
10. A: Yes, all the correct settings to be compatible with mods are selected by default and you should only change them if you know what the options do and what they mean.

11. Q: What does the word "path" mean?
11. A: A path is a location of a folder, a hard drive or a CD-ROM drive on your computer.

12. Q: Why do there seem to be less files in the FF7 Folder?
12. A: Some files that the original installer used don't get installed or get replaced by others this installer uses since the installers have different architectures.

13. Q: How do I manually uninstall the game?
13. A: Delete %ProgramFiles(x86)%\Square Soft, Inc, delete in registry local machine\ software\Square Soft, Inc, delete the start menu folder and that's it.

14. Q: On the screen with Sephiroth Fire background I get an error!
14. A: Your disc/mounted ISO is bad, try again with an original or 100% compatible disc/ISO

15. Q: Does it work with winetricks installed
15. A: Yes it does work with and without winetricks but you got to have either Microsoft .Net 4.0 or Wine Mono installed (This applies only to linux)
« Last Edit: 2017-01-28 13:13:52 by Tom »

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
edit: Reserved
« Last Edit: 2015-09-02 00:51:27 by Covarr »

RedManMark86

  • Cool newbie
  • *
  • Posts: 83
  • Karma: 8
    • View Profile
I'm lost, is this actually released as I can't see a download it anywhere?

Maki

  • Lana Del Rey
  • Insane poster
  • *
  • Posts: 443
  • Karma: 76
  • Final Fantasy VIII reverse team
    • View Profile
I'm lost, is this actually released as I can't see a download it anywhere?

Looks like it's indev.

Could you do the one for FF8 also? InstallShield doesn't even start on windows 10.

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3913
  • Karma: 116
  • The Great Redarr.
    • View Profile
Looks like it's indev.
Yes, this is why I asked Tom to start this thread in Scripting and Reverse Engineering. I'll move it to Tools once there's a release at a usable state.

edit: and there it goes!
« Last Edit: 2015-08-31 03:15:11 by Covarr »

RedManMark86

  • Cool newbie
  • *
  • Posts: 83
  • Karma: 8
    • View Profile
thanks for the download mate, Though not being able to change the install path could cause some issues with 7th Heaven...

In the past whenever I've installed to the windows program folders it has caused it not to work, probably because of the protection on them so I always installed it to games/FF7 but I will test later and let you know :)

Thank you for your work mate

quick update, tried installing and I get this error...

http://imgur.com/qhk4Yrf

Code: [Select]
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.InvalidOperationException: An error occurred creating the form. See Exception.InnerException for details.  The error is: Could not load file or assembly 'Microsoft.VisualBasic.PowerPacks.Vs, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.VisualBasic.PowerPacks.Vs, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
   at FF7Inst.WelcomeWindow.InitializeComponent()
   at FF7Inst.WelcomeWindow..ctor()
   --- End of inner exception stack trace ---
   at FF7Inst.My.MyProject.MyForms.Create__Instance__[T](T Instance)
   at FF7Inst.My.MyProject.MyForms.get_WelcomeWindow()
   at FF7Inst.InstallerStartup.TimerProgress_Tick(Object sender, EventArgs e)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.96.0 built by: NETFXREL2STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
FF7Inst
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Mark/Downloads/Toms_Installer_v1.00/FF7Inst.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
CustomControls
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Mark/Downloads/Toms_Installer_v1.00/CustomControls.DLL
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

« Last Edit: 2015-08-31 12:59:36 by RedManMark86 »

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
« Last Edit: 2015-08-31 16:58:12 by Tom »

RedManMark86

  • Cool newbie
  • *
  • Posts: 83
  • Karma: 8
    • View Profile
new error when it is just about to start installing after you click ok to the start menu program folder.

Code: [Select]
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
   at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start()
   at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start(String fileName)
   at FF7Inst.SetupComplete.SetupComplete_Load(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.96.0 built by: NETFXREL2STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
FF7Inst
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Mark/Downloads/Toms_Installer_v1.01/FF7Inst.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
CustomControls
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Mark/Downloads/Toms_Installer_v1.01/CustomControls.DLL
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
Microsoft.VisualBasic.PowerPacks.Vs
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.30319.1
    CodeBase: file:///C:/Users/Mark/Downloads/Toms_Installer_v1.01/Microsoft.VisualBasic.PowerPacks.Vs.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.



Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
That error was due to a missing DLL and has been fixed in version 1.01 (now 1.1.0): http://www.mediafire.com/download/of82k8d4znfjciq/Toms_Installer1.1.0.zip
« Last Edit: 2015-08-31 16:57:58 by Tom »

RedManMark86

  • Cool newbie
  • *
  • Posts: 83
  • Karma: 8
    • View Profile
I just did 1.01... before it crashed on the moment after it said a valid disk had been found, then you added the visual basic pack it was looking for and now it crashes when you say ok to the start menu program folder name just before it goes to install... it is a different error

Update

Running it as an administrator fixes the issue
« Last Edit: 2015-08-31 15:02:20 by RedManMark86 »

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
Its an installer, you always run installers as admin.  How did the install go?  What Operating System are you on?
« Last Edit: 2015-08-31 16:37:41 by Tom »

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3913
  • Karma: 116
  • The Great Redarr.
    • View Profile
Its an installer, you always run installers as admin.  How does it install the game?  What Operating System are you on?
As a rule of thumb, any software that needs admin should be requesting it on its own. It is not good practice to require the user to run as admin manually.

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
Update 1.3.0 is out!
Automatically asks for administrator now!
Fixes cancel buttons
Adds auto chocobo patching
Adds auto 1.02 updating
Eliminates most crashes
Download in the OP or here: http://www.mediafire.com/download/siop8geqc6or2f4/Toms_Installer1.3.0.zip
« Last Edit: 2015-08-31 21:42:42 by Tom »

Hellbringer616

  • No life
  • *
  • Posts: 1915
  • Karma: 12
    • View Profile
the chocobo patch isn't the dreaded "XP Patch" is it? could be i am way out of the scene these days, But i never had a need for the patch

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3913
  • Karma: 116
  • The Great Redarr.
    • View Profile
the chocobo patch isn't the dreaded "XP Patch" is it? could be i am way out of the scene these days, But i never had a need for the patch
No. There was a bug in the game that caused the chocobo races to crash on XP or later, and a patch released by Qhimm back when he was active that fixed this bug. Very small tweak. You didn't need it if you used Aali's driver, because it has the same fix built in.

The dreaded "XP Patch" You're referring to is probably AnimeVamp's 1.4 patch, which causes all sorts of problems both with the game and with the OS, and should be avoided at all costs.

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
Fixed wine compatibility in 1.3.4
You can now install the game in a *nix/linux/*buntu computer with the new installer :)

Kaldarasha

  • No life
  • *
  • Posts: 2127
  • Karma: 127
  • Prince of Model Editing
    • View Profile
What the games converter does is that it replaces all non-english files with the english ones. It also installs DLPB's Tools (I think it doesn't use the latest 2.0 build) so it can use hext texts to translate the english ff7.exe to the desired language. The idea behind this is to unify all different language versions to one universal files system, this allows all mods for the english game to also work with the French,German and Spain installment. For the steam version does the GC also add needed registry entries. If you could implement something similar as that it, would be an absolute great addition.

http://forums.qhimm.com/index.php?topic=14047.0

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
How does it replace German files with English ones if you only have the German ones to start with?
So it makes the game English then translates it again?  I do not understand...

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 2671
  • Karma: 184
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
I can PM you the .bat code to get a better look at what it does.

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
Yes, that would be nice.

Pooka

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
  • Rufus Shinra
    • View Profile
I just downloaded the installer and tried it on my FF7 ISO. Windows 10 Home, Single Language, 64-bit edition.

Right after I click the OK and the background changes to Nibelheim Sephiroth, an unhandled exception pops out.

Code: [Select]
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
   at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start()
   at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start(String fileName)
   at FF7Inst.SetupComplete.SetupComplete_Load(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.96.0 built by: NETFXREL2STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
FF7Inst
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Pooka/Desktop/FF7Inst/FF7Inst.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.93.0 built by: NETFXREL2STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.79.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
CustomControls
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Pooka/Desktop/FF7Inst/CustomControls.DLL
----------------------------------------
Microsoft.VisualBasic.PowerPacks.Vs
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.30319.1
    CodeBase: file:///C:/Users/Pooka/Desktop/FF7Inst/Microsoft.VisualBasic.PowerPacks.Vs.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Also, its interesting how I can only change the install path to something inside Program Files. No selection of other partitions or anything. I'd appreciate this option. Oh, and this bug was with the latest edition (1.3.4). But I'm appreciating the idea of the program. I'm waiting for a similar one for FF8, as I never got FF8 to run on Windows 10, period.

Oh, and hi Qhimm!

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
I need a bit more to know what caused this, did you change the install path and even if you encountered the error did the game actually install?  (Did you try and change it but hit cancel?)  Did you select any of the extras like Yamaha SoftSynth, DirectX, DirectShow, 1.02 update or Chocobo Patch?

Pooka

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
  • Rufus Shinra
    • View Profile
I need a bit more to know what caused this, did you change the install path and even if you encountered the error did the game actually install?  (Did you try and change it but hit cancel?)  Did you select any of the extras like Yamaha SoftSynth, DirectX, DirectShow, 1.02 update or Chocobo Patch?

I tried changing the install path, and then tried keeping it. I also ticked off some extras, mainly the old things (Yamaha, DX, DirectShow). When I get to the part with the error, and continue, the installer says all is okay, restart is needed, but turns out nothing was ever moved besides a few directories and only a file or two. I'll reproduce this today and get a more detailed description.

Tom

  • Crazy poster
  • *
  • Posts: 210
  • Karma: 38
    • View Profile
Try it once without ever touching the path settings and leave all options that are checked by default, do maximum install and as a install disc use your ff7 install disc, if you have an ISO you must mount the ISO as it will not read anything directly from the ISO, even if you extract it.  It will only work from a disc drive (physical and virtual are both supported but it must be a drive).
Use a program like MagicDisc (free) to mount the ISO if you don't have CD-ROM drive or can't use it.

In the first insert-disc dialogue select the root of your CD-ROM drive, like just select the drive and nothing inside, and again it wont work from a folder only from a drive.