Author Topic: [SOLVED] [FF8PC-2000] Problems with Aali's drivers on windows 10  (Read 817 times)

Halfer

  • Crazy poster
  • *
  • Posts: 142
  • Karma: 32
    • View Profile
Hello!

While ago I installed windows 10 again on my laptop. Before that I had windows 10 installed with straight update from windows 8 and FF8 worked fine on that.

However, now that i'm trying to install FF8 again on fresh windows I keep encountering problems with it.

Here's APP.LOG from Aali's drivers:
Code: [Select]
[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF8 1.2 US English
[00000000] INFO: Intel Intel(R) HD Graphics 4400 4.3.0 - Build 10.18.14.4222
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Using PBO
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 16384x16384
[00000000] INFO: Original resolution 640x480, window size 1024x768, output resolution 1024x768, internal resolution 1280x960
[00000000] INFO: Shader limits: varying 64, vert uniform 4096, frag uniform 4096
[00000001] MATRIX INITIALIZE
[00000001] INITIALIZING SOUND...
[00000001]   initializing direct sound
[00000001]   EAXDirectSoundCreate

Also, worth to note that whenever trying to launch EAXUnified.exe, it extracts itself and installshield and pops window with error saying: failed to load custom driver.

Using, non-geforce update 1.20 with HD 4400 integrated gpu since Geforce 840m didn't work with FF8 before installing windows 10 again.

P.S. This stupid problem is limiting the development of wmx2obj/obj2wmx program since I can't test it right now.... Was planning on releasing a version before Christmas, but it's hard to test the correct behavior without FF8.

Edit: Another app.log with different error

Code: [Select]
[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF8 1.2 US English
[00000000] INFO: Intel Intel(R) HD Graphics 4400 4.3.0 - Build 10.18.14.4222
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Using PBO
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 16384x16384
[00000000] INFO: Original resolution 640x480, window size 1920x1080, output resolution 1440x1080, internal resolution 1920x1440
[00000000] INFO: Shader limits: varying 64, vert uniform 4096, frag uniform 4096
[00000000] ERROR: failed to stat file c:\ff8\final fantasy viii/shaders/main.vert
[00000000] ERROR: failed to load shaders
« Last Edit: 2015-12-21 13:57:33 by Halfer »

Yagami Light

  • Cool newbie
  • *
  • Posts: 50
  • Karma: 13
    • View Profile
Re: [FF8PC-2000] Problems with Aali's drivers on windows 10
« Reply #1 on: 2015-12-21 12:47:41 »
Hmm not sure, you could try

1. Uninstalling and reinstalling outside of program file folder
2. Cleaning up any registry issues
3. Run in 7/8 compatibility mode

If shaders not loading is the issue, maybe it's not playing well with the intergrated gpu, why doesn't the 840m work? you have latest nvidia updates installed? tried reverting to an older nvidia update? isn't the non-geforce 1.2 patch meant for amd cards?

If nothing works you can just buy ff8 off steam during winter sale for dirt cheap

Halfer

  • Crazy poster
  • *
  • Posts: 142
  • Karma: 32
    • View Profile
Re: [FF8PC-2000] Problems with Aali's drivers on windows 10
« Reply #2 on: 2015-12-21 13:13:51 »
Okay after fighting over night and morning I finally got it working. The reason was FAULTY eax.dll in SysWOW64 application.

About my graphic cards. I have run FF8 on integrated GPU because when I set up FF8 first time to this laptop I had really bad graphic problems with 840m. I'm not sure if they were an issue with Aali's drivers or something else, didn't bother with that much since I got it working somehow.

I was about to buy FF8 from steam if I wouldn't have got this old version working, but well, here it is working again :D Thanks for help also!