Author Topic: Broken light animations in upscaled backgrounds?  (Read 251 times)

BahamutSIN

  • Fast newbie
  • *
  • Posts: 40
  • Karma: 0
    • View Profile
Broken light animations in upscaled backgrounds?
« on: 2018-02-25 01:29:09 »
So I'm using Satsuki's upscaled waifu backgrounds and my issue is that some light animations don't work well (or at all). Is this a known issue? And is there a fix?
« Last Edit: 2018-02-25 20:09:27 by BahamutSIN »

BahamutSIN

  • Fast newbie
  • *
  • Posts: 40
  • Karma: 0
    • View Profile
Re: Broken light animations in upscaled backgrounds?
« Reply #1 on: 2018-03-02 10:57:49 »
A bump with some examples because this is an otherwise awesome upscale mod with just odd animation flaws here and there. And I've noticed that these issues also happen with Yarlson's and Omzy's backgrounds too.

- The end of the highway (after Motorball fight). Car lights flicker but construction lights stay still.
- Shinra Building: The blue lights surrounding the elevator in which Aerith and Red XIII are trapped in aren't 'glowing', they're just still.
- Candle lights inside Kalm houses don't flicker. They're still.
- Cloud's flashback: When Tifa, Cloud and Sephiroth approach the materia spring, in this scene the lights illuminating the materia don't animate themselves smoothly (hope that makes sense?)
- Dyne death scene: again, the dramatic lights from the sky appear without smooth transition.

These glitches are often accompanied by brief yellow error messages popping up at the bottom of the screen that say something like "failed to load texture". I'd appreciate any help or advice on this matter.

Kaldarasha

  • No life
  • *
  • Posts: 2200
  • Karma: 133
  • Prince of Model Editing
    • View Profile
Re: Broken light animations in upscaled backgrounds?
« Reply #2 on: 2018-03-02 12:14:14 »
Sorry, for the late response but it is a known error. The opengl driver can't handle the light layer in png format correctly. Even when you would replace the layer with a not upscaled version of them, the light gets broken. The only way to fix it, is to delete the files for the light layer. Usually they end with _15 (and up).

BahamutSIN

  • Fast newbie
  • *
  • Posts: 40
  • Karma: 0
    • View Profile
Re: Broken light animations in upscaled backgrounds?
« Reply #3 on: 2018-03-02 14:00:52 »
Hey thanks for the answer Kaldarasha. If that's the case, I will try removing the glitchy light files then. Don't want this issue to break my immersion in the game. I could live with the low res lights as long as they work well. Thanks!