Author Topic: Error with 7th Heaven every time I try to launch the game, with or without mods.  (Read 297 times)

Moonfrost

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Hello everyone, I am currently having issues with 7th heaven to play FFVII with some awesome mods, I have the steam version which I have converted as per instructions, all that went smoothly...but cannot start the game with the mods or without on 7th heaven,tried everything on the frequently asked questions, all the workshop settings are correct, I have all mods in the correct order etc. and I'm using version 1.54 (also happened with 1.55 even with all save slots occupied, so had to roll back).

Every time I try to start I get this error:

Quote
System.IO.FileNotFoundException: Could not load file or assembly 'EasyHook, Version=2.7.6035.0, Culture=neutral, PublicKeyToken=4b580fca19d0b0c5' or one of its dependencies. The system cannot find the file specified.
File name: 'EasyHook, Version=2.7.6035.0, Culture=neutral, PublicKeyToken=4b580fca19d0b0c5'
   at Iros._7th.Workshop.fLibrary.Launch(Boolean varDump, Boolean debug)
   at Iros._7th.Workshop.fLibrary.bLaunch_Click(Object sender, EventArgs e) in C:\Code\7H\7thWorkshop\fLibrary.cs:line 1124
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

If any more info is needed please let me know, I have also tried what it says at the bottom regarding a registry entry, but I cannot find the specified key to change...thanks in advance.

EDIT: I deleted the workshop appdata folder, started again, set up the mods again, now the game starts but right before the main menu it crashes with "Oops, something went very wrong" error message, when I check the APP.LOG, I get the following:


Quote
[00000000] INFO: main program link log:
No errors.

[00000000] INFO: FFMpeg movie player plugin loaded
[00000000] INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
[00000000] INFO: VGMStream music plugin loaded
[00000000] INFO: Loading external library Multi.dll
[00000000] LOCK UNLOCK TEST
[00000001] MATRIX INITIALIZE
[00000001] INITIALIZE DD/D3D END
[00000001] initializing sound...
[00000001] creating dsound primary buffer
[00000001] reading audio file
[00000001] loading static sounds
[00000001] sound initialized
[00000001] set music volume: 127
[00000001] set music volume: 127
[00000001] Entering MAIN
[00000001] Exiting MAIN
[00000001] START OF CREDITS!!!
[00000001] INFO: C:\Games\Final Fantasy VII\data\movies\eidoslogo.avi; vp8/vorbis 1280x960, 30.000000 FPS, duration: 11.133000, frames: 334
[00000001] INFO: vertex shader compile log:
No errors.

[00000001] INFO: fragment shader compile log:
No errors.

[00000001] INFO: yuv program link log:
No errors.

[00000065] set music volume trans: 127->0, step=60
[00000130] END OF CREDITS!!!
[00000130] Entering MAIN
[00000130] set music volume: 127
[00000130] Exiting MAIN
[00000130] START OF MENU SYSTEM!!!
[00000130] ERROR: unhandled exception

I tried this with just one mod activated, and all of them, or some of them, same error every time...
« Last Edit: 2017-07-16 01:36:47 by Moonfrost »

GriFFiNN.Qc

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
I have the same error with the same Config:
Steam, correct order, 1.54, etc.
Did you find the solution?

prefix

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
Sounds like you guys might be having the same problem i had.
Look at my post, especially number 5 in my list :)

http://forums.qhimm.com/index.php?topic=17780.0