Author Topic: FF8 Battle Flashes Disabled  (Read 1310 times)

DLPB

  • No life
  • *
  • Posts: 9239
  • Karma: 297
  • For I realized that God's a young man, too.
    • View Profile
FF8 Battle Flashes Disabled
« on: 2017-09-07 00:26:08 »
I worked with JWP to solve this issue for user Giud, and eventually we got there.  FF8 is a NIGHTMARE to debug.  The optimizer being on without stack frames is only the start.  This may be useful to those with epilepsy.  Use HextEdit (or other hex editor) with the following:

Code: [Select]
FF8_EN.exe

{For certain flashes like critical attacks
{1067BC = 90:5

{Disable all battle flashes
1712C0 = C3

When using HextLaunch (memory addresses), it is

Code: [Select]
{For certain flashes like critical attacks
{5067BC = 90:5

{Disable all battle flashes
5712C0 = C3

If you only want specific critical flashes to be disabled, move the curly bracket { over the second entry and remove it from the first.

This is for the English Steam version.  Other versions will need new addresses.



Mcindus

  • Freak
  • *
  • Posts: 761
  • Karma: 129
  • Artist, Modder, Musician.
    • View Profile
    • Lunatic Pandora
Re: FF8 Battle Flashes Disabled
« Reply #1 on: 2017-09-07 10:06:07 »
Great work!!!

Looking forward to more FF8 mods from you in Hext!

gaaasstly

  • Fast newbie
  • *
  • Posts: 36
  • Karma: 2
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #2 on: 2017-09-07 15:50:55 »
Can you clarify the syntax for me?

{ = comment?
address = relative or absolute?
<address> = <hex>:<size>?

@Mcindus -> http://forums.qhimm.com/index.php?topic=15354.msg252994#msg252994
« Last Edit: 2017-09-07 15:54:42 by gaaasstly »

DLPB

  • No life
  • *
  • Posts: 9239
  • Karma: 297
  • For I realized that God's a young man, too.
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #3 on: 2017-09-07 18:12:47 »
Download HextTools 3.0 from tools.  It comes with full help file.

52983562983629

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #4 on: 2017-12-27 14:03:17 »
Hey do you know how to disable flashes on international versions of Steam? I'm from Italy and I would really like to do it.

Maki

  • Software hacker
  • Freak
  • *
  • Posts: 521
  • Karma: 99
  • Paranoid
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #5 on: 2017-12-27 17:38:11 »
FF8 is a NIGHTMARE to debug.

No, it's not. 👿

Hey do you know how to disable flashes on international versions of Steam? I'm from Italy and I would really like to do it.

It's a hack for international version. You probably want a patch for FF8_IT.exe
« Last Edit: 2017-12-27 17:41:18 by Maki »

52983562983629

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #6 on: 2017-12-27 20:52:35 »
Soooo... what do I do? (sorry, I'm not good at these things)

Maki

  • Software hacker
  • Freak
  • *
  • Posts: 521
  • Karma: 99
  • Paranoid
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #7 on: 2017-12-27 22:22:34 »
Wait a bit. DLPB will surely port it over to Italian. I'm also free tomorrow so if I don't forget I'll write you updated addresses.

DLPB

  • No life
  • *
  • Posts: 9239
  • Karma: 297
  • For I realized that God's a young man, too.
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #8 on: 2017-12-27 23:08:53 »
no no i'm too busy!  haha but it should be easy to find the offsets

Maki

  • Software hacker
  • Freak
  • *
  • Posts: 521
  • Karma: 99
  • Paranoid
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #9 on: 2017-12-28 11:25:52 »
Here you are!

0050638C
00571870

Therefore:
Code: [Select]
{For certain flashes like critical attacks
{50638C = 90:5

{Disable all battle flashes
571870 = C3

For EXE patching just change first 5 to 1
« Last Edit: 2017-12-28 11:37:55 by Maki »

52983562983629

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: FF8 Battle Flashes Disabled
« Reply #10 on: 2017-12-28 12:42:46 »
Thank you so much!!