Author Topic: Final Fantasy 7 sound effect problems  (Read 6497 times)

Edge4o7

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Final Fantasy 7 sound effect problems
« on: 2012-12-14 08:10:32 »
I was recommended this thread http://forums.qhimm.com/index.php?topic=13212 via another forum

For some reason, I'm not getting all the sound effects in the game. I'm using Bootloader with some general graphics mods. If anyone has any experience with this and can help me out I'd appreciate it.

I'm not getting:

attack sound effects
spell sound effects
menu sound effects
Chat sound effects (if they exist, I don't remember) like if I press X during dialogue, there's no little confirmation sound, if that makes sense. I don't really care though.

I've checked a lot of settings and can't get them to work. Any ideas?

PitBrat

  • No life
  • *
  • Posts: 1388
  • Karma: 12
  • Change to feed the machine.
    • View Profile
Re: Final Fantasy 7 sound effect problems
« Reply #1 on: 2012-12-14 12:01:17 »
Q:Why is there no sound in the game?  Why is the music playing from a different sound device than the game sounds?
A:You need to configure the sound and/or MIDI device.
  Run .\FF7Config.exe as Administrator
  In the SOUND tab, select the 'Sound Driver'
  In the MIDI tab, select the 'MIDI Driver' and the 'MIDI Data'
  Click OK to save the settings
  Open the Volume Mixer
  Adjust the volume for the playback device, applications and FF7 executable

Edge4o7

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Final Fantasy 7 sound effect problems
« Reply #2 on: 2012-12-14 17:32:22 »
>_<

I'm a little upset with my self because I saw that in the FAQ or whatever and I'm pretty sure I tried it. I don't even want to admit it but I might have pressed cancel instead of ok or something lol.

It worked though, thanks.


In other news, is there a way to fix this problem? When I set the volume for FF7Music on the Windows volume mixer, once I make FF7 my primary window again, the FF7Music goes back to the volume it was at previously. I've already turned the game down in ff7 config but this game is unbelievably loud and it makes talking with friends on vent while playing this game very frustrating.

PitBrat

  • No life
  • *
  • Posts: 1388
  • Karma: 12
  • Change to feed the machine.
    • View Profile
Re: Final Fantasy 7 sound effect problems
« Reply #3 on: 2012-12-14 22:47:46 »
FF7Music has a volume control in the configuration screen.
In the game folder, run .\FF7Music\FF7Music.exe as administrator.
Click on the CONFIGURE button.
Adjust the volume.
Save and exit.

On an unrelated note, I'm not sure what changed in Windows 7 just recently, but now I have a lot of problems with Windows switching the audio output device while I'm listening to music in Media Player and watching Youtube video simultaneously.

mystery_editor

  • Cool newbie
  • *
  • Posts: 71
  • Karma: 4
  • Mmm... Pi
    • View Profile
Re: Final Fantasy 7 sound effect problems
« Reply #4 on: 2012-12-15 03:01:39 »
It's to do with active outputs - I just disable all the ones I'm not currently using, and that seems to fix it. Otherwise, not 100% what the issue could be.

FF7 actually has a similar issue with switching inputs, where you have to change the default output ont he system as well as in FF7Config. Maybe a Windows 7 / Windows 8 issue only?