Author Topic: 7th Heaven setup but no mods work?  (Read 418 times)

Lune

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
7th Heaven setup but no mods work?
« on: 2017-12-30 14:40:25 »
So I have 7th Heaven all setup, downloaded catalogs, installed and configured mods, have them in the correct load order, etc.  I hit launch game at the bottom left and the game loads.  The game works correctly but none of the mods are loaded.  It is using the old character models, etc.  I've traced back through my steps and can't figure out what I did wrong.  I know something must be screwed up but I can't figure out what.  I can't even think of anything else to describe the issue as it is just as simple as that. 

Any ideas?

Lune

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: 7th Heaven setup but no mods work?
« Reply #1 on: 2017-12-30 15:06:57 »
I read another thread on a similar issue.  After looking back through some things I can see that my \mods\Textures folder is empty.  I'm not sure why because I followed the guide and have the Aali Modpath set to D:\FINAL FANTASY VII\mods\Textures.  My D:\FINAL FANTASY VII\mods\7th Heaven folder on the other hand has stuff in it. 

Also, the guide says to have "music" and "direct" listed under "Extra Folders".  I did that but it doesn't appear that 7th Heaven creates a music folder on it's own.  Do I need to create the folder?  I do have a D:\FINAL FANTASY VII\data\music folder but that only has like 5 files in it.  There is also a D:\FINAL FANTASY VII\data\music_ogg folder with 94 items in it. 

I'm not sure why 7th Heaven isn't putting stuff where it should or what I need to do to resolve it. 

UpRisen

  • Cool newbie
  • *
  • Posts: 70
  • Karma: 6
  • Again...Again... AVALANCHE is born again!
    • View Profile
Re: 7th Heaven setup but no mods work?
« Reply #2 on: 2017-12-30 19:39:41 »
in your ff7 directory there is a config file. open that file and scroll to near the bottom and find directmode= off and make it say directmode= on


Also if you are in doubt about your installation you can follow my tutorial video instead of the official one. Mine comes with a readme and is also voice which many find to be easier to follow than just reading. https://www.youtube.com/watch?v=cf7uQt2uaQc&t=57s
« Last Edit: 2017-12-30 19:41:33 by UpRisen »

Lune

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: 7th Heaven setup but no mods work?
« Reply #3 on: 2017-12-30 21:58:07 »
What is the name of the config file?

Lune

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: 7th Heaven setup but no mods work?
« Reply #4 on: 2017-12-30 22:33:25 »
Nevermind, I found it in your video.  Watched the whole thing.  Changed the config file as you say and that fixes the textures.  However, I am still wondering about the "music" folder.  I get an error every time I load 7thHeaven saying that the music folder cannot be found and that it is opening my settings window so I can fix it.  Still not sure what I need to do about that. 

Lune

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: 7th Heaven setup but no mods work?
« Reply #5 on: 2017-12-31 02:57:22 »
...and apparently I have no sound in my FMVs?...

Lune

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: 7th Heaven setup but no mods work?
« Reply #6 on: 2017-12-31 03:21:22 »
...and now without changing anything my game is no longer loading correctly.  It just goes to a black screen.  If I alt-tab out and back in the game comes up with no mods working. 

Well, I did do something.  I went to check to see if playing the movie files outside of the game had sound.  They didn't.  That is when they are playing with Windows Movie and TV player.  When playing them Windows Media player I have the same problem.  When playing with VLC player the sound works fine.  I tried changing my default program for avi files to VLC player and going into the game and this is what happened. 

evolvevil

  • Fast newbie
  • *
  • Posts: 13
  • Karma: 0
    • View Profile
Re: 7th Heaven setup but no mods work?
« Reply #7 on: 2018-01-05 00:27:11 »
in your ff7 directory there is a config file. open that file and scroll to near the bottom and find directmode= off and make it say directmode= on


Also if you are in doubt about your installation you can follow my tutorial video instead of the official one. Mine comes with a readme and is also voice which many find to be easier to follow than just reading. https://www.youtube.com/watch?v=cf7uQt2uaQc&t=57s

I followed all your instructions and my situation improved, but I couldn't get into the game because of lack of keyboard functionality. Also got no audio with or without music mod activated. Checked ff7 config setup thing but it reverted a bunch of the changes it looks like. Whoops. I get a beep when starting the game both with or without that though and still no keyboard functionality.
« Last Edit: 2018-01-05 01:29:30 by evolvevil »