Author Topic: [FF7PC-98] FF7Music Installer (1.51.13)(Discontinued, use Anxious Heart)  (Read 162769 times)

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #25 on: 2010-09-09 21:36:07 »
FF7Music Installer 1.51.2



Changes:
  • Desktop icon now launches FF7 and FF7Music together. Do NOT close the command prompt window, it'll close on its own when you're done playing. Also, it uses a higher quality icon than the one included with the game, seen above, (made by myself. I got my own permission to include it, don't worry).
  • Some behind-the-scenes fixes in the installer. Basically, I replaced a hacky workaround with some decent code. This shouldn't really be noticeable, but it won't leave a huge mess of unnecessary compatibility mode settings in your registry anymore. Settings made by previous versions of the installer remain, though.
  • Now gives the option of running FF7Music after install. This DOES NOT run the game automatically; this way you can choose between OGG and PSF soundtracks.
  • Major behind-the-scenes fixes in the uninstaller. Does a much better job cleaning up after itself than before, such as removing any compatibility mode settings that it changed. Again, settings from previous installer versions remain.

To-Do:
  • I forgot to update the readme again. When I do, I'll add an option to automatically open it after the install is finished. Probably also put it in the start menu. Until then, it's still in the install directory if you need it.
  • The installer adds the line "music_plugin = plugins/ff7music.fgp" to the end of your ff7_opengl.cfg. The uninstaller does not remove this line, so it still needs removed manually. You could easily end up with this line repeatedly if you run the installer multiple times. Not a HUGE deal, since I don't expect many people to uninstall FF7Music and go back to MIDI, but it's kind of wasteful, and I'd like to fix it.


Download: MEGAUPLOAD | MediaFire (7z) | PsycopathicStudios (Coming Soon)


edit: I have not tested this on Windows XP. If you run into errors, please let me know the nature of the problem, as well as what edition you're using (Home, Professional, or Media Center, it DOES make a difference).
« Last Edit: 2010-09-09 22:01:13 by Covarr »

old boss

  • Fast newbie
  • *
  • Posts: 37
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #26 on: 2010-09-13 06:47:20 »
i will test this on XP PRO and will report any bugs


EDIT: hi I have tested and unfortunately there are some problems the major one is that it made my game very slow [never happend before] the second problem that I found was also on the previous version whenever I quit the game I can't play again and have to restart my laptop
I hope I have been helpful and I also hope that u fix those bugs and I wish u luck on fixing them
« Last Edit: 2010-09-13 11:38:51 by old boss »

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #27 on: 2010-09-13 16:25:53 »
I'm sorry to hear that. I have a few ideas of what might be the matter, but I'll need your help to fix them because I don't have an XP system to test on. Could you please do the following?

  • After running FF7, without restarting your PC, right click on your taskbar and start the Task Manager. In the Processes tab, see if ff7.exe is listed. It may be easier if you sort by image name. Tell me the result.
  • Right click on the batch file on your desktop (should be titled Final Fantasy VII), and click edit. Copy what you see, and paste it into a reply, so I can double check what it says.

old boss

  • Fast newbie
  • *
  • Posts: 37
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #28 on: 2010-09-13 18:00:32 »
hi sorry it seems the slowing problem was my mistake yesterday i was playing with aali's custom driver and i raised the resolution too high and forgot to reset it so that leaves us with one bug now which is
Quote
the second problem that I found was also on the previous version whenever I quit the game I can't play again and have to restart my laptop
   ALSO i tried to run the game  itself without ffmusic and it still doesn't start  [i did so after using ffmusic and quitting]
now here is what u asked for covarr

1.  in the processes ff7 use approximately 95 of CPU and around 48,000 k of memory  ffmusic doesn't use any CPU but it use  around 5,500 k of memory [i assume u no longer need those since the problem was on my end  sorry]

2, this is what the batch has  [i copied this while the game was running]

Quote
start FF7Music.exe
ping localhost -n 2 > nul
CD C:\Program Files\Square Soft, Inc\Final Fantasy VII
start /w ff7.exe"
tskill FF7Music


that's all i hope this helps and please tell me if i could help in any way i would be glad to
« Last Edit: 2010-09-13 18:04:36 by old boss »

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #29 on: 2010-09-13 18:05:58 »
And this is AFTER quitting the game? I should have specified that before. What's probably going on, as far as I can tell, is that it's not quitting properly (a fairly common problem with FF7, IIRC). I think what I'm going to have to do is add a line in the batch file that quits it if it's still open before it tries to run the game again.

old boss

  • Fast newbie
  • *
  • Posts: 37
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #30 on: 2010-09-13 18:14:52 »
yes it's after quitting the game  and when i click run FF7 the pointer turns to the waiting icon for three secs and then nothing happens  ,  am going to try and check if the second bug is on my end or in the installer by restarting my laptop and playing ff7 from the .exe without touching ffmusic and then quit and try to play again to insure if the bug is from ffmusic or not
so give me a few minuets to check that out

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #31 on: 2010-09-13 18:44:16 »
Yeah, I've seen that problem before. I'm not entirely sure what causes it, but I think it's compatibility mode; Win98 compat mode on FF7 doesn't play nicely with XP. Could you try disabling compatibility mode for FF7 and see if FF7Music still works? It's definitely required on Vista and 7, but I might have it not set compatibility mode on XP if it's unneeded and prevents this problem.

In the meantime, if it's not closing properly, you can always end the process in the Task Manager. It won't mess anything up if you've already saved and quit before doing so.

old boss

  • Fast newbie
  • *
  • Posts: 37
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #32 on: 2010-09-13 19:15:07 »
THAT WAS IT !!! The windows 98 compatblty was the problem now It works wonderfully  [all of the bugs were on my end weren't they ? "sigh"] thanks covarr I will countnue using ffmusic and will report any bugs if any is found
And if there is anything else u need just let me know I would be glad to help

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #33 on: 2010-09-13 19:38:12 »
Okay then, I'll have it check for WinXP and not set a compatibility mode in future versions.

pyrozen

  • Freak
  • *
  • Posts: 793
  • Karma: 0
  • Team Avalanche Member
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #34 on: 2010-09-13 23:56:37 »
wanted to give props to everyone who helped in putting this together. I have been apprehensive of FF7music due to the long list of problems, but with the ogg loops and covaars installer, i finally jumped in. The quality is amazing, and aside from a few tiny pauses before some tracks this mod is flawless! I would consider this a must have for anyone replaying FF7, it beats any soundfonts available.

great job!

xarfax1105

  • Guest
Re: [RELEASE] FF7Music Installer
« Reply #35 on: 2010-09-22 12:38:11 »
Downloaded the mediafire ones, (ff7music_install_1512.7z.002 and ff7music_install_1511.7z.002) needless to say i wasn't able to open the archive for the installer... I'm currently downloading the MU one though xD

Hellbringer616

  • No life
  • *
  • Posts: 1915
  • Karma: 12
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #36 on: 2010-09-22 13:39:09 »
downloaded, installed without a hitch on win7 x64, have to go to work so i can't test it. I'll post feedback when i get home.

See if it sounds better then soundfonts with my soundcard :D

Tyler_Wu

  • Cool newbie
  • *
  • Posts: 64
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #37 on: 2010-09-22 14:07:43 »
I have spent a decent amount of time searching for the answer... forgive me for failing to find it.

I have ff7 music working perfect, and phoenix rejuvenation project also working fine.

BUT I don't know how to have BOTH working at the SAME TIME.

FF7 music has its own icon on the desktop to make it work and start up with the game  but so does the ff7-prp,  how can I have both at the same time?

Or do I have to choose between updated models and updated music?

Thanks in advance.

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #38 on: 2010-09-22 18:45:37 »
Unfortunately, I'm not terribly familiar with PRP. I wasn't aware that you needed to start with their icon to make it work.

If you must use their icon, there's still a solution: Open FF7Music from the start menu. This will NOT automatically start the game, just FF7Music. Then you can start it from the PRP icon.

Tyler_Wu

  • Cool newbie
  • *
  • Posts: 64
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #39 on: 2010-09-22 19:18:11 »
Wow, well i feel dumb, for some reason I assumed the only way to have ff7 music working was to use the icon on the desktop.

Thanks for the help.

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #40 on: 2010-09-22 22:31:08 »
The icon on the desktop is just a shortcut to launch FF7Music and FF7 together, to make things a bit quicker and easier. It's still possible to launch them separately.

I may stick a FF7Music icon on the desktop as well in the next version, not entirely sure yet though.

Tyler_Wu

  • Cool newbie
  • *
  • Posts: 64
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #41 on: 2010-09-24 20:44:47 »
So I have a problem.  When playing ff7, with ff7 music the music (finalfantim's) in game sounds a little funny.  its hard to explain, its like its slow or something.  almost like it stutters or like i have my two headphones or speakers on and they are both playing the same music but 1 speaker is  half a second behind/slower than the other speaker. 

NOTE: When im using  finalfantims music with windows media player (not in game)  the music sounds perfectly fine, its only when it plays the music in final fantasy 7 that it gets all weird/garbled... not very bad or anything though.

im using windows vista, its a pretty new computer, in ff7 config for sound driver it says im using sigmatel high definition audio codec.  and under midi driver it says microsoft gs wavetable  synth then under midi data it says yamaha xg midi. 

if there is any other info i can give to be helpful let know.

i would love to be able to fix the music so its not garbled together anymore.

also should mention,  in ff7 music it says my input plugin is C:\FF7Music\in_vgmstream.dll and my output plugin is C:\FF7Music\out_wave.dll

i have no idea if any of that matters but i want to give as much info as possible so i can fix this problem.
« Last Edit: 2010-09-24 20:51:01 by Tyler_Wu »

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #42 on: 2010-09-24 21:02:28 »
That's weird. In FF7Music settings, for the output plugin settings, try increasing the buffer. It'll create a bit more of a delay before a song starts, but it can also fix weird issues like this.

Tyler_Wu

  • Cool newbie
  • *
  • Posts: 64
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #43 on: 2010-09-24 21:55:24 »
Thanks, I did what you said and it definitely sounds better BUT its still kinda weird. Like when i get in a battle you hear the song play twice. like it starts when it should normally start but then the music starts a 2nd time on top of the 1rst time. like im playing two songs at the same time but i started one a half second before starting the 1rst.

if i increase the buffer to the max (20 000) can it cause any problems?


edit: pyrozen  where it says mute midi on custom playback it is checkmarked yes... unless you are referring to somewhere else.
« Last Edit: 2010-09-24 22:21:58 by Tyler_Wu »

pyrozen

  • Freak
  • *
  • Posts: 793
  • Karma: 0
  • Team Avalanche Member
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #44 on: 2010-09-24 22:06:05 »
are u sure you turned off MIDI playback? If you didn't it would cause issues like this

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #45 on: 2010-09-24 22:34:03 »
You may have upgraded Aali's driver since installing this. In which case, find "ff7_opengl.cfg", and make sure that the line "music_plugin = plugins/ff7music.fgp" doesn't have a # at the start.

Tyler_Wu

  • Cool newbie
  • *
  • Posts: 64
  • Karma: 0
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #46 on: 2010-09-24 22:56:38 »
Alright It did have a number sign in front of it so i deleted it...


the problem didnt go away,  AND now my sound affects arent working at all in ff7

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3871
  • Karma: 113
  • The Great Redarr.
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #47 on: 2010-09-24 23:10:30 »
First, open ff7config to make sure that the OpenGL driver is selected. Then, if it already is, or if that doesn't work, try choosing out_ds.dll for your output plugin.

(I admit, I have no idea what the hell is going on, I'm just kind of grasping at straws).

obesebear

  • Administrator
  • No life
  • *
  • Posts: 3217
  • Karma: 109
    • View Profile
Re: [RELEASE] FF7Music Installer
« Reply #48 on: 2010-09-25 00:48:31 »
Search around for a post I made a while back to help with FF7 music.  Somewhere in there is an uploaded midi.lgp file where all of the volume on them has been turned off.  Use that and your sound effects should all come back.

delpo

  • Guest
Re: [RELEASE] FF7Music Installer
« Reply #49 on: 2010-09-25 01:18:36 »
The installer has worked wonders for me except my game always freezes up right when I am about to go against Dyne.  The game just freezes with a really short loop of the wind sound, and it says on the bottom of the screen, error: could not read file wind.wav in C://etc...

This also happens in other areas where the wind music plays, and there seems to be a problem of both the wind music and background music playing at once.  However, in the other areas the game does not freeze.

I tried reinstalling ff7music but the same problem occured.

Any help is greatly appreciated.