Author Topic: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions  (Read 245598 times)

Vgr

  • Global moderator
  • No life
  • *
  • Posts: 2209
  • Karma: 33
  • If it quacks like a duck, it must be a duck
    • View Profile
Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« on: 2011-06-18 21:16:16 »
Support and suggestion thread for Aali's Custom Graphic Driver 0.7.11b

EDIT: Read the FAQ below before posting to see if your issue has been resolved!

I have stickied this thread - Bosola

Post your config file and APP log when reporting an error! We cannot help you if you don't! Also make sure you have latest version before reporting an error.



Edit (July 1st, 2013): Added a FAQ section for people to look for answers. Will be updated on request and on need.
Edit (July 2nd, 2013): Updated the FAQ. (Thanks to Kompass63 for pointing some things out!)
Edit (August 11th, 2013): Changed a few things here and there. Updated the FAQ.

Frequently Asked Questions:

Help topics covered: Popups - Posting errors - Help with code tags - Finding necessary files - Black bar - Disabling shaders - Textures fail to load - NVIDIA cards problems - Older patches problems - General help - Downloaded game - Everything is made of light - Running as administrator



Popups

Q: How to disable/hide those yellow and red popups at the bottom of the screen?
A: Add "disable_popup = yes" at the bottom of ff7_opengl.cfg (alternatively, you can try "disable_popup = on" or "disable_popup = true").



Posting errors

Q: Aali's driver doesn't seem to be working! What do I do?
A: First make sure you have the latest version (Current version is 0.7.11b). Then, make sure the driver is working by clicking FF7Config and then the Graphics tab. Select "Custom Driver" if that's not already the case. If the driver is installed, a popup will appear. Then, use the following form:

Use code tags and post your config file (ff7_opengl.cfg OR ff8_opengl.cfg) like this:

[ code ] Paste all your config here [ /code ] (Remove the spaces inside the brackets)

Then, post your APP.log that lies inside your FF7 folder (only relevant if you launched the game at least once) like this:

[ code ] Paste all your APP.log here [ /code ] (Remove the spaces inside the brackets)

Don't forget to specify if it said if it was installed or not.



Help with code tags

Q: I don't understand how to make this code thing work!
A: You can click on the '#' button (At the top of your post, not the key on your keyboard) to make code tags appear in your post where your cursor is. You can also select all the text that goes inside the code tags and click the '#' button.



Finding necessary files

Q: Where can I find those files you talk about? (config and APP log files)
A: In the main Final Fantasy VII/VIII game folder (FF8 creates an APP.log file, but it will be blank).



Black bar

Q: There's a black bar at the bottom of my screen when moving around in field! Help!
A: It is normal. It goes away in battle and menus. It goes back to the old PSX days. Some things are programmed based on coordinates, and removing the black bar would cause issues.



Disabling shaders

Q: I experience some problems/crashes and I don't know what causes it!
A: Turn off shaders ("use_shaders = no" in the config file) or use the "Everything is made of light" fix (see below). If that doesn't fix it, try disabling fancy transparency ("fancy_transparency = off" in the config file). If that still doesn't work, post your config and APP log files using the method described above.



Textures fail to load

Q: FF7 was installed and I played it for some time, now I tried to add a new texture and it doesn't load! What do I do?
A: Delete the files from the cache folders:

.\Final Fantasy VII\cache
.\Final Fantasy VII\mods\cache

Don't forget the virtual store:

   32BIT
     C:\Users\[USERNAME]\AppData\Local\VirtualStore\Program Files\Square Soft, Inc\Final Fantasy VII
   64BIT
      C:\Users\[USERNAME]\AppData\Local\VirtualStore\Program Files (x86)\Square Soft, Inc\Final Fantasy VII

Credits go to PitBrat and Kompass33



NVIDIA cards problems

Q: The game crashes and I don't know why. I have an NVIDIA card.
A: The driver has trouble with newer NVIDIA drivers. Disable your shaders (see above) or use the "Everything is made of light" fix (see below). It has been fixed for the next release



Older patches problems

Q: I used The SaiNt's Hi-Res patch with or without Aali's custom driver but it doesn't work well!
Q: I used the FF8 Launcher with or without Aali's custom driver but it doesn't work well!
A: Those patches are outdated. Uninstall them and use Aali's custom driver alone.



General help

Q: HEEEEEEELP!!!!!!!!!!1111oneoneone
A: Did you try reinstalling the game and the driver? Do you have the latest graphic drivers? Did you try fiddling with the options? Try experimenting on your own, it often wields better results.



Downloaded game

Q: I downloaded FF7/FF8 from the Internet and the driver doesn't work!
A: Save yourself some trouble and don't bother posting. Pirated games are not supported.



Everything is made of light

Q: My game is all black/white! It goes away when I disable shaders, but I don't want to! What do I do?
A: In your FF7 directory, copy and replace the files .\shaders\main.frag and .\shaders\main.vert into .\shaders\nolight\ (however, the shaders need to be enabled for this to work!) or you can download the shaders-fix (thanks to UGerstl for this).

Credits go to Xion999, Kompass33 and UGerstl.



Running as administrator

Q: The game works but some things don't. I am on Vista or newer.
A: You need to run the game as administrator.

Q: How to run the game as administrator?
A: Right-click FF7.exe > Properties > Compatibility > Run this program as administrator.



If you feel like I forgot something, this list needs updating, there's an error or you simply need something to be changed, reply to this thread or send me a PM/email (I am more likely to see those than a reply).
« Last Edit: 2013-08-11 17:55:15 by Vgr »

Terid__K

  • Insane poster
  • *
  • Posts: 387
  • Karma: -3
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #1 on: 2011-06-18 21:27:01 »
Might as well post this here:


New version of the driver (0.7.11b) broke FF7 for me. The special effects in-battle are all missing, plus there's a slowdown before they appear. App.log doesn't say anything useful.

FF8 does not have this problem, but I got stuttering on movie playback. This didn't happen in 0.7.10b.

Here's the App.log for it:

Code: [Select]
INFO: FF7/FF8 OpenGL driver version 0.7.11b
INFO: Auto-detected version: FF8 1.2 US English (Nvidia)
INFO: NVIDIA Corporation GeForce GTX 260/PCI/SSE2 3.3.0
INFO: OpenGL 2.0 support detected
INFO: Found swap_control extension
INFO: Max texture size: 8192x8192
INFO: Number of texture units: 4
INFO: Original resolution 640x480, window size 1366x768, output resolution 1024x768, internal resolution 1280x960
INFO: FBO extension detected, using fast scaling/postprocessing path
INFO: Shader limits: varying 60, vert uniform 4096, frag uniform 2048
MATRIX INITIALIZE
INITIALIZING SOUND...
  initializing direct sound
  EAXDirectSoundCreate
  creating primary buffer
  initializing audio data
  OK
  initializing streaming
SOUND INITIALIZED
DIRECT MUSIC - Enumerating Ports...
PORT 0: SB X-Fi Audio [0001]
GUID={0x490a03e8,0x742f,0x11d2,0x8f,0x8a,0x0,0xc0,0x4f,0xbf,0x8f,0xef}
PORT 1: Mapeador de MIDI da Microsoft [Emulado]
GUID={0x81192e03,0xc5db,0x403f,0x89,0xb5,0x32,0x4e,0xe4,0x2c,0x66,0x47}
PORT 2: Sint. softw.tab. sons wave MS G [Emulado]
GUID={0xe0f83cf,0xe264,0x4f03,0x83,0xbb,0x36,0x19,0x21,0x32,0xfc,0x83}
PORT 3: SB X-Fi Synth A [0001] [Emulado]
GUID={0x4c7ba8bd,0x190c,0x4603,0x87,0xf1,0x9b,0x7d,0x7e,0x37,0xd2,0xe1}
PORT 4: SB X-Fi Synth B [0001] [Emulado]
GUID={0xb475d800,0xd2d2,0x4dd5,0x8a,0xc7,0x8b,0x52,0xdc,0x17,0x87,0x66}
PORT 5: Microsoft Synthesizer
GUID={0x58c2b4d0,0x46e7,0x11d1,0x89,0xac,0x0,0xa0,0xc9,0x5,0x41,0x29}
Creating Port1...
    SB X-Fi Audio [0001]
  Port1 supports XG data
BinkClose
GLITCH: missed palette write to external texture data/eng/menu/icon
SdMusicPlay ()
sd_music_play (number=0, song_id=79, volume=0)
midi_play...
Stopping Performance
Loading DLS...
Playing Segment
midi_play successful
MIDI stop
SdMusicPlay ()
sd_music_play (number=0, song_id=41, volume=0)
midi_play...
Stopping Performance
Playing Segment
midi_play successful
SdMusicPlay ()
sd_music_play (number=0, song_id=5, volume=127)
MIDI stop
midi_play...
Stopping Performance
Playing Segment
midi_play successful
GLITCH: unsupported texture format
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
BdLinkTask: FAILED !!!!
MIDI stop
sd_music_play (number=0, song_id=41, volume=127)
midi_play...
Stopping Performance
Playing Segment
midi_play successful
WM_CLOSE

Releasing Performance...


Releasing Loader...


Releasing Port1...


Releasing DirectMusic interface...

Releasing COM...


Going back to 0.7.10b for now.

EDIT: The slowdown/stuttering was due to not using pbo. Effects are still missing in FF7 though.



« Last Edit: 2011-06-18 21:43:01 by TeridKane »

Aali

  • Moderator
  • No life
  • *
  • Posts: 1194
  • Karma: 108
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #2 on: 2011-06-18 21:50:56 »
FF7 seems to be broken, yes, taking down the download for now.

Nothing should have changed regarding FF8 movie playback? Works fine here.

:EDIT:

Download is back up, some testing stuff accidentally made it in the release, should be working now. Redownload if you got the broken version.
« Last Edit: 2011-06-18 22:03:13 by Aali »

Terid__K

  • Insane poster
  • *
  • Posts: 387
  • Karma: -3
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #3 on: 2011-06-18 21:53:42 »
Nothing should have changed regarding FF8 movie playback? Works fine here.

Yes, I've edited my post to include that the stuttering was due to having pbo disabled. Turning it on fixed that (I'm using the altered FF8 GUI).




DLPB

  • No life
  • *
  • Posts: 8481
  • Karma: 231
  • This rose will never die This rose will never die
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #4 on: 2011-06-18 22:03:18 »
 :-D  tut tut aali.  I may have broken the universe but I didn't break my own driver.  :evil:

Terid__K

  • Insane poster
  • *
  • Posts: 387
  • Karma: -3
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #5 on: 2011-06-18 22:13:08 »
Alright, seems to be working fine now.



Template

  • Freak
  • *
  • Posts: 861
  • Karma: 17
  • Life is a series of cats.
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #6 on: 2011-06-19 04:10:30 »
From the legacy ATI camp, was surprised to find that turning pbo on did not cause any problems for my x800 XT p4 system FF7 build. The new release runs fine where the .10b version did not for some other reason I guess? Unfortunately I am still unable to run DLPBs FMV restoration at full speed in game, though that certainly isn't the end of the world.

Comparing to the .09b driver I had been running the worldmap looks much nicer. I guess the Anti-aliasing kicked on, or something.

Thanks ever so much for the continued work on your driver Aali, its brought me countless hours of fun.

I'm surprised too, but my ATI system is running this latest driver release with both texture compression and PBO on. Looks great and seems to be running faster now. I wish it would go make me a sandwich.

ninja edit: nvm texture compression on worked fine til I unleashed a mighty Cross-cut and then I got some weird artifacts in the animation. so far PBO on and texture compression off working fine under testing.
« Last Edit: 2011-06-19 10:04:05 by Template »

philman

  • Crazy poster
  • *
  • Posts: 127
  • Karma: 2
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #7 on: 2011-06-19 05:43:55 »
I have used this version,good work Aali,i don't have shaders problem anymore and black bar is removed in battle and when playing movies.

but when i updated graphics driver to 0.7.11b the songs are playing directly from midi.lgp,somebody have any idea how to fix it to use with FF7 music?

EDIT: Sorry,i remember i should remove the # in ff7_opengl.cfg to music work,problem fixed.
« Last Edit: 2011-06-19 16:29:14 by philman »

Aali

  • Moderator
  • No life
  • *
  • Posts: 1194
  • Karma: 108
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #8 on: 2011-06-19 09:08:16 »
PBOs work fine on most ATI cards as long as you dont use texture compression. If that is working for you aswell I will be positively surprised :P

As you can see from the changelog, AF (Anisotropic filtering), or any filtering at all for that matter is now turned on for any worldmap mods which will make it look alot less pixelated.

Terid__K

  • Insane poster
  • *
  • Posts: 387
  • Karma: -3
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #9 on: 2011-06-19 16:34:48 »
Something weird I noticed in FF8 is that when the characters are having a long conversation, if one of them blinks during it his/her eyes might remain shut until the conversation is over.

I'm not sure if it's a problem with the driver, but I don't remember this happening in my previous playthroughs without it.

Also, I'm often getting the message "GLITCH: unsupported texture format", and occasionaly a message like "Can't open file: \ff8\data\eng\field\mapdata\do\dotown_1\dotown_1.sfx " (This path doesn't even exist).

I don't notice anything missing during gameplay despite those messages. Battles are working just fine (battle swirl and all).





« Last Edit: 2011-06-19 16:42:37 by TeridKane »

Timbo

  • Guest
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #10 on: 2011-06-19 16:48:22 »
can someone please tell me why full screen isn't working?

Code: [Select]
# mod directory
# subdirectroy of mods/ where textures will be loaded from
# does not affect the old external textures feature, those should still go in textures/
mod_path = none

# use shaders, if available and supported
# turn shaders off to use the OpenGL 1.1 backend
use_shaders = yes

# plugins
# a movie plugin is required, the music plugin is optional, but required to make FF7Music work
movie_plugin = plugins/ffmpeg_movies.fgp
#music_plugin = plugins/ff7music.fgp

# vertex and fragment shaders
vert_source = shaders/main.vert
frag_source = shaders/main.frag

# YUV fast path shader
yuv_source = shaders/yuv.frag

# post-processing shader, used to apply fullscreen effects
post_source = shaders/bloom2.post
enable_postprocessing = no

# display frames per second counter in upper right corner
show_fps = no

# display some real-time debug information
show_stats = no

# set the window size (and fullscreen resolution) of FF7
# 0 means use original resolution (whatever ff7.exe provides)
# preserve_aspect adds black borders as needed to preserve a 4:3 aspect ratio
window_size_x = 1600
window_size_y = 900
preserve_aspect = yes
fullscreen = yes

# prevent glitches due to rounding errors by rendering in the nearest (larger, if supported)
# multiple of the original resolution and up/down-scaling
prevent_rounding_errors = yes

# check your driver settings if this option doesn't seem to work
enable_vsync = yes

# limit snowboard, coaster and highway minigames to refresh rate / 2, i.e. 30fps for a 60hz display mode
# vsync must be enabled and working for this to have any effect
minigame_framelimiter = on

# same thing, but for the battle swirl
battleswirl_framelimiter = off

# replace FF7's default framelimiter timer source
use_new_timer = yes

# use a more stable (but less accurate) timer to control FF7's framelimiter
# this option has no effect unless the use_new_timer option is on
use_stable_timer = no

# allow FF7 to use linear filtering for its textures
# some things look slightly better with this option on, but alot of textures just lose their detail
linear_filter = off

# make all dialog boxes transparent, same effect as the transparent dialog boxes YAMP patch
transparent_dialogs = off

# allow max hp/mp to go over 9999, same effect as the YAMP patch by dziugo
break_9999limit = no

# include armor in magic defense calculation
mdef_fix = yes

# expand battle viewport to cover entire screen and make the battle menu transparent
new_battle_interface = off

# enable alpha blending for textures without an existing blending effect
fancy_transparency = on

# store external textures in a compressed cache for increased performance
# compression is not lossless, some artifacts may appear when this option is in use
# texture cache does NOT update automatically if the source image changes, however, deleting anything from the cache
# will cause that file to be recreated from the source
compress_textures = yes

# read files directly instead of using LGP archives
# for example; if FF7 is looking for aaab.rsd in char.lgp, this option will make it open direct/char/aaab.rsd first,
# if this file doesn't exist it will look for the original in the LGP archive
# this option should be used for testing only, performance will take a hit
direct_mode = off

# show every failed attempt at loading a .png texture
# this option is for modders only, it's useful to find out which texture to replace and which palettes it needs
show_missing_textures = no

no matter what i change x&y to, it always runs in the default resolution

edit: nvm - i'm an idiot. i was running it in win95 compatibility mode. unchecked that and it works fine -_-
was getting ready to rage my monitor out the window. there goes about an hour and a half of my life
« Last Edit: 2011-06-19 16:57:24 by Timbo »

Aali

  • Moderator
  • No life
  • *
  • Posts: 1194
  • Karma: 108
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #11 on: 2011-06-19 17:08:15 »
Something weird I noticed in FF8 is that when the characters are having a long conversation, if one of them blinks during it his/her eyes might remain shut until the conversation is over.

I'm not sure if it's a problem with the driver, but I don't remember this happening in my previous playthroughs without it.

Also, I'm often getting the message "GLITCH: unsupported texture format", and occasionaly a message like "Can't open file: \ff8\data\eng\field\mapdata\do\dotown_1\dotown_1.sfx " (This path doesn't even exist).

I don't notice anything missing during gameplay despite those messages. Battles are working just fine (battle swirl and all).

The blinking thing might be an oversight in the optimizations I did for 0.7.10b but I can't tell off the top of my head why that is happening.
The unsupported texture format bit is just something I forgot to hide away, its odd that FF8 behaves that way but its perfectly normal.
FF8 likes to complain about certain .sfx files sometimes, I dont know if its really supposed to happen but its normal.

Gamecollector

  • Guest
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #12 on: 2011-06-19 21:31:53 »
Ati X850PE Agp with Catalyst 7.11 - no shaders with 0.7.11:

App.log:
Code: [Select]
INFO: FF7/FF8 OpenGL driver version 0.7.11b
INFO: Auto-detected version: FF7 1.02 US English
INFO: ATI Technologies Inc. RADEON X850 Series x86/SSE2 2.0.7058 WinXP Release
INFO: OpenGL 2.0 support detected
INFO: PBO not supported
INFO: Found swap_control extension
INFO: Max texture size: 2048x2048
INFO: Number of texture units: 8
INFO: Original resolution 640x480, window size 1024x768, output resolution 1024x768, internal resolution 1280x960
INFO: FBO extension detected, using fast scaling/postprocessing path
INFO: Shader limits: varying 44, vert uniform 4096, frag uniform 4096
INFO: vertex shader compile log:
ERROR: 0:1: '' :  Version number not supported by GL2
ERROR: 1 compilation errors.  No code generated.


INFO: fragment shader compile log:
ERROR: 0:1: '' :  Version number not supported by GL2
ERROR: 1 compilation errors.  No code generated.


INFO: main program link log:
 Link failed. All shader objects have not been successfully compiled.
ERROR: failed to load shaders, reverting to fixed function
INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: No shaders, codecs with YUV output will be slow.
LOCK UNLOCK TEST
MATRIX INITIALIZE
INITIALIZE DD/D3D END
initializing sound...
creating dsound primary buffer
reading audio file
loading static sounds
sound initialized
INITIALIZING MIDI...
selecting device 0:SoundMAX WDM MIDI, mid=1, pid=102,
midi data type: YAMAHA XG MIDI
using midi data file: F:\Program Files\Square Soft, Inc.\Final Fantasy VII\Data\midi\xg.lgp
midiOutGetVolume returned: ffffffff
MIDI INITIALIZED
set music volume: 127
MIDI set volume: 127
100% of 127 = 127
set music volume: 127
MIDI set master volume: 100
MIDI set volume: 127
100% of 127 = 127
Entering MAIN
Exiting MAIN
START OF CREDITS!!!
INFO: J:\FF7\Movies\eidoslogo.avi; truemotion2/pcm_u8 320x240, 15.000000 FPS, duration: 10.133333, frames: 152
INFO: J:\FF7\Movies\sqlogo.avi; truemotion2/pcm_u8 320x224, 15.000000 FPS, duration: 14.533333, frames: 218
WM_CLOSE
END OF CREDITS!!!
Field Quit
MIDI stop - OK
resetting MIDI driver volume - OK
UNINITIALIZE DD

With nolight shaders - the same issue.

Aali

  • Moderator
  • No life
  • *
  • Posts: 1194
  • Karma: 108
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #13 on: 2011-06-19 21:59:13 »
Your graphics card/drivers is just too old to support those shaders. Nolight shaders are used by default so whatever you did to them its no wonder that didn't fix anything. Fortunately, the game works just as well without shaders.

Vgr

  • Global moderator
  • No life
  • *
  • Posts: 2209
  • Karma: 33
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #14 on: 2011-06-19 23:49:31 »
For anyone to know, about these weird paths that doesn't exist, here's what they mean (and this has nothing to do with the driver) : Inside the .fs files, there are "paths" which start by /ff8/[language]/ and so the game looks for these paths... which means these weird messages. Use Garden if you're insure.

DLPB

  • No life
  • *
  • Posts: 8481
  • Karma: 231
  • This rose will never die This rose will never die
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #15 on: 2011-06-20 00:07:10 »
Critical hit white flash is not displaying, and there is a black area which displays when the battle is fading out, over the bottom part of the screen.

These are linked to the changes you have made to extend the critical hit/screen flashes to the bottom of the screen.

Xion999

  • Guest
Re: Custom graphics driver for FF7/FF8 [v0.7.10b]
« Reply #16 on: 2011-06-20 01:24:30 »
Sorry if this thread is supposed to be posted to by Aali only, but I have something important to add.

For Aali's driver v0.7.10b and up, newer Nvidia drivers do not use the shaders properly, causing this 'everything is made of light' effect.

The problem seems to lie in the no light shaders he introduced in v0.7.9b for users receiving an error that shaders were not loading. They are apparently already included in v0.7.10b+, and load automatically. For those experiencing this issue, simply remove the files in /shaders/nolight (you will receive a harmless error on startup--to remove this error, copy the regular shaders into the nolight folder) so the regular shaders are loaded. This solved my problem 100% and I thought it was important enough to post here.

Moderators: Please move to the right location if necessary. Thanks!

walkinghawking

  • Fast newbie
  • *
  • Posts: 23
  • Karma: 3
  • Weapon killer
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #17 on: 2011-06-21 10:54:39 »
EDIT:  Nevermind, just realized that shaders are broken on NVIDIA cards, not fancy transparency  :-X
« Last Edit: 2011-06-21 11:04:50 by deepdespair »

Twiggy000b

  • Guest
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #18 on: 2011-06-22 02:09:20 »
I know this is probably plagiarism... or something bad but i fixed the "ff7_opengl-0.7.11b" file and fixed a few other issues that i have had with NVIDIA drivers, and laptop issues as well. And no... I did not have permission from Aali... But hopefully he will ask for help or thank me for letting everyone else bask in the pleasure of the new ff7_opengl-0.7.11b+" version. Note the "+".

I'll let everyone figure out what was fixed and added. movies are no longer buggy or sluggish. thats all im saying :?: (I did get the idea from Xion999. But not all the fixes were his.just the bright light i was getting at the main menu. Lets just say i REFUSED to go any further til that issue was fixed xD!!!)

Link removed. <--- ff7_opengl-0.7.11b+

You actually do need to get his permission before releasing his work as your own.
« Last Edit: 2011-06-22 03:21:40 by Obesebear »

Vgr

  • Global moderator
  • No life
  • *
  • Posts: 2209
  • Karma: 33
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #19 on: 2011-06-22 02:16:11 »
From what I can tell... Take it down.

DLPB

  • No life
  • *
  • Posts: 8481
  • Karma: 231
  • This rose will never die This rose will never die
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #20 on: 2011-06-22 02:18:18 »
 ;D  you can't go releasing someone elses driver as your own haha

edit: and thats the exact same driver btw. Nothing has been changed.
« Last Edit: 2011-06-22 02:28:15 by DLPB »

Vgr

  • Global moderator
  • No life
  • *
  • Posts: 2209
  • Karma: 33
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #21 on: 2011-06-22 02:28:29 »
It's not even a fix. Files are identical.

LIEEEEEEEEEEEEEES!

Soul XXcult

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 1
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #22 on: 2011-06-22 08:33:56 »
Got an issue when I extract all the files to my ff8 folder it won't launch ff8.exe but instead there was a white blank screen ? is there any ways to fix this
« Last Edit: 2011-08-06 08:35:11 by Soul XXcult »

Terid__K

  • Insane poster
  • *
  • Posts: 387
  • Karma: -3
    • View Profile
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #23 on: 2011-06-23 02:50:00 »
So, I was fooling around in FF8 at the Tomb of the Unknown King when a pretty nasty glitch happened:







This happened sometimes when I switched from one background to another. If I brought up the menu, it would return to normal.




Twiggy000b

  • Guest
Re: Aali's driver [v 0.7.11b] Help/Bugs/Suggestions
« Reply #24 on: 2011-06-24 00:26:50 »
Ahh, i didnt know if i had to or not. thats ok. it seems i didnt pack the right files anyway lol. sorry bout that. didnt wanna seem like a bad guy taking someone elses work. :/