Author Topic: Problems upscaling FF7 field Textures  (Read 629 times)

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Problems upscaling FF7 field Textures
« on: 2017-07-17 20:28:03 »
I have been sifting through the forums on here and trying to upscale and improve the FF7 field textures to suit my tastes. I have ran into two problems:

1. I open ancnt1.lgp in palmer editor, I extract the PNG files and get the 6 or so layers for that background, I open the files in Corel Paint shop Pro X and paste and align all the layers into one image (everything fine so far). Now here's where I hit my first problem After I edit/resize the texture when I try to save the PNG with all 6 or so layers Paint shop will not save the PNG as a layered image it forces the PNG to be saved as a merged image.

2. I assume that the merged image is ok to use. So I open ancnt1.lgp again in palmer editor and choose import PNG, my new merged PNG is imported and everything seems fine. Now I hit the second problem with i choose create modpath textures in palmer editor, even though my imported png is 2048x2048 palmer editor save the modpath texture as 256x256. Is this normal? and am I just supposed to resize the new modpath texture to 2048x2048 again??

Any help would be appreciated, been tearing what little hair I have left out over this lol

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: Problems upscaling FF7 field Textures
« Reply #1 on: 2017-07-17 22:45:38 »
Okay so I made some progress. I now know what was wrong, every extracted layer has to be edited individually and placed together in a separate folder before palmer will import the PNG's. So now I can successfully import my upscaled/edited pngs with palmer and the modpath textures are exported in 1024x1024 as should be.

The problem I now have is that even choosing magnify only in Waifu2x to upscale the field textures makes a very slight green outline round the separate layers when you zoom in with palmer editor. Is this normal?? Or do I have to tweak some settings in waifu2x???? Anyone? Surely someone must know?

Grimmy

  • Insane poster
  • *
  • Posts: 476
  • Karma: 22
  • Only one man is exempt from my disgust.
    • View Profile
    • GrimmyGames
Re: Problems upscaling FF7 field Textures
« Reply #2 on: 2017-07-18 16:21:22 »
Use the full composite image(upscaled same as other layers) for the base layer which is where the green/red are usually.

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: Problems upscaling FF7 field Textures
« Reply #3 on: 2017-07-18 18:47:04 »
For the ancnt1 field there is no full image only six "jigsaw pieces" that all fit together to make the "composite image". Should I paste all the pieces together to make a whole image to use?

Grimmy

  • Insane poster
  • *
  • Posts: 476
  • Karma: 22
  • Only one man is exempt from my disgust.
    • View Profile
    • GrimmyGames
Re: Problems upscaling FF7 field Textures
« Reply #4 on: 2017-07-18 19:04:29 »
Yes. Use that full image as the base layer, but don't include any of the lighting effect layers for the full composite image.

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: Problems upscaling FF7 field Textures
« Reply #5 on: 2017-07-18 19:14:26 »
Ok thanks I will give it a bash

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: Problems upscaling FF7 field Textures
« Reply #6 on: 2017-07-18 19:46:14 »
Got rid of the green outline using this method but it has now been replaced with an outline of little speckled pixels. Back to the drawing board I guess

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: Problems upscaling FF7 field Textures
« Reply #7 on: 2017-07-18 19:54:55 »
Got it working now. The problem is with Waifu2x caffe. I just upscaled the same PNG in Corel Paint shop pro and now it has imported fine with no pixelated speckles

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: Problems upscaling FF7 field Textures
« Reply #8 on: 2017-07-18 20:11:01 »
Scratch that the PNG looksfine with no displacement at all in Paint shop but as soon as I import it to Palmer Editor the lines between the layers are slightly misaligned and have speckled pixels around them. I give up man, I have modded many games successfully but I never had problems like this before. I guess I will just leave it to the pros lol