Author Topic: [FF8PC] External Texture Support - Tonberry (v1.5)  (Read 143891 times)

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: [FF8PC] External Texture Support - Tonberry (v1.5)
« Reply #200 on: 2017-08-25 19:50:44 »
I found out that its the file d3d9callback.dll that causes the problems. My FF8 constantly crashes and its always  d3d9callback.dll that is indicated as the problem in the windows error report. So I tried replacing only the d3d9callback.dll with teh one in Tonbery enhanced 2.04 and the launcher crash is back. Windows 7 hates that file lol

Mcindus

  • Freak
  • *
  • Posts: 641
  • Karma: 111
  • Artist, Modder, Musician.
    • View Profile
Re: [FF8PC] External Texture Support - Tonberry (v1.5)
« Reply #201 on: 2017-08-25 21:56:42 »
I found out that its the file d3d9callback.dll that causes the problems. My FF8 constantly crashes and its always  d3d9callback.dll that is indicated as the problem in the windows error report. So I tried replacing only the d3d9callback.dll with teh one in Tonbery enhanced 2.04 and the launcher crash is back. Windows 7 hates that file lol

You should be posting on the other Tonberry thread (Enhanced)
You need to make sure you have VC Redistributable and the latest version of DirectX9c runtimes.  I run Win 7 and don't have those problems.  Also - read through the Tonberry Enhanced thread to see if your questions have been addressed.  It's not this thread, it's this other one here:
http://forums.qhimm.com/index.php?topic=15945.0

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: [FF8PC] External Texture Support - Tonberry (v1.5)
« Reply #202 on: 2017-08-26 10:02:17 »
I have every version of VN redistributable installed from 2010 to 2017 (x86 and x64) I have upated directx and have followed the guideto the letter but nomatter what I do every of tonberry enhanced past 2.01 crashes my ff8 launcher and it wont load .

Mcindus

  • Freak
  • *
  • Posts: 641
  • Karma: 111
  • Artist, Modder, Musician.
    • View Profile
Re: [FF8PC] External Texture Support - Tonberry (v1.5)
« Reply #203 on: 2017-08-27 01:27:46 »
I have every version of VN redistributable installed from 2010 to 2017 (x86 and x64) I have upated directx and have followed the guideto the letter but nomatter what I do every of tonberry enhanced past 2.01 crashes my ff8 launcher and it wont load .

Get the developer package for directx9c redist 2010.  After you download, find the most recent one from the list and download.  You might THINK you have what you need, but this download package should fix your problem... it doesn't come with any other package and not only fixes d3d9 hooks, but does so on ALL win 10 machines (which is a huge issue). Here's the link:
https://www.microsoft.com/en-us/download/details.aspx?id=8109

DO THIS.  Please.

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: [FF8PC] External Texture Support - Tonberry (v1.5)
« Reply #204 on: 2017-09-03 00:01:49 »
Thanks I will try at some point (recently bought FF9 Steam and am around halfway through disc3 I think). Though I have Windows 7 not 10. Will it still do?

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: [FF8PC] External Texture Support - Tonberry (v1.5)
« Reply #205 on: 2017-10-02 13:04:26 »
Hey I finally got round to trying this. I still get the exact same error "The application was unable to start correctly (0xc000007b). ClickOK to close the application." with the directx update installed. Guess I will just have to stick with v2.1

bobbythejobby

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 0
    • View Profile
Re: [FF8PC] External Texture Support - Tonberry (v1.5)
« Reply #206 on: 2017-10-02 23:09:32 »
Hey I managed to fix this issue after hours of digging around on these forums. What I did was download msvcp120.dll and msvcr120.dll and copied both files to the Final Fantasy VIII installation directory (the one with ff8_en.exe and ff8launcher.exe) and now my FF8 Launcher opens fine with Tonberry enhanced v2.04 installed. Just thought I would post here so anyone else experiencing this issue can fix it.