Qhimm.com Forums

Final Fantasy Forums => Aali's Custom FF7/FF8 Driver => Topic started by: Kompass63 on 2014-04-18 10:02:50

Title: Aali's Custom Driver Installation
Post by: Kompass63 on 2014-04-18 10:02:50
                    Aali's Custom Driver FF7/FF8 Installer (http://www.file-upload.net/download-8872518/Install_Aali-s_opengl_driver_0.8.1b.exe.html)
               (Custom Driver (Version 0.8.1b) made by Aali, Installer made by Kompass63)

You must also download Aali's Custom graphics driver [v0.8.1b] from this page (http://forums.qhimm.com/index.php?topic=14922.msg209380#msg209380).
Put ff7_opengl-0.8.1b.zip and Install_Aali-s_opengl_driver_0.8.1b.exe into the same Place and run the Installer.

Warning:
  The graphics driver within the Windows installations DVD does not support OpenGL 2.0 or higher!
  If you see inside the app.log this Line:
         INFO: Microsoft Corporation GDI Generic 1.1.0
  then
  Update your graphics driver!



This installer installs the Custom Driver for both FF7 (1998) as well as FF8 (2000).
The Custom Driver is not suitable for the newer versions (Rerelease or Steamrelease) of this games.
If you have a newer version of FF7, this can be converted using a converter into the old version.

This installer installs also "FF7Config.exe" together with "RunFFVIIConfig.exe" (for FF7 only).
The latter ensures that the Custom Driver is again entered into the Registry after FF7Config was executed.
Title: Re: Aali's Custom Driver Installation
Post by: Aali on 2014-04-28 20:23:26
You do not have permission to redistribute the driver in this manner. I'm not going to ask you to take it down but you really should have asked first.
Title: Re: Aali's Custom Driver Installation
Post by: Kompass63 on 2014-04-29 06:38:46
I sent you a PM, but you did not answer it ...
Title: Re: Aali's Custom Driver Installation
Post by: Aali on 2014-04-29 10:16:41
I get a lot of PMs and I hardly ever answer because most of them are utter crap. Yours was quite rude and not anywhere close to asking for permission.
Title: Re: Aali's Custom Driver Installation
Post by: Kaldarasha on 2014-04-29 12:22:11
How about making the installer to use an external package? It would be better this way, because the installer would work with any newer version without the need of updating the program.
Title: Re: Aali's Custom Driver Installation
Post by: Aali on 2014-04-29 15:55:08
How about making the installer to use an external package? It would be better this way, because the installer would work with any newer version without the need of updating the program.

That would be a great solution, if the installer just prompted for the zip file when you launch it I would have no problem with that. Linking to the release thread from the program is also acceptable, direct linking to the download is not.
Title: Re: Aali's Custom Driver Installation
Post by: genesis063 on 2014-04-29 22:01:46
This is why you read pms to avoid these issues its you fault for not addressing this early.  You are also being rude for ignoring the pm then throwing a fit about him posting the link.  I agree this was wrong to do but you also share the blame.
Title: Re: Aali's Custom Driver Installation
Post by: DLPB on 2014-04-29 22:09:58
I will also once again add that the driver needs a readme and known issues page (not having one is causing all kinds of issues).  I have offered twice to make one, but been ignored.  And now I am a lot busier.
Title: Re: Aali's Custom Driver Installation
Post by: Covarr on 2014-04-29 23:11:28
Enough with the drama, especially from people who aren't even involved in it. From here on in, let's limit this thread to discussion of the installer itself. ~Covarr

Aali, you may want to consider including a license file with future revisions of your driver, even a simple one that says nothing more than "NOT FOR DISTRIBUTION WITHOUT PERMISSION".

Kompass63, the sooner you can get that updated version that uses an external package, the better.
Title: Re: Aali's Custom Driver Installation
Post by: Kompass63 on 2014-05-01 00:20:32
I now have as demanded the Custom Driver removed.


How about making the installer to use an external package? It would be better this way, because the installer would work with any newer version without the need of updating the program.
The installer is tuned to the Custom Driver 0.8.1b and will not work with other versions.
Title: Re: Aali's Custom Driver Installation
Post by: dkmirishman on 2014-08-24 22:56:58
Has anybody written a guide about how to install Aali's custom graphics driver for folks who have the Steam version?
Title: Re: Aali's Custom Driver Installation
Post by: Kaldarasha on 2014-08-24 23:26:35
http://forums.qhimm.com/index.php?topic=15214.0
And don't ask about achievements support. It's not possible due to DotEmu's own hack, which is needed for them.
Read this, too.
http://forums.qhimm.com/index.php?topic=14407.0
Title: Re: Aali's Custom Driver Installation
Post by: cmh175 on 2014-09-06 17:07:26
Has there been update about removing the error notices? It's great to see them during testing but otherwise they're very distracting, particularly if there's more than one, they can fill up almost half the screen. I'd say this feature from the previous version with bootleg is basically essential. Anyone have an idea of how to disable this with the new driver?
Title: Re: Aali's Custom Driver Installation
Post by: WolfMan on 2014-09-07 00:22:41
There's a way to remove the glitch notices in the config file. Someone post on another thread the code to add to hide them. I just can't remember who and where.
Title: Re: Aali's Custom Driver Installation
Post by: Vgr on 2014-09-07 00:36:38
That is no longer part of Aali's driver.
Title: Re: Aali's Custom Driver Installation
Post by: chriserenity on 2016-03-05 00:27:43
Hello people,

I've dumped all the files that were in the Aali download .zip V0.8.1b into my game directory but when I run the game I get an error message saying Aali's driver is not compatible with my version of FFVIII due to ... it then lists about 10 possible reasons the only ones that made sense were either patch 1.2 was missing or i was using the older Eidos patch and needed the newer Squaresoft one.  I tried swapping it out but to no avail. 

When I go into FF8Config.exe there is no option to select 'custom driver'.  The only option is 'Primary display driver'. 

The installation instructions I tried to follow here http://forums.qhimm.com/index.php?topic=14922.0 said to change the settings in the config file after dumping the files in the game directory.  I assume the custom config file is ff8_opengl.cfg but it doesn't say what I need to change! 

Please help!

Running Windows 10 64bit. 

APP log:
[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] ERROR: no compatible version found

Config file:
# ff7_opengl-0.8b config file



## USER OPTIONS ##
## If you just want to play the game, these are the only options you'll want to change.

# set the window size (or fullscreen resolution) of FF7
# 0 means use original resolution in window mode, your current desktop resolution will be used in fullscreen mode
# preserve_aspect adds black borders as needed to preserve a 4:3 aspect ratio
window_size_x = 0
window_size_y = 0
preserve_aspect = yes
fullscreen = yes

# mod directory
# subdirectroy of mods/ where textures will be loaded from
mod_path = none

# check your Nvidia/ATI/Intel control panel settings if this option doesn't seem to work
enable_vsync = yes

# allow FF7 to use linear filtering for its textures
# some things look slightly better with this option on, but alot of textures just lose their detail
# only affects low-res textures, high-res replacements will still be filtered where appropriate
linear_filter = off

# plugin used to play music, VGMstream requires a set of looping .ogg files in the music/vgmstream folder.
# If no music plugin is loaded the game will play MIDI as usual but FF7Music will NOT work.
#music_plugin = plugins/vgmstream_music.fgp



## ENHANCEMENTS ##
## All the little extras that weren't part of the original game, default options include only trivial bug fixes.

# make all dialog boxes transparent, same effect as the transparent dialog boxes YAMP patch
transparent_dialogs = off

# include armor in magic defense calculation
mdef_fix = yes

# post-processing shader, used to apply fullscreen effects
post_source = shaders/bloom2.post
enable_postprocessing = no



## ADVANCED OPTIONS ##
## Don't fiddle with these unless you know what you're doing.

# enable alpha blending for textures without an existing blending effect
fancy_transparency = on

# display frames per second counter in upper right corner
show_fps = no

# display some real-time debug information
show_stats = no

# store external textures in a compressed cache for increased performance
# compression is not lossless, some artifacts may appear when this option is in use
# texture cache does NOT update automatically if the source image changes, however, deleting anything from the cache
# will cause that file to be recreated from the source
compress_textures = no

# max size of the texture cache to hold in RAM, in megabytes
# don't set it any higher than 1GB unless you want your game to crash
texture_cache_size = 256

# use pixel buffer objects to speed up texture loading
# might crash horribly on ATI cards but should work for NVIDIA users
use_pbo = yes

# use mipmaps (anisotropic filtering) for high-res textures
use_mipmaps = yes

# replace FF7's default framelimiter timer source
use_new_timer = yes

# plugin used to play movies, FFMpeg is the only choice for now
movie_plugin = plugins/ffmpeg_movies.fgp



## MODDER OPTIONS ##
## These options are mostly useful to modders and should not be enabled during normal play.

# read files directly instead of using LGP archives
# for example; if FF7 is looking for aaab.rsd in char.lgp, this option will make it open direct/char/aaab.rsd first,
# if this file doesn't exist it will look for the original in the LGP archive
direct_mode = off

# show every failed attempt at loading a .png texture
show_missing_textures = no
Title: Re: Aali's Custom Driver Installation
Post by: chriserenity on 2016-03-05 00:53:57
(http://i65.tinypic.com/np5105.png)

This is the error message I get when i run FFVIII.  I'm using original 2000 version by the way on a virtual drive (iso).  Game runs vanilla without Aali driver at moment. 
Title: Re: Aali's Custom Driver Installation
Post by: Jotaro on 2016-03-05 03:36:05
Do you have the SquareSoft 1.2 patch?
It would be best to patch it with that, even if you think it already is, just to be safe.
Unless, off course, you've tried modding FF8 before.
Also, is the iso pirated, or a backup of your disk(s)? If the former, we can't help.
Title: Re: Aali's Custom Driver Installation
Post by: chriserenity on 2016-03-05 09:37:03
Do you have the SquareSoft 1.2 patch?
It would be best to patch it with that, even if you think it already is, just to be safe.
Unless, off course, you've tried modding FF8 before.
Also, is the iso pirated, or a backup of your disk(s)? If the former, we can't help.

Hi, thanks for reply. 

I think I have the squaresoft 1.2 patch.  I got it from here:

https://www.google.co.uk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&ved=0ahUKEwibmdfsq6nLAhVGUBQKHfphDFUQFggnMAI&url=http%3A%2F%2Fwww.fileplanet.com%2F40188%2F40000%2Ffileinfo%2FFinal-Fantasy-VIII-v1.2&usg=AFQjCNGaJJMGmUG_77R25sFdYmeY2IPytw&sig2=M-wtD85ysYtJhKGGsqj1Iw&cad=rja

First time modding FFVIII yes. 
You just put the patch in the game's directory right, you don't need to do anything with it?  In my case

C:\Program Files (x86)\Eidos Interactive\Square Soft, Inc\FINAL FANTASY VIII

I'm trying to mod the game with Roses and Wine and it says in the instructions that Aali's driver is a prerequisite. 
Title: Re: Aali's Custom Driver Installation
Post by: Sydney22 on 2016-12-29 05:52:59
Hello people,

I've dumped all the files that were in the Aali download .zip V0.8.1b into my game directory but when I run the game I get an error message saying Aali's driver is not compatible with my version of FFVIII due to ... although If you’ve been looking at alternatives to steroids, then you’ll have likely stumbled across GNC and their huge range. https://legalsteroids.best/gnc/ for legal steroids at gnc  it then lists  about 10 possible reasons the only ones that made sense were either patch 1.2 was missing or i was using the older Eidos patch and needed the newer Squaresoft one.  I tried swapping it out but to no avail. 

When I go into FF8Config.exe there is no option to select 'custom driver'.  The only option is 'Primary display driver'. 

The installation instructions I tried to follow here http://forums.qhimm.com/index.php?topic=14922.0 said to change the settings in the config file after dumping the files in the game directory.  I assume the custom config file is ff8_opengl.cfg but it doesn't say what I need to change! 

Please help!

Running Windows 10 64bit. 

APP log:
[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] ERROR: no compatible version found

Config file:
# ff7_opengl-0.8b config file



## USER OPTIONS ##
## If you just want to play the game, these are the only options you'll want to change.

# set the window size (or fullscreen resolution) of FF7
# 0 means use original resolution in window mode, your current desktop resolution will be used in fullscreen mode
# preserve_aspect adds black borders as needed to preserve a 4:3 aspect ratio
window_size_x = 0
window_size_y = 0
preserve_aspect = yes
fullscreen = yes

# mod directory
# subdirectroy of mods/ where textures will be loaded from
mod_path = none

# check your Nvidia/ATI/Intel control panel settings if this option doesn't seem to work
enable_vsync = yes

# allow FF7 to use linear filtering for its textures
# some things look slightly better with this option on, but alot of textures just lose their detail
# only affects low-res textures, high-res replacements will still be filtered where appropriate
linear_filter = off

# plugin used to play music, VGMstream requires a set of looping .ogg files in the music/vgmstream folder.
# If no music plugin is loaded the game will play MIDI as usual but FF7Music will NOT work.
#music_plugin = plugins/vgmstream_music.fgp



## ENHANCEMENTS ##
## All the little extras that weren't part of the original game, default options include only trivial bug fixes.

# make all dialog boxes transparent, same effect as the transparent dialog boxes YAMP patch
transparent_dialogs = off

# include armor in magic defense calculation
mdef_fix = yes

# post-processing shader, used to apply fullscreen effects
post_source = shaders/bloom2.post
enable_postprocessing = no



## ADVANCED OPTIONS ##
## Don't fiddle with these unless you know what you're doing.

# enable alpha blending for textures without an existing blending effect
fancy_transparency = on

# display frames per second counter in upper right corner
show_fps = no

# display some real-time debug information
show_stats = no

# store external textures in a compressed cache for increased performance
# compression is not lossless, some artifacts may appear when this option is in use
# texture cache does NOT update automatically if the source image changes, however, deleting anything from the cache
# will cause that file to be recreated from the source
compress_textures = no

# max size of the texture cache to hold in RAM, in megabytes
# don't set it any higher than 1GB unless you want your game to crash
texture_cache_size = 256

# use pixel buffer objects to speed up texture loading
# might crash horribly on ATI cards but should work for NVIDIA users
use_pbo = yes

# use mipmaps (anisotropic filtering) for high-res textures
use_mipmaps = yes

# replace FF7's default framelimiter timer source
use_new_timer = yes

# plugin used to play movies, FFMpeg is the only choice for now
movie_plugin = plugins/ffmpeg_movies.fgp



## MODDER OPTIONS ##
## These options are mostly useful to modders and should not be enabled during normal play.

# read files directly instead of using LGP archives
# for example; if FF7 is looking for aaab.rsd in char.lgp, this option will make it open direct/char/aaab.rsd first,
# if this file doesn't exist it will look for the original in the LGP archive
direct_mode = off

# show every failed attempt at loading a .png texture
show_missing_textures = no

Well at first i was getting the same error, but try resintalling and then make the changes to .cfg files and it will work fine, Although it does lag on windows 10