Qhimm.com Forums

Miscellaneous Forums => Troubleshooting => Topic started by: Tenko Kuugen on 2014-12-01 02:00:59

Title: Flevel corruption - Fields crashing randomy
Post by: Tenko Kuugen on 2014-12-01 02:00:59
We've come across a ridiculous CTD in the game that leaves me puzzled as to what could be happening.

The situation is basically as follows:
The book rooms in shinra HQ F62 cause crashes. Sometimes. Randomly.
Yes, it really is that. I exported fields from the vanilla flevel and imported them (tried all variants each time with a new flevel) and the error persists. Then I copy the flevel and replace the flevel with the copy I just made and I can enter the room. Once or twice. After that it crashes. And crashes again non-stop when I restart the game.
It works with a complete vanilla flevel so it's not the .exe or the driver. At least I don't believe so. But then the crashes make no sense, considering I did replace both book rooms.
I did get to the point where I replaced both book rooms with the uncompressed exported field and could enter one of them but then the other crashed, whichever I imported first worked.
I can supply the flevel and the actual fields but I am at a loss as to what is actually happening since all the app.log tells me is that there's an unhandled exception.
The crash is instant upon entering the room before the screen loads but after the music (if placed) loads
Title: Re: Flevel corruption - Fields crashing randomy
Post by: Vgr on 2014-12-01 02:38:50
What we could do to find is to rule out what cannot cause the issue from what is a possible cause. Without further information I'm guessing it's a script that's meant to run when entering the screen, which may or may not have been there before. We know it all too well, that game is known for having a lot of unused content. I'm not sure what else could be causing this, but it's weird. Have you tried comparing both yours and the vanilla fields side-to-side? I don't know how many modifications you put in there.
Title: Re: Flevel corruption - Fields crashing randomy
Post by: Sega Chief on 2014-12-01 03:57:47
It might be the tool; when Kalderasha And Alyza were originally going through my flevel files they mentioned there being some kind of corruption that prevent them from being decompiled properly. And just recently, Neuro mentioned something about a corruption warning about backgrounds when he was importing a vanilla field to replace a modified one (using the latest Makou version).

It might be too that there's some hidden process going on that the tool doesn't recognise or import properly. Another possibility is that a variable is used for this room but it's been used elsewhere in the mod that's causing the game to trip over itself. To rule that out though, you could try loading a vanilla save file and heading into the book rooms a few times.
Title: Re: Flevel corruption - Fields crashing randomy
Post by: Tenko Kuugen on 2014-12-01 04:13:46
@VGR I replaced the entire field with the vanilla version and the crash persisted so it's not the script/code itself.
The only changes I actually made to the fields are adding two groups to each and the fields still crash without that (A hidden item, per group. Cloud himself is a group, Tifa is a group, etc, just so you know what I mean.)

I skip importing the backgrounds and the error persisted.
I tested a vanilla save without hidden items or other mod stuff and the error popped up after I entered the room, left and returned. Unless it's actually possible to debug what is happening by hooking something on top of ff7, I've no idea what to do.
Title: Re: Flevel corruption - Fields crashing randomy
Post by: Kaldarasha on 2014-12-01 06:08:16
Have you modified the sound files? I have a crash because of it in zz1, which is strange because it worked before.
Do you use Aali's latest driver or the 07.11.b build?
The group AD looks suspicious. It endless stores Cloud's position in [6][3]. Don't know if this is harmful or even needed.
Are both rooms effected by it? blin62_3 seems to have an unfinished main script compared to blin62_2.
I'll do further investigations when I'm at home.
Title: Re: Flevel corruption - Fields crashing randomy
Post by: Tenko Kuugen on 2014-12-01 23:52:40
As I mentioned above, both rooms crash on occasion. Sometimes one works and the other doesn't.
I have VGMstream running with Aali's latest driver but I'm pretty sure I did have this problem before, like 6 months ago, and I wasn't using the new driver then. I ignored the issue back then because I saw no solution.

As for 6:13, that shouldn't be it considering the rooms still crash if I replace them entirely with a vanilla version.
blin62_2's main script just lacks a "display X text in menu" that clearly labels the main script as main script.