Final Fantasy Forums > Other Mods

Help with ToughScript

(1/5) > >>

UpRisen:
Hello all, Im trying to change menu options using Toughscript and I get an error saying

Registry values found:SOFTWARE\Square Soft, Inc.\Final Fantasy VII
Error creating spacing table
Cannot read / error reading flevel
Couldn't dump world_us: basic_ios::clear: iostream error
Couldn't dump scene: converting to scene failed, basic_ios::clear: iostream error
Couldn't dump kernel: basic_ios::clear: iostream error
Couldn't dump kernel2: basic_ios::clear: iostream error
Couldn't dump exe: basic_ios::clear: iostream error

I have read the entire toughscript thread and none of the solutions there seemed to fix the issue. Ive reinstalled, cleared my registry, and done any other solution mentioned in the post.
My ini file is as follows
# Strip unused text
text_strip = 1

# Strip unused scripts
script_strip = 1

# Insert missing windows.
# Reuses previous window id values if available,
# otherwise defaults are x = 80, y = 80, w = 150, h = 57
window_patch = 1

# Dump window parameters with text
# (where available)
dump_x = 0
dump_y = 0
dump_w = 0
dump_h = 1
dump_sp = 0
dump_question = 0

# Force character name widths to width of value
# (not recommended for redistribution)
# cloud = Cloud
# barret = Barret
# tifa = Tifa
# aerith = Aerith
# redxiii = Red XIII
# yuffie = Yuffie
# caitsith = Cait Sith
# vincent = Vincent
# cid = Cid

# Override paths
text = .\text\
flevel = "D:\Games\Steamapps\Common\Final Fantasy VII\data\field\flevel.lgp"
world = "D:\Games\Steamapps\Common\Final Fantasy VII\data\wm\world_us.lgp"
scene = "D:\Games\Steamapps\Common\Final Fantasy VII\data\battle\scene.bin"
kernel = "D:\Games\Steamapps\Common\Final Fantasy VII\data\kernel\kernel.bin"
kernel2 = "D:\Games\Steamapps\Common\Final Fantasy VII\data\kernel\kernel2.bin"
window = "D:\Games\Steamapps\Common\Final Fantasy VII\data\kernel\window.bin"
exe = "D:\Games\Steamapps\Common\Final Fantasy VII\ff7.exe"

I have my TS and ff7 folder all set to write and all run as administrator and im using version 1.3.1. Idk what ive missed so any help would be appreciated.

DLPB:
Certain of your files are either corrupt, broken, non readable/writable, or not compatible.

I assume "d" drive is a writable drive?  And not your cd/dvd/blu-ray drive?

UpRisen:
Yes my D drive is my secondary HDD, Ive even gone so far as to use my admin account to disable read-only mode for the entire drive. Ive done fresh installs of TS and ff7, including the exes gained from 7h even though they should have no effect on this process, i even tried changing the exe path in the ini file to the BC, MO, and even SS exes to see if any of those would change it.

DLPB:
Your game seems to be English version, which is correct.  All I can assume is your files are broken somehow.  A mod you have installed may have broken one of the files.  Does ts work with original game?

UpRisen:
No, When i did a fresh install i tried it before running the ff7 converter, after running but before setting up 7h

Navigation

[0] Message Index

[#] Next page

Go to full version