Author Topic: "Failed to set requested fullscreen mode, reverting to original resolution"  (Read 347 times)

Volkier

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Hi all,

I've finally managed to get everything working, had a blast playing ye olde FF7 yesterday with the awesome mods. No problems whatsoever - everything works great!

Tried to start the game today, and no matter what I do I cannot get the game to run in fullscreen mode. The most annoying thing is NOTHING HAS CHANGED from last night AT ALL. I didn't even shut down the laptop that I played on (I have restarted it as a means of trying to fix this problem since however)

I've tried altering the resolution to 0, 0, toggled aspect ratio, toggled filtering on and off, tried every shader (pretty much every option in Aalia's driver window). I've disabled every single mod to see if it will launch, yet still get that error. App.log below:

[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF7 1.02 US English
[00000000] ERROR: failed to set fullscreen mode
[00000000] INFO: Intel Intel(R) HD Graphics 4000 4.0.0 - Build 10.18.10.4425
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 16384x16384
[00000000] INFO: Original resolution 640x480, window size 640x480, output resolution 640x480, internal resolution 3840x2160
[00000000] INFO: Shader limits: varying 64, vert uniform 4096, frag uniform 4096
[00000000] INFO: FFMpeg movie player plugin loaded
[00000000] INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
[00000000] INFO: VGMStream music plugin loaded
[00000000] INFO: Loading external library Multi.dll
[00000000] LOCK UNLOCK TEST
[00000001] MATRIX INITIALIZE
[00000001] INITIALIZE DD/D3D END
[00000001] initializing sound...
[00000001] creating dsound primary buffer
[00000001] reading audio file
[00000001] loading static sounds
[00000001] sound initialized
[00000001] set music volume: 127
[00000001] set music volume: 127
[00000001] Entering MAIN
[00000001] Exiting MAIN
[00000001] START OF CREDITS!!!
[00000001] INFO: D:\FFVII\data\movies\eidoslogo.avi; h264/aac 1280x960, 15.000000 FPS, duration: 10.193000, frames: 153
[00000023] WM_CLOSE
[00000023] END OF CREDITS!!!
[00000023] Field Quit
[00000023] UNINITIALIZE DD
sic file: D:\FFVII\/music/vgmstream/PRE.ogg
[00001019] WM_CLOSE
[00001019] END OF CREDITS!!!
[00001019] Field Quit
[00001019] UNINITIALIZE DD

Really at a loss as to what to do. Any help would be hugely appreciated.

Oh and windowed mode works fine at any resolution, just not fullscreen.

Volkier

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
UPDATE:

Reinstalling FF7_GameConverter_7H fixes this. However this problem returns when laptop goes in and out of standby (7thHeaven is not running when the laptop goes into standby mode).

EDIT:

Also happens any time I shut down / restart the computer.
« Last Edit: 2019-02-16 21:46:41 by Volkier »

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 3033
  • Karma: 208
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Try fiddling with the DPI settings under the exe Properties.