Author Topic: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)  (Read 219952 times)

obesebear

  • Administrator
  • *
  • Posts: 1361
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #350 on: 2020-07-18 15:01:56 »
Could be something to do with using the steam version.  A more complete version of this mod is included with Reunion that can be found at ff7.live

Luks_18

  • *
  • Posts: 10
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #351 on: 2020-07-18 17:43:59 »
Thanks for the sugestion!
I installed this mod, but this mod install a bunch of other things, and my problem is that the Cloud Saving is not working, is there a way to reactivate Cloud Saving, I reinstaled everything and I lost the local file, I only have it on the cloud.

-Ori

  • In the garage, I feel safe.
  • *
  • Posts: 344
  • No one laughs about my ways.
    • View Profile
    • The Reunion
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #352 on: 2020-07-18 18:03:30 »
Thanks for the sugestion!
I installed this mod, but this mod install a bunch of other things, and my problem is that the Cloud Saving is not working, is there a way to reactivate Cloud Saving, I reinstaled everything and I lost the local file, I only have it on the cloud.

i would not trust cloud saving, personally

when installing reunion, it creates and uses its own save folder in the folder where you installed FF7 (folder called 'save')

if you are using the steam version of FF7, the save file should be located at Documents/Square Enix/Final Fantasy VII Steam/user_********

you can move saves from one location to the other and it will work fine, keep a backup though!

Luks_18

  • *
  • Posts: 10
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #353 on: 2020-07-18 20:47:40 »
Thanks! One last thing, I noticed that none sound is playing during my game, only the FMV's play correctly, but the music and SFX doesn't play.
Here is the audio config.
[AUDIO REPLACEMENT]
Audio_Device = -1
Mute = n
Music_Vol =75
SFX_Vol =100
Mono_Output = n
Centre_Battle_SFX = n
Field_SFX_In_Battle = n
Music_Balance_Functions = n
Load_SFX_To_Memory = y
Audio_Log_Level = 4

-Ori

  • In the garage, I feel safe.
  • *
  • Posts: 344
  • No one laughs about my ways.
    • View Profile
    • The Reunion
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #354 on: 2020-07-18 22:31:21 »
Thanks! One last thing, I noticed that none sound is playing during my game, only the FMV's play correctly, but the music and SFX doesn't play.
Here is the audio config.
[AUDIO REPLACEMENT]
Audio_Device = -1
Mute = n
Music_Vol =75
SFX_Vol =100
Mono_Output = n
Centre_Battle_SFX = n
Field_SFX_In_Battle = n
Music_Balance_Functions = n
Load_SFX_To_Memory = y
Audio_Log_Level = 4

CTRL + ALT + M is an in-game mute toggle, you accidentally turn that on?

and my centre_battle_SFX is y, you turn that off purposefully?
« Last Edit: 2020-07-18 22:34:26 by -Ori »

Luks_18

  • *
  • Posts: 10
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #355 on: 2020-07-19 01:56:29 »
I tried that, I alson changed the audio device (which I don't think it's the problem since FMV's play correctly) to -2, 0, 1 and 2, but nothing changes.
I uninstalled everything without changing any settings, but the game still doesn't have SFX and music.
(If I disable the mod then everything works normally)

-Ori

  • In the garage, I feel safe.
  • *
  • Posts: 344
  • No one laughs about my ways.
    • View Profile
    • The Reunion
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #356 on: 2020-07-19 02:06:10 »
I tried that, I alson changed the audio device (which I don't think it's the problem since FMV's play correctly) to -2, 0, 1 and 2, but nothing changes.
I uninstalled everything without changing any settings, but the game still doesn't have SFX and music.
(If I disable the mod then everything works normally)

well then i assume you are running an hdmi cable to a monitor with speakers or a TV?

you will have to do a workaround and use another output for your audio... USB speakers, 3.5mm headphone jack, or digital optical (TOSLINK)
the problem is related to the hdmi input on the TV or monitor (or perhaps displayport as well, or any input that combines digital audio and video) even though it works fine without the mod
« Last Edit: 2020-07-19 02:16:33 by -Ori »

Luks_18

  • *
  • Posts: 10
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #357 on: 2020-07-19 02:49:51 »
I tried removing my HDMI cable, use head phone and speakers, but the problem is the same.
I don't know If it would be useful, but here is the Audio.log file the mod creates, I think it may help solve this problem.

0.Could not retrieve device GUIDs: EAccessViolation
Access violation at address 776FE136 in module 'ntdll.dll'. Read of address 00000044
0.Could not retrieve device names: EAccessViolation
Access violation at address 776FE136 in module 'ntdll.dll'. Read of address 00000044
0.SetVolume [Channel 0, Volume 127]
70.SetVolumeTransition [Channel 0, TargetVolume 0, Time 1000ms]
134.BassStopSounds_Begin
134.StopSound [Channel 0]
134.BassStopSounds_End
135.BassStopSounds_Begin
135.StopSound [Channel 0]
135.BassStopSounds_End
135.BassStopSounds_Begin
135.StopSound [Channels 1 to 4]
135.BassStopSounds_End
135.BassStopSounds_Begin
135.StopSound [Channels 20 to 24]
135.BassStopSounds_End
135.SetVolume [Channel 0, Volume 127]
135.SetVolume [Channels 1 to 4, Volume 127]
135.SetTempo [Channel 0, Tempo 0]
135.SetTempo [Channels 1 to 4, Tempo 0]
135.SetBalance [Channels 1 to 4, Balance 64]
136.SetVolume [Channel 5, Volume 127]
251.BassSetEffect_Begin
251.BassStopSounds_Begin
251.BassStopSounds_End
251.BassSetEffect_End
256.BassSetEffect_Begin
256.BassStopSounds_Begin
256.BassStopSounds_End
256.BassSetEffect_End
265.BassSetEffect_Begin
265.BassStopSounds_Begin
265.BassStopSounds_End
265.BassSetEffect_End
271.BassSetEffect_Begin
271.BassStopSounds_Begin
271.BassStopSounds_End
271.BassSetEffect_End
275.BassSetEffect_Begin
275.BassStopSounds_Begin
275.BassStopSounds_End
275.BassSetEffect_End
279.BassSetEffect_Begin
279.BassStopSounds_Begin
279.BassStopSounds_End
279.BassSetEffect_End


Also the Hext.log and The_Reunion.log doesn't show any error, the Audio Replacement load just fine.

-Ori

  • In the garage, I feel safe.
  • *
  • Posts: 344
  • No one laughs about my ways.
    • View Profile
    • The Reunion
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #358 on: 2020-07-19 04:10:50 »
when you plug in your headphones, did you change that to your default audio output in windows  (or whatever OS you are using) before you launched the game?

the problem is at the start of the log, its not finding your audio devices

perhaps you need to update your audio device drivers? i know old drivers sometimes cause the EAccessViolation error
« Last Edit: 2020-07-19 04:15:00 by -Ori »

Luks_18

  • *
  • Posts: 10
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #359 on: 2020-07-19 05:31:04 »
How do I do that? It works just fine, but it doesn't show up as a new device.
I'm using a notebook windows 7 with Realtek High Definition Audio.
I checked the GUID from the device, but it's a giant number, not an ID like the Options.ini file shows by default, {4d36e96c-e325-11ce-bfc1-08002be10318}

-Ori

  • In the garage, I feel safe.
  • *
  • Posts: 344
  • No one laughs about my ways.
    • View Profile
    • The Reunion
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #360 on: 2020-07-19 07:03:37 »
How do I do that? It works just fine, but it doesn't show up as a new device.
I'm using a notebook windows 7 with Realtek High Definition Audio.
I checked the GUID from the device, but it's a giant number, not an ID like the Options.ini file shows by default, {4d36e96c-e325-11ce-bfc1-08002be10318}

that GUID should show up in the audio log, you've tried restarting the computer? also make sure you try windows update manually and download all available updates

with all the stuff you've done trying to get 60fps battles to work in FF7, you probably need to reinstall both FF7 AND reunion

if those things still dont work you need to try activating the hidden administrator account, logging on with it and trying that way, user account control can cause this

also dont forget about the drivers, go to your notebook manufacturer's website and see if there is updated drivers for anything


even if none of these work, there are several other things that can cause this, and being on windows 7 won't make this easy, possible to upgrade to win10?
« Last Edit: 2020-07-19 07:21:44 by -Ori »

usb

  • *
  • Posts: 110
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #361 on: 2020-07-19 18:46:24 »
I tried removing my HDMI cable, use head phone and speakers, but the problem is the same.
I don't know If it would be useful, but here is the Audio.log file the mod creates, I think it may help solve this problem.

0.Could not retrieve device GUIDs: EAccessViolation
Access violation at address 776FE136 in module 'ntdll.dll'. Read of address 00000044
0.Could not retrieve device names: EAccessViolation
Access violation at address 776FE136 in module 'ntdll.dll'. Read of address 00000044
0.SetVolume [Channel 0, Volume 127]
70.SetVolumeTransition [Channel 0, TargetVolume 0, Time 1000ms]
134.BassStopSounds_Begin
134.StopSound [Channel 0]
134.BassStopSounds_End
135.BassStopSounds_Begin
135.StopSound [Channel 0]
135.BassStopSounds_End
135.BassStopSounds_Begin
135.StopSound [Channels 1 to 4]
135.BassStopSounds_End
135.BassStopSounds_Begin
135.StopSound [Channels 20 to 24]
135.BassStopSounds_End
135.SetVolume [Channel 0, Volume 127]
135.SetVolume [Channels 1 to 4, Volume 127]
135.SetTempo [Channel 0, Tempo 0]
135.SetTempo [Channels 1 to 4, Tempo 0]
135.SetBalance [Channels 1 to 4, Balance 64]
136.SetVolume [Channel 5, Volume 127]
251.BassSetEffect_Begin
251.BassStopSounds_Begin
251.BassStopSounds_End
251.BassSetEffect_End
256.BassSetEffect_Begin
256.BassStopSounds_Begin
256.BassStopSounds_End
256.BassSetEffect_End
265.BassSetEffect_Begin
265.BassStopSounds_Begin
265.BassStopSounds_End
265.BassSetEffect_End
271.BassSetEffect_Begin
271.BassStopSounds_Begin
271.BassStopSounds_End
271.BassSetEffect_End
275.BassSetEffect_Begin
275.BassStopSounds_Begin
275.BassStopSounds_End
275.BassSetEffect_End
279.BassSetEffect_Begin
279.BassStopSounds_Begin
279.BassStopSounds_End
279.BassSetEffect_End


Also the Hext.log and The_Reunion.log doesn't show any error, the Audio Replacement load just fine.

Try the fixed dll in my thread http://forums.qhimm.com/index.php?topic=19551.0 (it's in known issue section) I've got the same error when r06f was released(first to report bug) and than it was fixed by daniel
« Last Edit: 2020-07-19 18:57:47 by usb »

Luks_18

  • *
  • Posts: 10
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #362 on: 2020-07-19 19:30:06 »
So I literally update to Windows 10 and it just worked for no reason.
Also thanks for the dll link anyway!

But one more last thing (again sorry), is there a way to change the music? It always play the PS1 music (I am the only one who don't like that stuffy music from PS1?), I have the ogg files with the Yamaha XG music, but when I put into the original music_ogg folder, it doesn't play, It still plays the PS1 music from the BASE folder, and when I delete the files from that folder, no music plays at all.
Is there a way to disable that path to reproduction? Or do I really need to change every single file name to the BASE folder respectively?

-Ori

  • In the garage, I feel safe.
  • *
  • Posts: 344
  • No one laughs about my ways.
    • View Profile
    • The Reunion
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #363 on: 2020-07-19 21:48:10 »
So I literally update to Windows 10 and it just worked for no reason.

its not for no reason, the old drivers from win7 was the issue, updating to win10 updates the ntdll.dll and sound drivers that you were having problems with

i see you found the discord, dont hesitate to ask for more help if you cant get your music files working
« Last Edit: 2020-07-19 21:56:20 by -Ori »

Luks_18

  • *
  • Posts: 10
    • View Profile
Re: [FF7PC-98/Steam] Smoother 60FPS Battles (v0.93)
« Reply #364 on: 2020-07-19 22:25:15 »
Thanks for all the help!