Author Topic: [FF7PC-98] FF7Music Installer (1.51.13)(Discontinued, use Anxious Heart)  (Read 276314 times)

sen

  • *
  • Posts: 1244
  • Good vibes
    • View Profile
Re: FF7Music Installer
« Reply #225 on: 2011-07-22 17:03:48 »
What issues are you having?  It would be easier to assist if you could be more specific.

I installed it exactly the way he said but the sound never works for some reason

sen

  • *
  • Posts: 1244
  • Good vibes
    • View Profile
Re: FF7Music Installer
« Reply #226 on: 2011-07-22 17:04:51 »
thanks alot it works now thanks to you  :)

You don't need to doublepost - just edit your previous one - Bosola
« Last Edit: 2011-07-22 18:12:25 by Bosola »

mickking

  • *
  • Posts: 14
    • View Profile
Re: FF7Music Installer
« Reply #227 on: 2011-07-24 14:54:00 »
hey guys

i dont wanna read all those posts cause my english is very sick ._.
i have a littel prob. maybe u know the answer :-)
the music installer works very fine on my system.
the only prob is that the midi music is still playing. i klicked
the button disable midi music when other blablabla is playing, but the
midi is still playing :-(
maybe some of u can help me please...

greets, micki

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #228 on: 2011-07-24 18:38:17 »
Aali's driver should be disabling it. Did you update or reinstall aali's driver after running this installer? If so, do the following:
  • In your FF7 install directory, and open ff7_opengl.cfg in a text editor.
  • Find the line that says "music_plugin = plugins/ff7music.fgp"
  • If there's a # at the beginning of the line, remove it.
That should fix the problem, unless you deleted your plugins folder or something.

mickking

  • *
  • Posts: 14
    • View Profile
Re: FF7Music Installer
« Reply #229 on: 2011-07-24 21:44:31 »
i remoed the # but the prob is still the same.....
double music... the midi and the remix :-(

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #230 on: 2011-07-24 21:55:28 »
Then FF7 is not using Aali's driver. Open ff7config.exe and make sure it's set to custom graphics driver in the graphics tab.

mickking

  • *
  • Posts: 14
    • View Profile
Re: FF7Music Installer
« Reply #231 on: 2011-07-24 22:34:55 »
hmmm by the way..... is it normal that my ff7config says me every time when i click on graphics " Info: self test passed. you are now ready to use the custom driver. see ff7_opengl.cfg for configuration. choosing additional graphics setting in ff7config will not affect anything while the driver is active." i get this message every time when i open my ff7config and click on graphic... yah and changing the display settings to 1024x768 isn't working too x_x maybe i do something wrong with the config? i run as admin...

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #232 on: 2011-07-24 22:49:29 »
Yeah, it should give that message every time. If you're running as admin and it's still not working, I'm not really sure what's wrong, sorry.

mickking

  • *
  • Posts: 14
    • View Profile
Re: FF7Music Installer
« Reply #233 on: 2011-07-24 23:06:53 »
damn..... could it be a problem that im using the german version of ff7 and not the english? i also use the german 1.2 patch...

EDIT: and i use compatibility mode with win xp sp2 cause it doesnt work in basic
« Last Edit: 2011-07-24 23:18:46 by mickking »

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #234 on: 2011-07-25 00:10:36 »
Could be. But then, I'm not an expert on aali's driver. Ask in this thread, you're more likely to get a response from someone who can actually help you.

In other news:
NEW VERSION: 1.51.9

Don't forget there's two installers. Use the minimal installer if you just wanna upgrade:
Full installer (MegaUpload, 373.37MB)
Minimal installer (MediaFire, 3.08MB) (REUPLOADED. IF YOU GOT THIS, GET IT AGAIN).

Changelog
  • You know how when you update to a new version of Aali's driver, it replaces your config and you have to manually enable music_plugin again? Not anymore. The launcher now automatically checks and corrects that. On Vista and 7, it'll ask for admin for "replacemusicplugin.exe" if it needs fixed. If it doesn't, it'll quiet down and leave you alone. You can also use this app to fix it OUTSIDE of the launcher if you so choose; it's in your FF7Music install directory.
  • You know how when you uninstall FF7Music, music_plugin stays enabled, leaving you with no music at all, and you have to manually disable music_plugin again? Not anymore. The uninstaller now automatically checks and corrects that.

This is a recommended upgrade. If you've got 1.51.4 or later, the minimal installer should be fine to upgrade with.
« Last Edit: 2011-07-25 05:04:45 by Covarr »

Jaki

  • *
  • Posts: 109
    • View Profile
Re: FF7Music Installer
« Reply #235 on: 2011-07-25 03:34:57 »
Sadly my plugins doesn't work, this is the same problem with 1.51.7 and i also get message "AutoIT error" when run launchff7.exe. Now i'm comeback with 1.51.8 and hope it's will be fix soon.

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #236 on: 2011-07-25 04:21:07 »
Because I was in a hurry and I didn't test it. Hotfix coming in a few minutes.

edit: Here ya go! This time I tested it and everything, so I know it works!

As for the plugin issues, I'll look into it for the next version. I formatted my hard drive today and did a fresh install of Windows, so now's the ideal time to test something like that.
« Last Edit: 2011-07-25 05:08:13 by Covarr »

Jaki

  • *
  • Posts: 109
    • View Profile
Re: FF7Music Installer
« Reply #237 on: 2011-07-25 05:58:02 »
Sorry Covarr, my fault. The plugin always work fine with launchff7.exe and it's only not work when i run game with FF7Music.exe. Now i'm happy with it and thanks so much  :)

mickking

  • *
  • Posts: 14
    • View Profile
Re: FF7Music Installer
« Reply #238 on: 2011-07-25 14:48:04 »
by the way... in ur ff7 tool there are only the remix versions of the ff7 music.
is there any link here in the forum to get the complete PSX Musics as profile to load in the FF7Music.exe ?

Vgr

  • Global moderator
  • *
  • Posts: 2163
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: FF7Music Installer
« Reply #239 on: 2011-07-25 14:50:38 »
PSFs are.

mickking

  • *
  • Posts: 14
    • View Profile
Re: FF7Music Installer
« Reply #240 on: 2011-07-25 14:54:54 »
hm? sry i dont understand... my english sucks as well as my shortcut understanding :P

Jaki

  • *
  • Posts: 109
    • View Profile
Re: FF7Music Installer
« Reply #241 on: 2011-07-25 15:12:44 »
Yes, open FF7Music.exe > configure > Files, and change profile to PSF.

mickking

  • *
  • Posts: 14
    • View Profile
Re: FF7Music Installer
« Reply #242 on: 2011-07-25 15:17:17 »
OMG! Im so stupid i cant belive it... Thank you so much Robert Plant and Vgr :-)
i just started to do it by myself. now i can use this perfect PSF file. Thank you so much. i cant believe it how stupid i am...
ok problem music is solved :-) now i have to solve this thing with the window solution...

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #243 on: 2011-07-25 17:34:01 »
Yeah, the front page explains that. Guess I should stick it in the readme as well.

grim_22

  • Guest
Re: FF7Music Installer
« Reply #244 on: 2011-08-01 17:01:17 »
Hi,

I'm having a small problem with FF7 music. During the nibelheim flashback, the song Those chosen by the planet - no intro doesn't play at all. I checked in the config file for the program and the song isn't included at all (should be between mura1 and oa. The code of the song is nointro). Is there anyway to fix this? If I had the midi ID and AWE id for the song I could add it to the config file, but I don't know how to get those.

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #245 on: 2011-08-01 17:51:49 »
Open FF7Music from the start menu, there should be a config screen.

Frankly, I don't know how I managed to overlook this, a fix will be coming in the next update.

grim_22

  • Guest
Re: FF7Music Installer
« Reply #246 on: 2011-08-01 19:32:31 »
Thank you for taking your time to fix this.

As for the config menu, I've already tried it, and I can't find a way to add a song to a profile. Even if you create a new profile, the midi codes (aseri, aseri2 etc) are already configured for it, and I see no way to add a new one, in this case nointro.

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #247 on: 2011-08-01 19:35:53 »
Alright then. An update will be out later today, pending another feature I'm trying to add into the installer (giving the choice of which profile to activate on install).

Armand

  • Guest
Re: FF7Music Installer
« Reply #248 on: 2011-08-02 02:19:50 »
So... I barely got my midis back (well, working again at least) when I posted from September of last year, and I'm a bit skeptical to try this again.... has it gotten any easier?  :?
« Last Edit: 2011-08-02 02:31:35 by Armand »

Covarr

  • Covarr-Let
  • Administrator
  • *
  • Posts: 3938
  • Just Covarr. No "n".
    • View Profile
Re: FF7Music Installer
« Reply #249 on: 2011-08-02 03:15:22 »
Well, I don't know if I solved your particular problem, since when I asked for more info (system specs, etc) you never got back to me. However, I have poured quite a bit of time into various improvements and fixes, and there are currently no known bugs (except the one grim_22 mentioned a few posts ago. I'm surprised nobody noticed it before, and I'm already working on it). Other than that, it should be as simple as installing and running.



HOLD IT! I just released a new version that fixes grim_22's problem, among other things.
NEW VERSION: 1.51.10

Don't forget there's two installers. Use the minimal installer if you just wanna upgrade:
Full installer (MegaUpload, 373.46MB)
Minimal installer (MediaFire, 3.13MB)

Changelog
  • "nointro" is now correctly set up in FF7MUSIC.ini
  • Now requires user to choose a profile to activate when installing. This will not work for custom profiles, which must be reselected in FF7Music after install.
  • Added a picture of Cloud to the installer.
  • Fixed a bug in the uninstaller that caused it not to de-register FF7Music in Windows's uninstaller control panel.

This is a recommended upgrade. If you've got 1.51.4 or later, the minimal installer should be fine to upgrade with.

I don't have any more new features or changes in mind. Unless someone finds another bug, this will probably be the last version until SymphoniC finishes his project. I think it's high time I started a new project.
« Last Edit: 2011-08-02 08:18:14 by Covarr »