Author Topic: FF7 Graphic "garbage" problem..  (Read 3372 times)

Dimon

  • Guest
FF7 Graphic "garbage" problem..
« on: 2010-09-01 08:36:53 »
To whom it may concern,

I had a movie problem with Final Fantasy 7, but i seem to have fixed it with this fix for it located on this page, the opengl drive for FF7:

http://forums.qhimm.com/index.php?topic=8306.0

Unfortanetly, it created a new problem. The problem now seems to be with grapchical garbage sitting around the game. For example, in the opening train fight area, the train appears as a green glob of bricks. Fights seem normal enough, not that i can play very much, as soon as you follow barret to the street area, it gets very hard to even see where cloud is. I got error's from the app.log and ill copy them on here. Also, here is some information that may help ya help me:

OS(Operating System): Windows XP Pro
Service Pack: 3

Here is the errors i receive:

INFO: Vertex info
-----------
Internal error: assembly compile error for vertex shader at offset 2061:
-- error message --
line 71, column 13:  error: invalid operand variable
line 115, column 13:  error: invalid operand variable
line 127, column 24:  error: invalid operand variable
line 128, column 25:  error: invalid operand variable
-- internal assembly text --
!!ARBvp1.0
OPTION NV_vertex_program3;
# cgc version 1.5.0000, build date Aug 28 2006 18:30:31
# command line args:
#vendor NVIDIA Corporation
#version 1.0.02
#profile vp40
#program main
#semantic gl_ModelViewMatrix
#semantic gl_ProjectionMatrix
#semantic vertextype
#semantic blend_mode
#semantic d3dviewport_matrix
#semantic fb_texture
#semantic d3dprojection_matrix
#var float4 gl_Color : $vin.COLOR0 : COLOR0 : -1 : 1
#var float4 gl_Vertex : $vin.POSITION : POSITION : -1 : 1
#var float4 gl_MultiTexCoord0 : $vin.TEXCOORD0 : TEXCOORD0 : -1 : 1
#var float4 gl_Position : $vout.POSITION : HPOS : -1 : 1
#var float4 gl_FrontColor : $vout.COLOR0 : COL0 : -1Vertex info
-----------
Internal error: assembly compile error for vertex shader at offset 2061:
-- error message --
line 71, column 13:  error: invalid operand variable
line 115, column 13:  error: invalid operand variable
line 127, column 24:  error: invalid operand variable
line 128, column 25:  error: invalid operand variable
-- internal assembly text --
!!ARBvp1.0
OPTION NV_vertex_program3;
# cgc version 1.5.0000, build date Aug 28 2006 18:30:31
# command line args:
#vendor NVIDIA Corporation
#version 1.0.02
#profile vp40
#program main
#semantic gl_ModelViewMatrix
#semantic gl_ProjectionMatrix
#semantic vertextype
#semantic blend_mode
#semantic d3dviewport_matrix
#semantic fb_texture
#semantic d3dprojection_matrix
#var float4 gl_Color : $vin.COLOR0 : COLOR0 : -1 : 1
#var float4 gl_Vertex : $vin.POSITION : POSITION : -1 : 1
#var float4 gl_MultiTexCoord0 : $vin.TEXCOORD0 : TEXCOORD0 : -1 : 1
#var float4 gl_Position : $vout.POSITION : HPOS : -1 : 1
#var float4 gl_FrontColor : $vout.COLOR0 : COL0 : -1 : 1
#_├łERROR: failed to load shaders, reverting to fixed function
INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r21874, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: No shaders, codecs with YUV output will be slow.

I also received some kind of shader error that i have no clue what it said as it pops on one second and is gone the next. Please help me. The above opengl patch helped with the movies, but now the game has weird graphics glitches. Thanks for helping me!




A possible fix and a new problem:

Ok, about the above problem, i was experiementing with stuff in compatibility mode on the right tab and found that this setting seems to work:

Verision: Windows 95
Run in 256 colors
Run in 640X480 screen resolution
Disable Visual Themes

I checked all the ones above. It fixed the strange graphical garbage i had floating around in the game, but i have not played it long enough to see if there is more, but at least now i can actually see cloud on the street. The new problem is that when i quit to desktop, all the things on the desktop are frozen at 640X480, so it looks all big. I have to manually find the ff7 program still running (it never shut off apparently) and closed it in the task manager. Not sure what caused that now, or the other problem. Just some annoying things to consider looking into..seems like those are my only 2 problems..so far..
« Last Edit: 2010-09-17 08:10:29 by Dimon »

Senti

  • *
  • Posts: 79
  • There's a fine line between insanity and ingenius
    • View Profile
    • Psychopathic Studios
Re: FF7 Graphic "garbage" problem..
« Reply #1 on: 2010-09-01 14:40:26 »
I would recommend reinstalling to ensure that none of your main files have been glitched, install the official 1.02 patch and then using Aali's lastest custom driver. Just unzip Aali's driver to your FFVII install directory, and run FF7config.exe, wait till it says you're good to go with the driver, select the custom graphics driver and you should be good to go without running any compatibility mode. Just make sure that you have any UAC turned off.

Dimon

  • Guest
Re: FF7 Graphic "garbage" problem..
« Reply #2 on: 2010-09-01 21:46:13 »
What is UAC? And really, i don't mind running it in compatibility mode as long as it works.

Oh, and i have the official version 1.02 patch installed. Did that before i put the other one above on.
« Last Edit: 2010-09-01 21:51:41 by Dimon »

Senti

  • *
  • Posts: 79
  • There's a fine line between insanity and ingenius
    • View Profile
    • Psychopathic Studios
Re: FF7 Graphic "garbage" problem..
« Reply #3 on: 2010-09-01 21:54:28 »
UAC is User Account Control in Vista and 7, if it's turned on then it can prevent the proper alteration of files done by programs. With Aali's drivers you have no need to worry about compatibility mode, in fact I'm running Windows 7 Ultimate 64bit version without any compatibility mode on at 1280x800 with almost 0 problems, only one so far, with a few tweaks to suit my personal tastes, would be Aeris' left hand not loading when she's carrying the basket of flowers after the first bombing mission. Not sure why it's not loading properly but that's the only problem thus far. Well, aside from the main menu splash screen not loading, but that doesn't really matter either, and will be addressed soon.

Aali

  • *
  • Posts: 1196
    • View Profile
Re: FF7 Graphic "garbage" problem..
« Reply #4 on: 2010-09-01 21:57:49 »
You should try updating your nvidia drivers if you haven't already done so. Since you omitted that information from the log output, may I ask what kind of card you have?

Dimon

  • Guest
Re: FF7 Graphic "garbage" problem..
« Reply #5 on: 2010-09-01 22:05:47 »
First, my pc does not have admin account . It is windows xp pro, as i stated above. So i already am "admin" on my pc. Sorry, didn't mean to not omit my graphics card, but i put it on the whole applog and copy it here now. I don't know my graphic card actually because i just bought this pc from my friend. My old xp computer died. Im guessing this is my video card:

NVIDIA Corporation Quadro NVS 210S / NVIDIA GeForce 6150LE/PCI/SSE2/3DNOW! 2.0.1

Since you guys/gals seem the experts, ill try everything you suggested, reinstall, update drivers, as i just seen there from 2006 (OUT OF DATE). Anyways, thanks for the help. Ill get back to you the next problem(s) i have.

One more question, when i reinstall should i install the movie player? Or the direct x drivers? I did not do those last time, and felt they were not relevant to the game at this point, but that maybe my mistake..


Here is the whole log, in case you need to assess the situation more in detail:

Code: [Select]
INFO: FF7/FF8 OpenGL driver version 0.7.8b
INFO: Auto-detected version: FF7 1.02 US English
INFO: NVIDIA Corporation Quadro NVS 210S / NVIDIA GeForce 6150LE/PCI/SSE2/3DNOW! 2.0.1
INFO: OpenGL 2.0 support detected
INFO: Found swap_control extension
INFO: Max texture size: 4096x4096
INFO: Original resolution 640x480, window size 640x480, output resolution 640x480, internal resolution 640x480
INFO: Vertex info
-----------
Internal error: assembly compile error for vertex shader at offset 2061:
-- error message --
line 71, column 13:  error: invalid operand variable
line 115, column 13:  error: invalid operand variable
line 127, column 24:  error: invalid operand variable
line 128, column 25:  error: invalid operand variable
-- internal assembly text --
!!ARBvp1.0
OPTION NV_vertex_program3;
# cgc version 1.5.0000, build date Aug 28 2006 18:30:31
# command line args:
#vendor NVIDIA Corporation
#version 1.0.02
#profile vp40
#program main
#semantic gl_ModelViewMatrix
#semantic gl_ProjectionMatrix
#semantic vertextype
#semantic blend_mode
#semantic d3dviewport_matrix
#semantic fb_texture
#semantic d3dprojection_matrix
#var float4 gl_Color : $vin.COLOR0 : COLOR0 : -1 : 1
#var float4 gl_Vertex : $vin.POSITION : POSITION : -1 : 1
#var float4 gl_MultiTexCoord0 : $vin.TEXCOORD0 : TEXCOORD0 : -1 : 1
#var float4 gl_Position : $vout.POSITION : HPOS : -1 : 1
#var float4 gl_FrontColor : $vout.COLOR0 : COL0 : -1Vertex info
-----------
Internal error: assembly compile error for vertex shader at offset 2061:
-- error message --
line 71, column 13:  error: invalid operand variable
line 115, column 13:  error: invalid operand variable
line 127, column 24:  error: invalid operand variable
line 128, column 25:  error: invalid operand variable
-- internal assembly text --
!!ARBvp1.0
OPTION NV_vertex_program3;
# cgc version 1.5.0000, build date Aug 28 2006 18:30:31
# command line args:
#vendor NVIDIA Corporation
#version 1.0.02
#profile vp40
#program main
#semantic gl_ModelViewMatrix
#semantic gl_ProjectionMatrix
#semantic vertextype
#semantic blend_mode
#semantic d3dviewport_matrix
#semantic fb_texture
#semantic d3dprojection_matrix
#var float4 gl_Color : $vin.COLOR0 : COLOR0 : -1 : 1
#var float4 gl_Vertex : $vin.POSITION : POSITION : -1 : 1
#var float4 gl_MultiTexCoord0 : $vin.TEXCOORD0 : TEXCOORD0 : -1 : 1
#var float4 gl_Position : $vout.POSITION : HPOS : -1 : 1
#var float4 gl_FrontColor : $vout.COLOR0 : COL0 : -1 : 1
#_├łERROR: failed to load shaders, reverting to fixed function
INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r21874, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: No shaders, codecs with YUV output will be slow.
LOCK UNLOCK TEST
MATRIX INITIALIZE
INITIALIZE DD/D3D END
ERROR: could not open file C:\Program Files\Square Soft, Inc.\Final Fantasy VII\ff7input.cfg
initializing sound...
creating dsound primary buffer
reading audio file
loading static sounds
sound initialized
INITIALIZING MIDI...
selecting device 0:Microsoft GS Wavetable SW Synth, mid=1, pid=102,
midi data type: GENERAL MIDI
using midi data file: C:\Program Files\Square Soft, Inc.\Final Fantasy VII\Data\midi\midi.lgp
midiOutGetVolume returned: ffffffff
MIDI INITIALIZED
set music volume: 127
MIDI set volume: 127
100% of 127 = 127
set music volume: 127
MIDI set master volume: 100
MIDI set volume: 127
100% of 127 = 127
Entering MAIN
Exiting MAIN
START OF CREDITS!!!
INFO: D:\FF7\Movies\eidoslogo.avi; truemotion2/pcm_u8 320x240, 15.000000 FPS, duration: 10.133333, frames: 152
set music volume trans: 127->0, step=60
MIDI set volume trans: 127->0; step=60
MIDI stop - OK
INFO: D:\FF7\Movies\sqlogo.avi; truemotion2/pcm_u8 320x224, 15.000000 FPS, duration: 14.533333, frames: 218
MIDI stop - OK
END OF CREDITS!!!
Entering MAIN
set music volume: 127
MIDI set volume: 127
100% of 127 = 127
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
MIDI stop - OK
INFO: D:\FF7\Movies\opening.avi; truemotion2/pcm_u8 320x224, 15.000000 FPS, duration: 119.400000, frames: 1791
MIDI play: 2
reading midi file: OB.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 300
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
MIDI cross fade: 2, time: 4
MIDI set volume trans: 127->127; step=4
MIDI set volume: 127
100% of 127 = 127
set music volume: 127
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
INFO: D:\FF7\Movies\mkup.avi; truemotion2/null 320x224, 15.000000 FPS, duration: 9.000000, frames: 135
MIDI play: 2
song is already playing...
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 303
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
MIDI cross fade: 2, time: 4
MIDI set volume trans: 127->127; step=4
MIDI set volume: 127
100% of 127 = 127
set music volume: 127
MIDI play: 2
song is already playing...
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 306
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
MIDI cross fade: 2, time: 4
MIDI set volume trans: 127->127; step=4
MIDI set volume: 127
100% of 127 = 127
set music volume: 127
set music volume: 127
MIDI set volume: 127
100% of 127 = 127
MIDI play: 6
reading midi file: MAKORO.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
MIDI play: 6
song is already playing...
MIDI play: 6
song is already playing...
Field Quit
Entering MAIN
MIDI play: 7
reading midi file: BAT.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 308
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
MIDI play: 46
reading midi file: FAN2.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
MIDI cross fade: 6, time: 4
MIDI set volume trans: 127->15; step=2
MIDI set volume: 15
100% of 15 = 15
MIDI play: 6
reading midi file: MAKORO.mid
current volume: 15
MIDI set volume trans: 15->127; step=2
MIDI set volume: 127
100% of 127 = 127
MIDI is playing SUCCESSFULLY!!!
set music volume: 127
MIDI play: 6
song is already playing...
MIDI play: 6
song is already playing...
Field Quit
Entering MAIN
MIDI play: 7
reading midi file: BAT.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 322
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
MIDI play: 46
reading midi file: FAN2.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
MIDI cross fade: 6, time: 4
MIDI set volume trans: 127->15; step=2
MIDI set volume: 15
100% of 15 = 15
MIDI play: 6
reading midi file: MAKORO.mid
current volume: 15
MIDI set volume trans: 15->127; step=2
MIDI set volume: 127
100% of 127 = 127
MIDI is playing SUCCESSFULLY!!!
set music volume: 127
Field Quit
Entering MAIN
MIDI play: 7
reading midi file: BAT.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 323
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
MIDI play: 46
reading midi file: FAN2.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
MIDI cross fade: 6, time: 4
MIDI set volume trans: 127->15; step=2
MIDI set volume: 15
100% of 15 = 15
MIDI play: 6
reading midi file: MAKORO.mid
current volume: 15
MIDI set volume trans: 15->127; step=2
MIDI set volume: 127
100% of 127 = 127
MIDI is playing SUCCESSFULLY!!!
set music volume: 127
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
WM_CLOSE
END OF MENU SYSTEM!!!
Field Quit
MIDI stop - OK
resetting MIDI driver volume - OK
UNINITIALIZE DD



Another new problem and a new error...

I did everything as noted above in the previous post

1. Got the most recent video card drivers from Nividia.com
2. Reinstalled the game
3. Patched it to 1.02
4. Installed open gl version 7.8b


I turned off Comatibiliy mode to test it out on these fresh installation. When i go to the mako reactor on the street, all you see is cloud's hair filling the whole screen. It is like cloud got real big and is now blocking the rest of the graphics out. Thru cloud's spikey hair, i can still see edges of buildings and the other members of Avalanche. What's even more strange is when the movie is supposed to close up on cloud looking at the mako reactor, it looks like it close uped on his foot :-o

On the next screen, he apparently ate that candy from "Alice in Wonderland" and shrunk back down to normal size. I have no clue what caused this problem, but it happened only after the new installation and new video drivers.

UPDATE: I still have the "big cloud" problem where he is soo big in certain maps, he blocks the screen out. I may just play in "Compatibility mode". Thanks for all your help people!
« Last Edit: 2010-09-22 03:21:35 by Dimon »

obesebear

  • Administrator
  • *
  • Posts: 1361
    • View Profile
Re: FF7 Graphic "garbage" problem..
« Reply #6 on: 2010-09-02 01:01:25 »
2 double posts?  are you serious?  Also, if you're going to type/paste a sh*t ton of code, please add {code} your information here {/code} but use brackets.  Hurray.

Dimon

  • Guest
Re: FF7 Graphic "garbage" problem..
« Reply #7 on: 2010-09-02 04:24:58 »
Sorry..i did not mean to double post. I am new here. Plus, i thought the information was relevent because it discussed a new problem i had. I only put the "whole code" there because someone asked why i omitted part of the "APPLOG" earlier, and i wanted to be helpful to others helping me in order not to miss anything important. I apologize.

I also did not know how to do that code thing you do. I am sorry.
« Last Edit: 2010-09-02 04:28:49 by Dimon »