Author Topic: SOLVED: Trouble with window mode  (Read 8950 times)

elque

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
SOLVED: Trouble with window mode
« on: 2011-05-09 02:58:02 »
i follow this steps

**********
Installation notes:

Two things you need before installation

1. game updated to version 1.02
2. you must create a save game for each save game slot this can be done through copy and paste and rename to save00, save01, save02, save03... all the way up to save09 (all with extension .ff7)

installation notes

1. extract .rar file
2. copy and paste all contents into your ff7 installation folder (if you have already played up until the first save in the game then you do not need "ff7input.cfg"
3. run ff7 config
4. click graphics, you should get a messgae saying "self test passed." click ok
5. go to ff7opengl right click and edit or open in notepad
6.scroll down to

# set the window size (and fullscreen resolution) of FF7
# 0 means use original resolution (whatever ff7.exe provides)
# preserve_aspect adds black borders as needed to preserve a 4:3 aspect ratio
window_size_x = 1280
window_size_y = 800
preserve_aspect = yes
fullscreen = no

7. edit the x and y ratio's to the resolution you want the game to run in
8. save this and run the game
**********************************************


when i added the mod of aali i got this message

"opengl renderer appears to be the microsoft software renderer. your graphics drivers are probably not installed correctly. expect extreme lag"

i put the game in windows mode and is going extremely slow. what can i do to play the game in normal speed?

I just want the game to work great in window mode. i didnt added any other mod other than this.

« Last Edit: 2011-05-10 11:13:50 by Bosola »

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 4067
  • Karma: 124
  • Just Covarr. No "n".
    • View Profile
Re: Trouble with window mode
« Reply #1 on: 2011-05-09 04:58:36 »
1. What rar file is this? I don't recognize those install notes. It's possible it contains an outdated version of Aali's driver. That's probably not the problem, but it's generally better to use the latest version, and get it from this page.

2. Make absolutely sure your computer's video card drivers are up-to-date. Do not rely on Windows Update to do this, as it is not always reliable or adequately updated; instead get them from the manufacturer's website (Intel, NVIDIA, AMD/ATI)

elque

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: Trouble with window mode
« Reply #2 on: 2011-05-09 05:01:57 »
which aali driver should i use? im running on windows 7, AMD/ATI (radeon)

is there a step by step to this a really good one that explains to use windows mode for ff7?
« Last Edit: 2011-05-09 05:46:46 by elque »

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 4067
  • Karma: 124
  • Just Covarr. No "n".
    • View Profile
Re: Trouble with window mode
« Reply #3 on: 2011-05-09 06:38:57 »
which aali driver should i use? im running on windows 7, AMD/ATI (radeon)

is there a step by step to this a really good one that explains to use windows mode for ff7?
Generally, you should use the latest version of Aali's driver. Currently, this is v0.7.10b

From your post, it looks like you did the setup correctly, as FF7 is clearly running in a window. Again, you will want to make sure your VIDEO CARD DRIVERS (not Aali's driver for the game) are up-to-date, you can probably grab the latest from AMD's website.

On a mostly unrelated note, the latest version of Aali's driver has minor issues with ATI and AMD cards (not this slowdown, but a different problem you're likely to run into). This can be avoided by setting "compress_textures = no" in ff7_opengl.cfg

elque

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: Trouble with window mode
« Reply #4 on: 2011-05-09 17:57:18 »
hmmmm now i got a bigger problem, i uninstalled the game to start over. it uninstalled perfect. now when i start disc 1 the setup starts, then it disappear and it closes. It doesn't go beyond the install button. What should i do?


Jaitsu

  • No life
  • *
  • Posts: 1074
  • Karma: 0
  • DON'T FWOOSH ME BRO
    • View Profile
    • Jaitsu Studios
Re: Trouble with window mode
« Reply #5 on: 2011-05-09 18:16:45 »
hmmmm now i got a bigger problem, i uninstalled the game to start over. it uninstalled perfect. now when i start disc 1 the setup starts, then it disappear and it closes. It doesn't go beyond the install button. What should i do?



did you restart after uninstalling first of all?

elque

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: Trouble with window mode
« Reply #6 on: 2011-05-09 18:18:49 »
yes i uninstall last night, turn off my pc and i turn it on this morning.

Update:

I restarted my pc 8x, to install ff7 as an admin in which it did. i updated aali driver. now im getting this message

« Last Edit: 2011-05-09 20:32:16 by elque »

BPLD

  • And then it dawned on me, that Satan is also an old fuck.
  • Freak
  • *
  • Posts: 898
  • Karma: -41
    • View Profile
Re: Trouble with window mode
« Reply #7 on: 2011-05-09 20:50:18 »
update your graphics card drivers.

Sorry to be a douche about it, but Covarr mentioned this many times, and you seem to be ignoring it.  Maybe you wouldn't have so many problems if you listened to people who give you advice.

elque

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: Trouble with window mode
« Reply #8 on: 2011-05-09 21:39:08 »



i did.

sl1982

  • Administrator
  • No life
  • *
  • Posts: 3696
  • Karma: 43
  • GUI Master :P
    • View Profile
Re: Trouble with window mode
« Reply #9 on: 2011-05-09 21:47:09 »
Given the fact that that driver name shows microsoft after it would make me believe it contains only directx drivers and not open gl. Did you get that from the amd site or windows update? If it is windows update go download the drivers from amd.

BPLD

  • And then it dawned on me, that Satan is also an old fuck.
  • Freak
  • *
  • Posts: 898
  • Karma: -41
    • View Profile
Re: Trouble with window mode
« Reply #10 on: 2011-05-09 21:48:58 »
CONGRATULATIONS ELQUE, YOU DON'T KNOW HOW TO READ.

2. Make absolutely sure your computer's video card drivers are up-to-date. Do not rely on Windows Update to do this, as it is not always reliable or adequately updated; instead get them from the manufacturer's website (Intel, NVIDIA, AMD/ATI)

2. Make absolutely sure your computer's video card drivers are up-to-date. Do not rely on Windows Update to do this, as it is not always reliable or adequately updated

Do not rely on Windows Update to do this, as it is not always reliable or adequately updated

Do not rely on Windows Update



That looks a hell of a lot like Windows Update to me

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 4067
  • Karma: 124
  • Just Covarr. No "n".
    • View Profile
Re: Trouble with window mode
« Reply #11 on: 2011-05-09 22:05:49 »
The graphics driver that Windows Update has given you is probably horribly outdated.

Technically, your card is not even supported under Windows 7, however you can install the final version of their Legacy Drivers for Vista and should have some degree of success.

elque

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: Trouble with window mode
« Reply #12 on: 2011-05-09 22:37:43 »
I finally got the extreme lag message not to appear..the graphic update from windows and the update from amd website didn't help, so i try the update from this site: http://it-nthusiast.blogspot.com/2009/12/ati-radeon-x300-aero-on-windows-7vista.html and it work like a charm.

now i have another problem the game now plays like this...but when i play full screen and not using the custom aali mod the game plays normal.




I do apologize for asking for help. It's like i solve one problem and another one appears. Thanks for everyone on this thread.
« Last Edit: 2011-05-09 22:43:25 by elque »

BPLD

  • And then it dawned on me, that Satan is also an old fuck.
  • Freak
  • *
  • Posts: 898
  • Karma: -41
    • View Profile
Re: Trouble with window mode
« Reply #13 on: 2011-05-09 22:47:15 »
turn off texture caching

elque

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: Trouble with window mode
« Reply #14 on: 2011-05-09 22:54:16 »
turn off texture caching

do u mean this?

"# store external textures in a compressed cache for increased performance
# compression is not lossless, some artifacts may appear when this option is in use
# texture cache does NOT update automatically if the source image changes, however, deleting anything from the cache
# will cause that file to be recreated from the source
compress_textures = no"

if so, i already turn it off

sl1982

  • Administrator
  • No life
  • *
  • Posts: 3696
  • Karma: 43
  • GUI Master :P
    • View Profile
Re: Trouble with window mode
« Reply #15 on: 2011-05-09 23:09:12 »
Can we see a copy of your app.log please.

Armorvil

  • Freak
  • *
  • Posts: 621
  • Karma: 0
  • Working on : FFVII Total Grudge
    • View Profile
Re: Trouble with window mode
« Reply #16 on: 2011-05-09 23:10:22 »
It's a problem with some ATI drivers combined with Aali's custom driver v0.7.10b. I also have a Radeon and had the same problem. I fixed it by going to AMD's website, and used the "search drivers" feature to install the latest pack.

Here is the page where I mention the problem. It's reply 55.

Here is the thread where I mention how I solved the problem. It's reply 110.
« Last Edit: 2011-05-09 23:12:05 by Armorvil »

sl1982

  • Administrator
  • No life
  • *
  • Posts: 3696
  • Karma: 43
  • GUI Master :P
    • View Profile
Re: Trouble with window mode
« Reply #17 on: 2011-05-09 23:12:38 »
Unfortunately he has a very old graphics card that is not really supported in windows 7. At least not with the normal catalyst drivers.

Armorvil

  • Freak
  • *
  • Posts: 621
  • Karma: 0
  • Working on : FFVII Total Grudge
    • View Profile
Re: Trouble with window mode
« Reply #18 on: 2011-05-09 23:15:39 »
In that case, maybe a better fix for him would be to use a previous version of the custom driver.

elque

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: Trouble with window mode
« Reply #19 on: 2011-05-09 23:48:56 »
AFTER all this work and days I finally found a solution

here's how i solve my problem:

i updated my graphic card like u guys told me, i didn't use windows update or amd. i updated by using a program call "drivermax" to update my graphic card. Then to fix the texture i downgraded the aali driver to (v0.78b).

Thanks to everyone who replied to this thread. Greatly appreaciated.

sl1982

  • Administrator
  • No life
  • *
  • Posts: 3696
  • Karma: 43
  • GUI Master :P
    • View Profile
Re: Trouble with window mode
« Reply #20 on: 2011-05-10 01:07:34 »
Glad we could help.

Bosola

  • Fire hazard!
  • No life
  • *
  • Posts: 1770
  • Karma: 15
    • View Profile
    • My YouTube Channel
Re: Trouble with window mode
« Reply #21 on: 2011-05-10 11:09:12 »
Closed as solved.