Author Topic: [FF7] Tutorial for Bootleg - Tifa's Bootleg  (Read 1834319 times)

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 3044
  • Karma: 210
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: [Tutorial] Tifa's Bootleg
« Reply #1775 on: 2013-11-03 19:57:44 »
I don't have time to test the game every time a Windows or video driver update is done, but in the past people have discovered certain updates that don't work with the game. It could very well be something you updated in between play times that has caused it to go bonkers.

leadwing85

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1776 on: 2013-11-08 17:09:44 »
hello, this looks to be an amazing project, I researched it and am ready to give it a go. However I fail upon Step 1 outlined in this tutorial.

I mount install image and install fine, I install old video drivers fine. I test play and everything works fine as in original.

then I download the required  FF7_GameConverter_0.9b.exe as specified in tutorial outline and install in game root directory. here -> http://forums.qhimm.com/index.php?topic=14047.msg196959#msg196959 it states you should run the game once before applying any mods with the bootleg.

I check as admin and proceed to run, BUT I get an error stating there is a error and cant run full screen/ reverting to original resolution. I click ok and then it say that the application has stopped working and it closes the program.

I have tried all number of settings in the ff7 config in attempts to get it working so I can then add the redone character models ect, but im either met with the same failure, or it fails to open anything whatsoever.

any help at all is much appretiated, shoot me a PM, im happy to anyswer any questions about my process of install ect. thanks

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 3044
  • Karma: 210
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: [Tutorial] Tifa's Bootleg
« Reply #1777 on: 2013-11-08 23:59:06 »
I never run the game in between FF7GC and Bootleg for the 1998 version and all is well. Bootleg will patch the game to 1.02 and install the correct cfg files to work with Aali's driver, and it's best to adjust cfg settings and run the game through FF7 Bootloader after Bootleg finishes. I would just skip running the game, go straight to STEP 2, and report back once you've finished installing Bootleg.

Akitu

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1778 on: 2013-11-09 22:19:18 »
Wow, I'm not sure why, but your profile fixed my problem exactly. I tried making one myself and it didn't resolve my issue, comparing the two I see no differences in how they were configured. I'll chalk it up to a new user experience.

My final conflict I'm having now is that my game is showing a black bar approx 1" thick on the bottom end of the screen, the resolution is a match to my monitor at 1920x1080, and it's only occurring on the field. Menus and battles do not have this issue.

I checked the FAQ page and did not see this issue, anyone have a tip for me? Loving it now so far, thanks once again for all the hard work that went into this!

Apologies to those who are helping me for the awkward time gaps between my posts, RL is a real pain sometimes.

I've searched the forums and can't seem to see anything relating to mini games having excessive frame rates? eg. The coaster game is running at 202-206 fps as did the first motorcycle game after exiting Shinra HQ. I see no options to limit the frame rate of the mini games anywhere, can anyone help me with that? My bar at the bottom was there because I was using the preserve aspect ratio button option, a little bit of playing around resolved that for me.

nvno

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1779 on: 2013-11-14 15:34:28 »
Hello i followed everything in the guide but when i start the game, after the squaresoft intro, when the music starts playing, my screen goes black with several red triangles and when i click Enter the game goes black. I've installed AMD Catalyst 13.8 Beta2 Driver for Windows and the same still happens.

APPLOG:
Code: [Select]
INFO: FF7/FF8 OpenGL driver version 0.7.11b
INFO: Auto-detected version: FF7 1.02 US English
INFO: ATI Technologies Inc. ATI Radeon HD 5800 Series 4.2.12217 Compatibility Profile Context 12.104.0.0
INFO: OpenGL 2.0 support detected
INFO: Using PBO
INFO: Found swap_control extension
INFO: Max texture size: 16384x16384
INFO: Number of texture units: 8
INFO: Original resolution 640x480, window size 1920x1080, output resolution 1440x1080, internal resolution 3840x2160
INFO: FBO extension detected, using fast scaling/postprocessing path
INFO: Shader limits: varying 128, vert uniform 16384, frag uniform 16384
INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: FF7Music helper plugin loaded
INFO: Loading external library Multi.dll
LOCK UNLOCK TEST
MATRIX INITIALIZE
INITIALIZE DD/D3D END
ERROR: could not open file C:\Games\Steam\steamapps\common\FINAL FANTASY VII\ff7input.cfg
initializing sound...
creating dsound primary buffer
reading audio file
loading static sounds
sound initialized
set music volume: 127
set music volume: 127
Entering MAIN
Exiting MAIN
START OF CREDITS!!!
INFO: C:\Games\Steam\steamapps\common\FINAL FANTASY VII\movies\eidoslogo.avi; indeo5/pcm_s16le 640x480, 30.000000 FPS, duration: 12.933333, frames: 388
INFO: slow output format from video codec indeo5; 6
INFO: C:\Games\Steam\steamapps\common\FINAL FANTASY VII\movies\sqlogo.avi; h264/aac 1280x896, 15.000000 FPS, duration: 14.533333, frames: 218
set music volume: 127
set music volume trans: 127->0, step=60
END OF CREDITS!!!
Entering MAIN
set music volume: 127
Exiting MAIN
START OF MENU SYSTEM!!!
WM_CLOSE
END OF MENU SYSTEM!!!
Field Quit
UNINITIALIZE DD
END UNINITIALIZE DD


UPDATE: IT seems to work when in the configuration menu i unchecked Shaders...

Would still appreciate  some help tho (:
« Last Edit: 2013-11-14 17:35:50 by nvno »

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 3044
  • Karma: 210
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: [Tutorial] Tifa's Bootleg
« Reply #1780 on: 2013-11-14 19:52:29 »
I don't have any confirmation from others on the 13.8 Beta2 drivers working. We know 13.8 Beta and 13.5 Beta2 drivers work, and I updated the download links to them in the FAQ section. Try them out and let me know your results.

nvno

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1781 on: 2013-11-15 01:18:48 »
one of the links sends me to Beta2 and the other is unavailable ):

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 3044
  • Karma: 210
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: [Tutorial] Tifa's Bootleg
« Reply #1782 on: 2013-11-15 02:03:15 »
They work fine for me. The downloads are from guru3d. I found them with a search on Google, so you can do the same.

Practicedummy

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1783 on: 2013-11-15 16:09:26 »
I am having a problem with the in-game volume controls not working. No matter where I adjust the slider to, the music volume remains the same.
« Last Edit: 2013-11-15 16:19:13 by Practicedummy »

tifalockheart1983

  • Cool newbie
  • *
  • Posts: 81
  • Karma: -3
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1784 on: 2013-11-20 15:37:04 »
I am having a problem with the in-game volume controls not working. No matter where I adjust the slider to, the music volume remains the same.

Have you tried using the volume control in the music mod itself because I believe that the mod overrides the game music controls.

nvno

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1785 on: 2013-11-20 16:54:59 »
Well the download links from guru send me to AMD page, one of them sends me to version2 and the other is unavailable. i cant seem to find links for either of these drivers elsewhere. But thats alright i can play without shaders. Thanks for your support anyway (:

UPDATE: ok during the raid on midgar on disc2 when battling rude and the others my game crashes with an error message... is it because of the drivers?

Code: [Select]
INFO: FF7/FF8 OpenGL driver version 0.7.11b
INFO: Auto-detected version: FF7 1.02 US English
INFO: ATI Technologies Inc. ATI Radeon HD 5800 Series 4.2.12217 Compatibility Profile Context 12.104.0.0
INFO: Using PBO
INFO: Found swap_control extension
INFO: Max texture size: 16384x16384
INFO: Number of texture units: 8
INFO: Original resolution 640x480, window size 1920x1080, output resolution 1440x1080, internal resolution 3840x2160
INFO: FBO extension detected, using fast scaling/postprocessing path
INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: No shaders, codecs with YUV output will be slow.
INFO: FF7Music helper plugin loaded
INFO: Loading external library Multi.dll
LOCK UNLOCK TEST
MATRIX INITIALIZE
INITIALIZE DD/D3D END
initializing sound...
creating dsound primary buffer
reading audio file
loading static sounds
sound initialized
set music volume: 127
set music volume: 127
Entering MAIN
Exiting MAIN
START OF CREDITS!!!
INFO: C:\Games\Steam\steamapps\common\FINAL FANTASY VII\movies\eidoslogo.avi; indeo5/pcm_s16le 640x480, 30.000000 FPS, duration: 12.933333, frames: 388
INFO: slow output format from video codec indeo5; 6
set music volume trans: 127->0, step=60
END OF CREDITS!!!
Entering MAIN
set music volume: 127
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
GLITCH: missed palette write to external texture field/tunnel_5/tunnel_5_15
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 833
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
set music volume: 127
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 831
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
set music volume: 127
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 830
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
set music volume: 127
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 833
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
set music volume: 127
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
fade music volume: 127->0, step=60
set music volume: 127
set music volume trans: 127->0, step=60
fade music volume: 0->127, step=1
set music volume: 0
set music volume trans: 0->127, step=1
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 840
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
ERROR: unhandled exception
« Last Edit: 2013-11-20 17:42:04 by nvno »

tifalockheart1983

  • Cool newbie
  • *
  • Posts: 81
  • Karma: -3
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1786 on: 2013-11-20 20:25:34 »
Well the download links from guru send me to AMD page, one of them sends me to version2 and the other is unavailable. i cant seem to find links for either of these drivers elsewhere. But thats alright i can play without shaders. Thanks for your support anyway (:

UPDATE: ok during the raid on midgar on disc2 when battling rude and the others my game crashes with an error message... is it because of the drivers?

Code: [Select]
INFO: FF7/FF8 OpenGL driver version 0.7.11b
INFO: Auto-detected version: FF7 1.02 US English
INFO: ATI Technologies Inc. ATI Radeon HD 5800 Series 4.2.12217 Compatibility Profile Context 12.104.0.0
INFO: Using PBO
INFO: Found swap_control extension
INFO: Max texture size: 16384x16384
INFO: Number of texture units: 8
INFO: Original resolution 640x480, window size 1920x1080, output resolution 1440x1080, internal resolution 3840x2160
INFO: FBO extension detected, using fast scaling/postprocessing path
INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: No shaders, codecs with YUV output will be slow.
INFO: FF7Music helper plugin loaded
INFO: Loading external library Multi.dll
LOCK UNLOCK TEST
MATRIX INITIALIZE
INITIALIZE DD/D3D END
initializing sound...
creating dsound primary buffer
reading audio file
loading static sounds
sound initialized
set music volume: 127
set music volume: 127
Entering MAIN
Exiting MAIN
START OF CREDITS!!!
INFO: C:\Games\Steam\steamapps\common\FINAL FANTASY VII\movies\eidoslogo.avi; indeo5/pcm_s16le 640x480, 30.000000 FPS, duration: 12.933333, frames: 388
INFO: slow output format from video codec indeo5; 6
set music volume trans: 127->0, step=60
END OF CREDITS!!!
Entering MAIN
set music volume: 127
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
GLITCH: missed palette write to external texture field/tunnel_5/tunnel_5_15
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 833
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
set music volume: 127
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 831
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
set music volume: 127
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 830
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
set music volume: 127
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 833
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
[BATTLE] End of current battle
[BATTLE] Begin end battle stuff
stop_sound
[BATTLE] Entering FRAME_QUIT
[BATTLE] endof battle.
[BATTLE] Exitting FRAME_QUIT
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
cross play music: 0
set music volume trans: 127->0, step=4
set music volume: 127
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
fade music volume: 127->0, step=60
set music volume: 127
set music volume trans: 127->0, step=60
fade music volume: 0->127, step=1
set music volume: 0
set music volume trans: 0->127, step=1
Field Quit
Entering MAIN
Exiting MAIN
Entering FRAME_INITIALIZE SWIRL
Exitting FRAME_INITIALIZE SWIRL
Swirl sound_effect1
stop_sound
End of Swirl sound_effect1
Entering FRAME_QUIT SWIRL
Exitting FRAME_QUIT SWIRL
Entering MAIN
Exiting MAIN
[BATTLE] Entering FRAME_INITIALIZE
[BATTLE] Scene# 840
[BATTLE] Exitting FRAME_INITIALIZE
[BATTLE] Begin main battle loop
ERROR: unhandled exception

You have a unhandled error message those usually come with some error number, if it did would be useful to know what that error number is.

nvno

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1787 on: 2013-11-20 20:36:27 »
lol... well somehow when i tried again to try and see the error message again i actually finished the battle with no problems. weird :S
thank you for the answer thou!

NeedlesKane

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1788 on: 2013-11-29 16:41:08 »
I am a newb with the Final Fantasy VII PC version, which I bought yesterday during the Steam sale. However, I am not a newb to the game, which I bought the day it was released on PlayStation back when I was a senior in high school.

I really appreciate all of the hard work everyone has put together with these mods, and they made me excited to play the game again. Now after following the directions illustrated on this page I have encountered a couple of problems so I have some questions, one somewhat unrelated.

1. I have monitors with 2 different resolutions connected to my computer with max resolutions of 1920x1080 and 1920x1200. When using these resolutions I am left with a black bar at the bottom of the screen that bugs me. I have deselected "Preserve Aspect" in the Bootloader and expected the image to stretch out across the screen. However, I am not receiving my desired results. I am guessing that the game was designed with the taskbar in mind on the bottom of the screen, and this mod is just stretching the game horizontally. I am just guessing that this is the case.

2. In the Bootloader I do not have any modes installed even though I did install Gjoerulv's Hardcore Mod, following the directions in the tutorial.

3. I want to use my Xbox 360 controller to play the game, and I am surprised that when I am mapping the controls using Xpadder they're not working the same way as expected. I can use the analog for moving around, but I can't use the d-pad for doing the same even though it is mapped out. Also the 0 key on the numpad is cancel and also makes me run. However, the enter key bound to the B button on my 360 controller makes me run. It seems like there are some conflicting controls stored somewhere for the game. The strange thing is that my 360 controller did nothing until I launched and configured Xpadder.

Note: Running Windows 8.1 Pro 64-bit with Media Center and my video card is an Sapphire Radeon HD 6970 2GB with the Catalyst 13.11 drivers installed.
« Last Edit: 2013-11-29 16:55:22 by NeedlesKane »

Arkais

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1789 on: 2013-11-30 15:07:16 »
First of all, thank you to everyone involved in all of these mods, as well as posting a comprehensive torrent to collect them and an explanation as to how to install them! I recently bought the Steam version and found this thread on how to mod the game. I downloaded everything, and followed the instructions (as near as I can figure). Everything installed without errors and in the same fashion as described in the screenshots and original post. When I start the game, I get the Eidos and Square logo movies, and the FF crystal theme starts playing. The game then fades to a whitish screen, and I can see the "New Game" and "Continue" in the middle of the screen with the pointer, and there is no picture, and the screen is almost all white, and at this point, the music stops, and the game is frozen. Any ideas on what is causing this? I attempted to search this thread, but it is gargantuan and I had not seen this issue posted. Any help would be appreciated, thanks!

Arkais

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1790 on: 2013-11-30 15:17:01 »
Nevermind! Updating my graphics drivers to the newest actually seems to have solved that problem.

Zweistar

  • Fast newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1791 on: 2013-12-02 19:41:37 »
Okay so, I thought this would be  simple (if a bit time consuming), and did everything step by step, but suddenly I'm getting errors, and the game won't even let me start because the menu isn't working.

Here's my APP log:
Code: [Select]
INFO: FF7/FF8 OpenGL driver version 0.7.11b
INFO: Auto-detected version: FF7 1.02 US English
INFO: ATI Technologies Inc. AMD Radeon HD 7640G 4.2.11476 Compatibility Profile Context
INFO: OpenGL 2.0 support detected
INFO: Found swap_control extension
INFO: Max texture size: 16384x16384
INFO: Number of texture units: 8
INFO: Original resolution 640x480, window size 640x480, output resolution 640x480, internal resolution 640x480
INFO: FBO extension detected, using fast scaling/postprocessing path
INFO: Shader limits: varying 128, vert uniform 16384, frag uniform 16384
INFO: vertex shader compile log:
Vertex shader was successfully compiled to run on hardware.

INFO: fragment shader compile log:
Fragment shader was successfully compiled to run on hardware.

INFO: main program link log:
Vertex shader(s) linked, fragment shader(s) linked.

INFO: fragment shader compile log:
Fragment shader was successfully compiled to run on hardware.

INFO: postprocessing program link log:
Fragment shader(s) linked.

INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
LOCK UNLOCK TEST
MATRIX INITIALIZE
INITIALIZE DD/D3D END
ERROR: could not open file C:\Users\Admin\Desktop\Steam\SteamApps\common\FINAL FANTASY VII\ff7input.cfg
initializing sound...
creating dsound primary buffer
reading audio file
loading static sounds
sound initialized
INITIALIZING MIDI...
selecting device 0:Microsoft GS Wavetable Synth, mid=1, pid=27,
midi data type: GENERAL MIDI
using midi data file: C:\Users\Admin\Desktop\Steam\SteamApps\common\FINAL FANTASY VII\Data\midi\midi.lgp
midiOutGetVolume returned: ffffffff
MIDI INITIALIZED
set music volume: 127
MIDI set volume: 127
100% of 127 = 127
set music volume: 127
MIDI set master volume: 100
MIDI set volume: 127
100% of 127 = 127
Entering MAIN
Exiting MAIN
START OF CREDITS!!!
ERROR: couldn't open movie file: C:\Users\Admin\Desktop\Steam\SteamApps\common\FINAL FANTASY VII\movies\eidoslogo.avi
ERROR: couldn't open movie file: C:\Users\Admin\Desktop\Steam\SteamApps\common\FINAL FANTASY VII\movies\sqlogo.avi
set music volume: 127
MIDI set volume: 127
100% of 127 = 127
MIDI play: 95
reading midi file: PRE.mid
current volume: 127
MIDI is playing SUCCESSFULLY!!!
set music volume trans: 127->0, step=60
MIDI set volume trans: 127->0; step=60
MIDI stop - OK
MIDI stop - OK
END OF CREDITS!!!
Entering MAIN
set music volume: 127
MIDI set volume: 127
100% of 127 = 127
Exiting MAIN
START OF MENU SYSTEM!!!
ERROR: COULD NOT CHANGE TO DIRECTORY C:\Users\Admin\Desktop\Steam\SteamApps\common\FINAL FANTASY VII\save
WM_CLOSE
END OF MENU SYSTEM!!!
Field Quit
MIDI stop - OK
resetting MIDI driver volume - OK
UNINITIALIZE DD

Any idea what I did wrong?

Rundas

  • Freak
  • *
  • Posts: 728
  • Karma: 15
  • What do you even do?
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1792 on: 2013-12-02 19:49:00 »
You must install it outside of Steam folders or system folders.

cmh175

  • Freak
  • *
  • Posts: 869
  • Karma: 66
    • View Profile
    • Chris Hendrickson's Artstation
Re: [Tutorial] Tifa's Bootleg
« Reply #1793 on: 2013-12-02 20:26:36 »
Probably not on the desktop either. You're best bet is c:\games\final fantasy 7\ff7, and final fantasy 7\ff7 mods for bootleg.

Zweistar

  • Fast newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1794 on: 2013-12-02 20:30:27 »
So would I have to reinstall it, or just move it and do all the bootlegger stuff again?

cmh175

  • Freak
  • *
  • Posts: 869
  • Karma: 66
    • View Profile
    • Chris Hendrickson's Artstation
Re: [Tutorial] Tifa's Bootleg
« Reply #1795 on: 2013-12-02 21:02:51 »
I'd reinstall first, you cant really move software installation files around without it causing issues.

Zweistar

  • Fast newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1796 on: 2013-12-02 21:11:16 »
Well, I can't choose where it installs because I have the steam version and it automatically puts it in steamapps\common. So even if I do reinstall, what good does it do?

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 4057
  • Karma: 124
  • Just Covarr. No "n".
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1797 on: 2013-12-02 21:29:51 »
If you have another HDD, you can set up a second Steam library on there in whatever directory you want. I've got one in D:\SteamLibrary, and I don't have the concerns that come with installing things in Program Files.

Zweistar

  • Fast newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1798 on: 2013-12-02 21:38:29 »
Well, I reread the instructions, and from what I can tell, a steam library is fine so long as it's not in program files or a system folder. My steam installation is on my desktop, so I see no issue with the location.

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 4057
  • Karma: 124
  • Just Covarr. No "n".
    • View Profile
Re: [Tutorial] Tifa's Bootleg
« Reply #1799 on: 2013-12-02 22:55:30 »
The desktop is a system folder. It may not seem like it, but programs do treat it differently than other folder, as does Windows, and you are quite likely to run into issues there.