Author Topic: FF7 Removing the hand indicator from [ASSIST] / SELECT in the field  (Read 5772 times)

Zuljin

  • *
  • Posts: 2
    • View Profile
UPDATE:
I got this mod working.  You can download it here:
http://www.mediafire.com/?o8x72f8p8pyo9ig

-------

I'm trying to remove the giant "You Are Here" hand indicator from the [ASSIST] (Select button on the playstation) from the PC version.


I believe I found the files that need to be changed and tried to mod them.  I was able to remove the hand, but the triangle indicators become the wrong color.  I'm guessing one of the tools that I'm using is not outputting the right format and it's screwing up the color.



If it makes a difference, I'm using the 2012 re-release of FF7.  Here are the steps I did:
  • Used ulgpGUI v0.5 to extract the tex files from Final Fantasy VII\data\field\flevel.lgp
A note: The wiki said flevel is the only one used, so fflevel, gflevel, sflevel were unchanged. Not sure what they do since the textures seemed to be the same in all of them.
  • Used Biturn 0.87 beta 4 (linked from the wiki) to convert hand.tex and hand_1.tex to BMP
  • Used photoshop to black out the hand in hand.bmp and hand_1.bmp
Photoshop seemed to change the header file even when I made no changes.
Code: (Unmodified hand.bmp header) [Select]
42 4D 36 0C 00 00 00 00 00 00 36 04 00 00 28 00 00 00 80 00 00 00 10 00 00 00 01 00 08 00 00 00 00 00 80 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Code: (Photoshop header of hand.bmp) [Select]
42 4D 38 0C 00 00 00 00 00 00 36 04 00 00 28 00 00 00 80 00 00 00 10 00 00 00 01 00 08 00 00 00 00 00 02 08 00 00 12 0B 00 00 12 0B 00 00 00 00 00 00 00 00 00 00 00 00 00 00So I used a hexeditor to change the header of my modified BMP files to match the exported originals from Biturn.
I was missing comdlg32.ocx since I'm using Windows 7 64bit, so I downloaded it from a site and copied it to Windows\SysWOW64 and registered it.  I kept the "Color 0 as transparent" option checked in the program.
  • Copied my modified tex files to the dumped files from ulgpGUI.  Switched it to the encode mode and made my modified flevel.lgp
  • Started the game and I get the 2nd picture of my post

Can anyone help me with this problem?  It seems like there could be an easier way to do this without going through the 4 different programs to get it, but I just started reading this site a few days ago and I don't know which tools are the best to use yet.

I also tried using CheatEngine to see which values are changed when I press [ASSIST].  I narrowed it down to 4 memory addresses and tried to monitor which assembly instructions were modifying them, but it was starting to get really complicated trying to go through the assembly which was why I tried just changing the texture instead.  If there was an instruction I could change to achieve the same effect, I would be fine with that method too.

I tried saving the modified image as a GIF instead of BMP before converting back to a tex file and I got the exact same file, so I don't think modifying the header is the reason for the wrong color.
I think the problem is that the BMPs that I get from Biturn are the same color as what I am getting in-game.  The game is converting the purple, blue, and gray into the red color, but not for the modified image that I made.  I think it could be related to this other thread.  The picture below is a 400% larger and cropped version of hand_1.bmp that I am getting from Biturn.
« Last Edit: 2012-08-28 02:32:05 by Zuljin »

PitBrat

  • *
  • Posts: 1376
  • Change to feed the machine.
    • View Profile
You could accomplish the same thing with Aali's OpenGL driver.
Just replace the assist hand graphic with a blank image.
All you'd need to do is modify a .png file and place it in the mods folder.


ff7_opengl-0.7.11b.zip                          Aali            OpenGL Driver from the god              Qhimm FILE MIRROR MIRROR


bloodygood

  • *
  • Posts: 11
    • View Profile
Hello Zuljin. I just ran a few tests on my own to see what could be the problem. I first tried the method you described with ULGP -> hand.tex ->img2tex -> hand.bmp. etc and when I converted back I ran into the same problem.
So I decided to try a slightly different method. Since these are small files I instead opened the hand.tex in TileMolestor-0.16. Once the file was loaded you will notice the file is jumbled and strangely coloured. then using the information from here. http://wiki.qhimm.com/FF7/TEX_format I changed these settings to make the image display correctly to edit. View>Mode>2-Dimensional and View>Codec>16bpp BGRA (5551). Then using the eyedropper on a empty space (gives the hex value of 00 I believe) and the brush tool I painted only the pixels for the hand. Then when I saved the new file and compared with the older version in a hex editor. I noticed only the hex values for the hand pixels had changed and nothing else. Then I just ULGP'd them back into the flevel and voila no hand.
These are the 2 modified tex files. But I recommend also attempting the method I described above for experience.
http://www.mediafire.com/?3poopu7leiun36u - updated to reflect fix
« Last Edit: 2012-08-28 03:06:59 by bloodygood »

Zuljin

  • *
  • Posts: 2
    • View Profile
Hello Zuljin. I just ran a few tests on my own to see what could be the problem. I first tried the method you described with ULGP -> hand.tex ->img2tex -> hand.bmp. etc and when I converted back I ran into the same problem.
So I decided to try a slightly different method. Since these are small files I instead opened the hand.tex in TileMolestor-0.16. Once the file was loaded you will notice the file is jumbled and strangely coloured. then using the information from here. http://wiki.qhimm.com/FF7/TEX_format I changed these settings to make the image display correctly to edit. View>Mode>2-Dimensional and View>Codec>16bpp BGRA (5551). Then using the eyedropper on a empty space (gives the hex value of 00 I believe) and the brush tool I painted only the pixels for the hand. Then when I saved the new file and compared with the older version in a hex editor. I noticed only the hex values for the hand pixels had changed and nothing else. Then I just ULGP'd them back into the flevel and voila no hand.
These are the 2 modified tex files. But I recommend also attempting the method I described above for experience.
http://www.mediafire.com/?p8t50choh3iv9p1

I tried your tex files and I got this extra line:


Went through the process you gave and I got the exact same hand_1.tex as you (hand.tex was different, yours looked like it still had some of the hand, but I don't think the game uses it at my video settings).  I compared the original hand_1.tex and my modified one and saw 4 bytes starting at 0x20EE.  I zeroed them out and that black line disappeared.  I think there were some extra pixels that TileMolestor wasn't displaying.

Thank you so much!  I don't think I could have gotten that without your help.

bloodygood

  • *
  • Posts: 11
    • View Profile
I tried your tex files and I got this extra line:


Went through the process you gave and I got the exact same hand_1.tex as you (hand.tex was different, yours looked like it still had some of the hand, but I don't think the game uses it at my video settings).  I compared the original hand_1.tex and my modified one and saw 4 bytes starting at 0x20EE.  I zeroed them out and that black line disappeared.  I think there were some extra pixels that TileMolestor wasn't displaying.

Thank you so much!  I don't think I could have gotten that without your help.
Ah I see, I must have just missed those when editing. I will be making the same correction to my version as well.  Thank you for also mentioning that. I felt that the hand was getting rather in the way at times and that it took away from the atmosphere a bit.