Author Topic: ff7 opengl-0.7.11b + video problem  (Read 6614 times)

Grondoval

  • *
  • Posts: 25
    • View Profile
ff7 opengl-0.7.11b + video problem
« on: 2012-12-23 22:35:12 »
Well i have installed FF7 with Final Fantasy VII Remix 2.5.1 + Bootleg 039 + Menu Overhaul project

And i´m configuring ff7_opengl.cfg right this lines:


Quote
# ff7_opengl-0.7.11b config file - modified by Bootleg


## USER OPTIONS ##
## If you just want to play the game, these are the only options you'll want to change.

# set the window size (or fullscreen resolution) of FF7
# 0 means use original resolution (whatever ff7.exe provides)
# preserve_aspect adds black borders as needed to preserve a 4:3 aspect ratio
window_size_x = 1280
window_size_y = 1024
internal_size_x = 1920
internal_size_y = 1080
preserve_aspect = yes
fullscreen = yes

#window_pos_x = -1
#window_pos_y = -1
#widescreen_hack = yes

# mod directory
# subdirectroy of mods/ where textures will be loaded from
# does not affect the old external textures feature, those should still go in textures/
mod_path = DK

# check your driver settings if this option doesn't seem to work
enable_vsync = yes
refresh_rate = 60

# limit snowboard, coaster and highway minigames to refresh rate / 2, i.e. 30fps for a 60hz display mode
# vsync must be enabled and working for this to have any effect
minigame_framelimiter = on

# same thing, but for the battle swirl
battleswirl_framelimiter = on

# allow FF7 to use linear filtering for its textures
# some things look slightly better with this option on, but alot of textures just lose their detail
linear_filter = on

# plugin used to play music, the FF7Music plugin MUST be enabled for FF7Music to work.
# If no music plugin is loaded the game will play MIDI as usual but FF7Music will NOT work.
music_plugin = plugins/ff7music.fgp


## ENHANCEMENTS ##
## All the little extras that weren't part of the original game, default options include only trivial bug fixes.

# make all dialog boxes transparent, same effect as the transparent dialog boxes YAMP patch
transparent_dialogs = on

# allow max hp/mp to go over 9999, same effect as the YAMP patch by dziugo
break_9999limit = no
#new_hp_limit = yes
#new_mp_limit = yes

# include armor in magic defense calculation
mdef_fix = yes

# expand battle viewport to cover entire screen and make the battle menu transparent
new_battle_interface = on

# post-processing shader, used to apply fullscreen effects
enable_postprocessing = yes
post_source = shaders\nolight\SmartBloom.post
yuv_source = shaders\yuv.frag
frag_source = shaders\nolight\main.frag
vert_source = shaders\nolight\main.vert


## ADVANCED OPTIONS ##
## Don't fiddle with these unless you know what you're doing.

# use shaders, if available and supported
# turn shaders off to use the OpenGL 1.1 backend
use_shaders = yes
#enable_lighting = yes
#show_light_rays = yes
#show_normals = yes
#show_tbn_space = yes
max_lights = 12

#Variable Functions#
#specular_fog = yes
#texture_scale_bias = 1
#texture_coordinate_clamp = yes
#pixel_texture_bits = 32
#generate_mipmap = yes
#detail_texture = yes
#shader_precision = yes
#tessellation_program5 = yes
#multisample_coverage = yes
#multisample_filter_hint = yes
#texture_filter_anisotropic = yes
#texture_edge_clamp = yes

# prevent glitches due to rounding errors by rendering in the nearest (larger, if supported)
# multiple of the original resolution and up/down-scaling
prevent_rounding_errors = yes

# enable alpha blending for textures without an existing blending effect
fancy_transparency = on

# display frames per second counter in upper right corner
show_fps = no
skip_frames = no

# display some real-time debug information
show_stats = no

# store external textures in a compressed cache for increased performance
# compression is not lossless, some artifacts may appear when this option is in use
# texture cache does NOT update automatically if the source image changes, however, deleting anything from the cache
# will cause that file to be recreated from the source
compress_textures = no

# use pixel buffer objects to speed up texture loading
# will probably crash horribly on ATI cards but should work for NVIDIA users
use_pbo = no
use_vbo = no

# replace FF7's default framelimiter timer source
use_new_timer = yes

# use a more stable (but less accurate) timer to control FF7's framelimiter
# this option has no effect unless the use_new_timer option is on
use_stable_timer = yes

# plugin used to play movies, FFMpeg is the only choice for now
movie_plugin = plugins/ffmpeg_movies.fgp



## MODDER OPTIONS ##
## These options are mostly useful to modders and should not be enabled during normal play.

# read files directly instead of using LGP archives
# for example; if FF7 is looking for aaab.rsd in char.lgp, this option will make it open direct/char/aaab.rsd first,
# if this file doesn't exist it will look for the original in the LGP archive
direct_mode = off

# show every failed attempt at loading a .png texture
show_missing_textures = no

# Disable Error Notifications
disable_popup = off

# Load Multiple DLLs
#load_library = Multi.dll

The shaders, postprocessing and menu overhaul project runs great, but i cant see the video when i launch game. If i disable enable_shaders can see videos but i cant see the game with filters.

Any idea?

ohh and this is the log i take when exit the game:

Quote
INFO: FF7/FF8 OpenGL driver version 0.7.11b
INFO: Auto-detected version: FF7 1.02 US English
INFO: NVIDIA Corporation GeForce GTX 550 Ti/PCIe/SSE2 4.2.0
INFO: OpenGL 2.0 support detected
INFO: Found swap_control extension
INFO: Max texture size: 16384x16384
INFO: Number of texture units: 4
INFO: Original resolution 640x480, window size 1280x1024, output resolution 1280x960, internal resolution 1920x1080
INFO: FBO extension detected, using fast scaling/postprocessing path
INFO: Shader limits: varying 124, vert uniform 4096, frag uniform 2048
INFO: main program link log:
Fragment info
-------------
0(43) : warning C7050: "texture_color.xyz" might be used before being initialized

INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: FF7Music helper plugin loaded
LOCK UNLOCK TEST
MATRIX INITIALIZE
INITIALIZE DD/D3D END
initializing sound...
creating dsound primary buffer
reading audio file
loading static sounds
sound initialized
set music volume: 127
set music volume: 127
Entering MAIN
Exiting MAIN
START OF CREDITS!!!
INFO: D:\FF7\movies\eidoslogo.avi; rawvideo/null 364x353, 15.000000 FPS, duration: 0.066667, frames: 1
INFO: D:\FF7\movies\sqlogo.avi; mpeg4/mp3 640x480, 15.000000 FPS, duration: 247.466667, frames: 3712
INFO: yuv program link log:
Vertex info
-----------
0(53) : error C5025: lvalue in assignment too complex
0(55) : error C5025: lvalue in assignment too complex
0(57) : error C5025: lvalue in assignment too complex

ERROR: failed to load yuv shader
set music volume trans: 127->0, step=60
END OF CREDITS!!!
Entering MAIN
set music volume: 127
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
INFO: D:\FF7\movies\opening.avi; mpeg4/mp3 1280x960, 15.000000 FPS, duration: 119.400000, frames: 1791
WM_CLOSE
Field Quit
UNINITIALIZE DD
END UNINITIALIZE DD
« Last Edit: 2012-12-23 23:00:16 by Grondoval »

Vgr

  • Global moderator
  • *
  • Posts: 2163
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #1 on: 2012-12-23 23:10:08 »
Uninstall everything. Install the game. Install Bootleg.

Grondoval

  • *
  • Posts: 25
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #2 on: 2012-12-24 00:07:39 »
i´m seeing bootleg mod list and lot of links are dead. :-\

¿And it´s necessary install all since 0? It´s only a shader/movie problem i don´t think the problem is all
« Last Edit: 2012-12-24 00:18:32 by Grondoval »

Kompass63

  • *
  • Posts: 695
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #3 on: 2012-12-24 00:19:52 »
hi Grondoval

Quote
-----------
0(53) : error C5025: lvalue in assignment too complex
0(55) : error C5025: lvalue in assignment too complex
0(57) : error C5025: lvalue in assignment too complex

ERROR: failed to load yuv shader

May Aali's yuv.frag  works better with your video card.

Grondoval

  • *
  • Posts: 25
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #4 on: 2012-12-24 00:28:44 »
hi Grondoval

May Aali's yuv.frag  works better with your video card.

And where i can find that?
« Last Edit: 2012-12-24 00:30:17 by Grondoval »

Kompass63

  • *
  • Posts: 695
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #5 on: 2012-12-24 00:42:34 »
Inside this zip-Archive (Aali's driver).
Rename the existing one and extract "yuv.frag" into your [gamedir]\shaders

And about the dead links, here exists a torrent to some files for bootleg, read this
« Last Edit: 2012-12-24 00:52:28 by Kompass63 »

Grondoval

  • *
  • Posts: 25
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #6 on: 2012-12-24 00:55:32 »
Inside this zip-Archive (Aali's driver).
Rename the existing one and extract "yuv.frag" into your [gamedir]\shaders

Im a little confused,

i rename the yuv.frag to for example 1yuv.frag that is on my FF7/shaders folder,

After copy the yuv.frag file of Aali´s driver you serve to my FF7/shaders folder.

Start the game and get the same error i post in the log:

Quote
-----------
0(53) : error C5025: lvalue in assignment too complex
0(55) : error C5025: lvalue in assignment too complex
0(57) : error C5025: lvalue in assignment too complex

ERROR: failed to load yuv shader

« Last Edit: 2012-12-24 00:58:08 by Grondoval »

Kompass63

  • *
  • Posts: 695
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #7 on: 2012-12-24 01:14:42 »
Hm...Since I'm also somewhat helpless...

Obviously this shader was not responsible for the error.
Can you manually play the videos?

Grondoval

  • *
  • Posts: 25
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #8 on: 2012-12-24 01:25:31 »
Hm...Since I'm also somewhat helpless...

Obviously this shader was not responsible for the error.
Can you manually play the videos?

Of course i can play manually the videos

And when i turn "use_shaders= no", i can see the movies in game. But i want to see shaders and videos. :-P

It´s strange the rest of postprocessing shaders/shaders dont show error,

and any shader have relation with video  ???
« Last Edit: 2012-12-24 01:29:01 by Grondoval »

Kompass63

  • *
  • Posts: 695
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #9 on: 2012-12-24 01:34:11 »
There are a few other shaders here.
maybe one of them works better.

Grondoval

  • *
  • Posts: 25
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #10 on: 2012-12-24 15:37:33 »
i dont know what shader take, i try a 1.03 spanish patch, and the others ff7_opengl and i continue with the same problem

use_shaders = yes -> cant see videos, but filters and other things see great
use_shaders = no -> can see videos, but filters and other things see horrible

tried to change the ff7Config to another to get the pass message and select custom driver and anything change. :?

Vgr

  • Global moderator
  • *
  • Posts: 2163
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #11 on: 2012-12-24 17:53:00 »
I (and other people as well) never use shaders, and it always works great. I've had far less problems without shaders than with. It all comes down to personal preference, too.

DLPB_

  • Banned
  • *
  • Posts: 11008
    • View Profile
Re: ff7 opengl-0.7.11b + video problem
« Reply #12 on: 2012-12-24 21:27:59 »
Aali told me that most will notice no difference with or without shaders.  I don't use them.