Author Topic: [PSX/PC] General editor - Hades Workshop (0.41d)  (Read 498026 times)

trostboot

  • *
  • Posts: 6
    • View Profile
Re: [PSX/PC] General editor - Hades Workshop (0.41d)
« Reply #1775 on: 2020-09-06 12:56:20 »
I'm running into strange issues when trying to create patches for the German PS1 version. I've verified that the base image I'm working from matches the checksums on redump, so it should be good to use.

Even making a minor edit like changing Thunder Slash's damage formula, then either creating a PPF from that change or overwriting the binary image directly will result in issues. If overwriting directly, the game will freeze on opening the equipment menu. When trying to apply the PPF patch to an exact copy of the image it was created against, PPF-o-matic warns about blocksize mismatch, and if I apply it anyway, the same freeze issue crops up. That ... probably shouldn't happen.

By contrast, doing the same to a NTSC-U image, it works just fine.

Edit: Digging into my archives, I found a version of Hades 0.40 marked specifically as "for_de", but no dice there, either. I understand that there's some differences between the versions, of course, but the description states compatibility with any language version, so something is amiss here.
« Last Edit: 2020-09-06 15:40:32 by trostboot »

mythikdawn

  • *
  • Posts: 1
    • View Profile
Re: [PSX/PC] General editor - Hades Workshop (0.41d)
« Reply #1776 on: 2020-09-12 01:42:41 »
I'm running into a slight issue when trying to use the randomizer. I am attempting to randomize NA PS1 ISOs. When I put in the same random seed for all four discs, with all the same options selected, I'm getting different results for each disc. For example, the seed 756029 might have the Mage Masher teach Blizzaga on Disc 1, but on Disc 2 it will teach Float, etc.

Is this intended? How can I get around this?

LeOsTyLe

  • *
  • Posts: 41
    • View Profile
Re: [PSX/PC] General editor - Hades Workshop (0.41d)
« Reply #1777 on: 2020-09-13 22:34:01 »
Hello i have a question.

When i open the Hades Programm and File open and choose the launcher nothing happens, and the programm dont react , anymore even i wait 15 min. But when i open Unity Asset Viewer and File open the Launcher, everything is alright. Do i am something wrong?

Edit: I reinstalled FF9 without Memoria Engine, then it works.

« Last Edit: 2020-09-16 23:17:19 by LeOsTyLe »

ChikoLad

  • *
  • Posts: 15
    • View Profile
Re: [PSX/PC] General editor - Hades Workshop (0.41d)
« Reply #1778 on: 2020-09-20 01:40:18 »
It's been a little while since I tried any FFIX modding but I decided to mess around with changing the character in the field again.

One thing I wanted to try was giving all of the characters animations for riding on Choco in locations like Chocobo's Paradise. However, for Freya, I actually want to have her sitting sideways, with her head facing the same direction as Choco's. I have a pretty good sitting animation for her, I just need to adjust the orientation of the body and head, and then maybe the coordinates slightly. Anyone know what functions I need to use to achieve that? I tried stuff like "TurnInstant" but couldn't get it to work.

Here's an image of how it looks right now. Basically I want to make her sit with her front facing Choco's right side, with her legs hanging down, and Freya's head looking to her side so she is looking at whatever is in front of Choco:


MysticLord

  • *
  • Posts: 59
    • View Profile
Re: [PSX/PC] General editor - Hades Workshop (0.41d)
« Reply #1779 on: 2020-09-24 18:30:14 »
Bit of a long shot here, but I get this error when I try to run Hades Workshop.
Quote
The code execution cannot proceed because MSVCP140.dll was not found. Reinstalling the program may fix this problem.

I run Windows 10, 64-bit, however I used BCUninstaller (Bulk Crap Uninstaller) to remove such wonderful applications as the WordPad (Now With Ads!), the People icon, Contacts, Maps, and numerous others which I have thankfully forgotten.

Trying to reinstall the framework which google tells me contains MSVCP140.dll doesn't make Hades Workshop work, so I assume something else is required or a configuration file is broken.

If you know, could you tell me more about what Hades Workshop requires to run on Windows 10? Or should I give up and run it on a Linux machine instead?