Author Topic: [FF7PC-98/Steam] Multiple mods and Modding Tool-The Reunion [R06c]  (Read 1688535 times)

Orichalcon

  • Cool newbie
  • *
  • Posts: 50
  • Karma: 1
    • View Profile
thats interesting that the whole thing is linked with another bug...

i figured it would be a simple fix, whoops  :-D

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
and i still cant find the part that's causing the fire effects to disappear.  Went through all counters too.

It's 100% the same issue though.  The fire effect cuts out one in two frames.  And with current 60fps we have either fire effect always drawing each frame or not drawing at all. 

Funny thing is the bullet casings that are dropped look better when incorrectly drawn every frame - as you see the full animation.
« Last Edit: 2020-03-23 23:42:54 by DLPB »

Orichalcon

  • Cool newbie
  • *
  • Posts: 50
  • Karma: 1
    • View Profile
As per my issue above (more details provided), I have now tested the game with The Reunion on another TV via HDMI and the problem of no sound in-game (but sound during cutscenes) persists on that TV as well.

i've had weird issues when porting sound out of a laptop hdmi before (certain audio playing, and not playing others), i dont know why, but sound coming out of hdmi can be finicky

i'd recommend using some usb speakers (or ones that plug into the 3.5mm jack) alongside the TV for sound, successfully troubleshooting your problem is a slim chance, not to mention a nightmare

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
I've located problem area for the firing effect.  I had to literally go down every function in the main battle draw function - branching out.

denialz

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
Good evening,

Im not sure if there was a change, but I am unable to use the remako mod with the new update. It was working prior by putting the remako files into custom and typing in satsuki under the custom id (same name as the folder within custom), thank you in advance.

Orichalcon

  • Cool newbie
  • *
  • Posts: 50
  • Karma: 1
    • View Profile
I've located problem area for the firing effect.  I had to literally go down every function in the main battle draw function - branching out.

killed 2 birds with one stone? Nice!  8-)

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
Good evening,

Im not sure if there was a change, but I am unable to use the remako mod with the new update. It was working prior by putting the remako files into custom and typing in satsuki under the custom id (same name as the folder within custom), thank you in advance.

See first post.  Use Hotfix 11.

Agravaile

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
    • View Profile
Sorry for asking that out of of nowhere, but i seem to have crashes after some time of play. Currently using the Steam version with several mods install on top of it, like satsuki field and world map stuff. The thing is, the less mods there are, the later crash happens. More mods - sooner. So i have to guess it has to do something with texture overload or something like that. I've fiddled with texture cache size in options.ini with numbers like 256 1024 2048 etc... while some made the crashes to be much later, some numbers made the happen sooner. Is there anything in options.ini i can change that would fix the random crashes entirely?

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
« Last Edit: 2020-03-24 21:53:44 by DLPB »

Agravaile

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
    • View Profile
oh, okay. See it the fix applies to that issue too. But can the problem be resolved completely, or we're just stuck with it for a while? While it the hotfix seems to make it happen less, it doesn't make the crashes disappear, if i'm not mistaken. Sorry again if you've had that question before.

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
See the reunion database.  There is nothing more I can do than to try to resolve bugs and make you aware of them. 

Agravaile

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
    • View Profile
Ok, gotcha. Found the database which had all the info i needed about the bugs. Though, i noticed that there were some fixes that were present in R06b, for example: Marin's name which was fixed to being Marlene, or scenes skip and other stuff which i don't have with currently installed R06c. So that brings me the question, is R06c is standalone, or just an update to previous releases? Sorry if that question might sound stupid, but the database says that some of the bugs and features were fixed in R06b, while i have them present in R06c, which is strange. Or is R06b is a newer package yet to be released?

Also, another quick question, is it possible to install Kaldarasha's ChaOS Dynamic Weapon mod into Reunion? If it is, where should i put the files for it to work?

Edit: Also, is Cloud's field and battle models are suppossed to be different in colors? Battle model fatigues seem to be a bit brighter blue than the field ones. Though i have Kaldarasha's ChaOS mod injected into the base lgps, could that be the problem?
« Last Edit: 2020-03-25 19:27:39 by strife98 »

skyhawk

  • Cool newbie
  • *
  • Posts: 51
  • Karma: 0
    • View Profile
Or is R06b is a newer package yet to be released?

I can't comment on most of your issues, but the confusion regarding R06b and R06c is easily fixed. R06b released with a major show-stopping bug, resulting in the unscheduled nearly-immediate subsequent release of R06c. Anywhere in the documentation you see R06b, you can just mentally substitute in R06c.

I would suggest that if you see issues or concerns and you're running any kind of modification at all, you should remove the modification and confirm the issue is present on vanilla Reunion before posting on this thread.

Agravaile

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
    • View Profile
Oh, that's good to know, thanks! At least now things became much clearer to me whenever i'm consulting with the database now.

About Cloud's model, when it looks different on Field and Battle,just checked again with a clean game and vanilla install of R06c with no other mods, and of course, model overhaul enabled, and the models still look different. Again, like i said before Cloud's clothes look brigher blue in battles, and darker in fields. It's not an issue at all, though consistency would be nice, so if there is any fix to that, would be great to know.

Anyways, thanks for replies, and especially to DLPB for the patience :D

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
Or better yet disable reunion in options.ini to test without it.

Agravaile

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
    • View Profile
Well, disabling the Reunion just makes them being normal, if you do not inject and models into the core game files, obviously. When you inject Kaldarashas lgp package, both field and battle Cloud models look the same, that means consistent, but if you enable model overhaul after that, the battle model starts to look different in all cases with model overhaul enabled. It's just that they're differently drawn.

I mean, it's up you whether it is an issue at all, to me it just looks strange that in field Cloud is pale with darker blue fatigues, and then in battles he suddenly gets a tan and his clothes become brighter. A matter of taste, i guess, and a few will notice it too, so i dunno.

What i did is extract Kaldarashas LGP model package downloaded from Nexus page, and just overwrite the battle models, and that did it for me.

And about that, i have a question... Are the Models present in Reunion, located in Model_Overhaul folder are newer and have some important fixes that the ones from Kaldarashas package? All models from Kaldarasha are dated January 2019, but while most in Model_Overhaul are dated January too, some of them are from October 2019. Were there any important changes, or i can just straight up overwrite everything from Kaldarashas package?

Agravaile

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
    • View Profile
The reason i'm also asking that, is because i've no idea which files are the ones that replace Bugen sitting model, and newer model for Barret, which are not by default in Reunion. Reunion has Bugen standing, and old barret (i think). If i want to have them, i'd have to overwrite the char folder that is in Reunion by default which, again, i'm afraid to do cause maybe there were some important fixes to models.

i just straight up have the folder with bugen sitting and new hd barret in the char folder with many other ones, but which are their files i've no idea. Maybe you'd happen to have a separate package with them so i could know EXACTLY what i'm overwriting.

Thanks in advance.

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
This isn't really something for this thread.  General help should be placed in a new thread :)

Agravaile

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 0
    • View Profile
Ok, gotcha, sorry 'bout that. And lastly (i think it could be considered a bug/overlook), when you use the Swap X and O during the installation, while the dialogues do swap X and O accordingly, the options menu do not, and in the controls customize menu, O is still labeled as Confirm and X as Cancel. I imagine this has to do with textures in menu folder and swapping icons in the tex files, or just switching labels which is easier.

Is there a Hext fix of some sort to revert it by default, please? while i have no preference with O and X, the incorrent labeling kinda annoys, would be great if there would be a quick fix to that without reinstallation to revert it back or just swap labels.

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
See the help file.

usb

  • Fast newbie
  • *
  • Posts: 47
  • Karma: 2
    • View Profile
with new translation on and model overhaul on there is a glitch with the ruby weapon model: it appears an emerald weapon distorted
with new translation on and model overhaul off no problem




here it is a save: save 9, file 11 (take the highwind and go to ruby weapon) https://www.mediafire.com/file/p7igzyzi4a2r7cf/save08.ff7/file

DLPB

  • No life
  • *
  • Posts: 10220
  • Karma: 283
  • The ascension of the ordinary man
    • View Profile
how funny...  though no idea how thats happened.  Def no custom mods?

oblongsausage

  • Fast newbie
  • *
  • Posts: 22
  • Karma: 0
    • View Profile
another one:

     -with 60fps battles set to 1 the status effect slow has the stop animation for all my characters, they looked stopped, but can act and are just slowed, i can repeat this by just casting slow on a teammate, and slow works normally when 60fps battles is turned off

Yes, I've experienced the same thing with 60fps 1.

usb

  • Fast newbie
  • *
  • Posts: 47
  • Karma: 2
    • View Profile
how funny...  though no idea how thats happened.  Def no custom mods?
only field texture hd... the problem is model overhaul: opening with kimera model overhaul\world\cqc.hrc instead of a ruby weapon model there is a glitchy emerald
also i forgot to say that it's also missing the red tentacle on the sand when approaching ruby

opening cqc.hrc with notepad there are reference in emerald model and :SKELETON e_weap_sk instead of r_weap_sk


this should be a fix https://pastebin.com/raw/nRAKbArx
with notepad++ create a file cqc.hrc, paste the text of the link and overwrite model overhaul\world\cqc.hrc
« Last Edit: Today at 10:32:16 by usb »

Orichalcon

  • Cool newbie
  • *
  • Posts: 50
  • Karma: 1
    • View Profile
Big Brawl for cid is set to ludicrous speed, lol.

I cant help but notice that no one said anything about my Spaceballs reference.

Step up your !$&@ing game, Reunion users.

with new translation on and model overhaul on there is a glitch with the ruby weapon model: it appears an emerald weapon distorted
with new translation on and model overhaul off no problem

Weird, I have model overhaul off with kaldarasha's models installed manually (with his lgp installer) and I'm not getting this

I've located problem area for the firing effect.  I had to literally go down every function in the main battle draw function - branching out.

is it looking like this will be fixed in R07? finding a problem and being able to fix it are 2 completely different things, unfortunately... haha
« Last Edit: Today at 04:52:54 by Orichalcon »