Author Topic: Custom graphics driver for FF7/FF8 [v0.8.1b]  (Read 223920 times)

WyndBalduram

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #150 on: 2014-04-28 17:41:41 »
I have copied the contents of the data folder from the original installation disc to the HDD, to no avail.  The problem i am having is the exact same as the problem that folks have run across with the 0.7.11 drivers, I think they called it the "everything is made of light" error.  To fix that problem, you just had to put use_shaders = off in the config file, but doing that with 0.8.1b does not work - an error pops up saying something to the effect that command does not exist or something.  =P  Thank you for putting up with me.

Kaldarasha

  • No life
  • *
  • Posts: 2438
  • Karma: 153
  • Prince of Model Editing
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #151 on: 2014-04-28 19:08:51 »
You have a texture problem, has nothing to do with the shaders (at last this time).
Do you have the latest driver installed for you graphic card?

WyndBalduram

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #152 on: 2014-04-28 19:31:19 »
I do indeed have the latest drivers for my card installed.  I installed them early last week hoping it might solve the issue.  I have an nvidia mobile gtx I think.  I am not at computer now so will have to get specifics later if they are needed.

Kompass63

  • Freak
  • *
  • Posts: 703
  • Karma: 18
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #153 on: 2014-04-29 07:06:19 »
The mistake in his app.log point rather to the fact that the Prorgamm the lgp files can not unpack properly.

One possibility would be that WyndBalduram has installed (eg) German version of FF7, but uses the engischen 1.02 patch.
But then one would have also to rename the gflevel.lgp in flevel.lgp, etc...
« Last Edit: 2014-04-29 07:16:49 by Kompass63 »

WyndBalduram

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #154 on: 2014-04-29 10:16:25 »
If this helps, the version of the game I have is the original 1998 version.  I bought the game when it originally came out for PC and have held onto the discs all this time.  It is the US english version, and so far as I can tell I used the English version of the 1.02 patch. 

Kompass63

  • Freak
  • *
  • Posts: 703
  • Karma: 18
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #155 on: 2014-04-29 23:19:13 »
@ WyndBalduram

Have you installed 'norton 360'?

WyndBalduram

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #156 on: 2014-04-30 03:22:10 »
Holy cow... I feel like an idiot...  :oops:

First, let me say that no, I don't have Norton 360 installed.

Second - I double checked, just to make sure I had the latest drivers for my graphics card installed...  Turns out I didn't.  I drivers that I referred to in previous post were either beta versions or the downright wrong ones.

I just updated my drivers to the actual newest versions... and... voila.  Works perfectly.

SORRY SORRY SORRY for wasting time!   :-D Thank you again for all of your patience and help.

Athelias

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #157 on: 2014-05-07 03:44:25 »
Hello, I was wondering if there was a way to make the backgrounds look better in FF8? Character models and monsters look great, but the backgrounds in towns look the same as before.  Is there like a filter or something for these? If not, are there any mods that make the backgrounds look better?
« Last Edit: 2014-05-07 05:26:22 by Athelias »

shOcKmAnz

  • Fast newbie
  • *
  • Posts: 31
  • Karma: -1
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #158 on: 2014-05-19 08:56:22 »
cann't look for Black Materia


ORIGINAL !!



MOD !!



Hellbringer616

  • No life
  • *
  • Posts: 1915
  • Karma: 12
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #159 on: 2014-05-19 16:31:14 »
This could be an issue with the mods you're using and not the graphics driver.
Try running the game without mods and using the graphics driver. though it looks like that is what you did. Ask for support for the mod on the mod thread

NFITC1

  • No life
  • *
  • Posts: 2910
  • Karma: 73
  • I just don't know what went wrong.
    • View Profile
    • WM/PrC Blog
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #160 on: 2014-05-19 21:38:24 »
I just upgraded my machine's HDD and had to re-install a lot of stuff. This happened:
Code: [Select]
[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF7 1.02 US English
[00000000] INFO: ATI Technologies Inc. ATI Mobility Radeon HD 5650 4.2.11672 Compatibility Profile Context
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Using PBO
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 16384x16384
[00000000] INFO: Original resolution 640x480, window size 640x480, output resolution 640x480, internal resolution 640x480
[00000000] INFO: Shader limits: varying 128, vert uniform 16384, frag uniform 16384
[00000000] INFO: vertex shader compile log:
Vertex shader failed to compile with the following errors:
[00000000] INFO: fragment shader compile log:
Fragment shader failed to compile with the following errors:
[00000000] INFO: main program link log:
Vertex and Fragment shader(s) were not successfully compiled before glLinkProgram() was called.  Link failed.

[00000000] ERROR: failed to load shaders

It might be a driver problem. I was working on ATI's 12.4 before my upgrade and now I think I installed 13.9.

EDIT:
Nevermind. A reboot or two fixed it.
« Last Edit: 2014-05-27 19:03:36 by NFITC1 »

SymphoniC

  • Fast newbie
  • *
  • Posts: 46
  • Karma: 1
  • Mind hack.
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #161 on: 2014-05-30 20:10:41 »
Hey guys, any idea what it will take to get the OpenGl driver working with the Simplified Chinese patch?

Iceboundphoenix

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 4
    • View Profile
Final Fantasy 8 failed to load shaders
« Reply #162 on: 2014-06-22 19:20:04 »
[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF8 1.2 US English (Nvidia)
[00000000] INFO: NVIDIA Corporation GeForce GTX 770/PCIe/SSE2 4.4.0
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Using PBO
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 16384x16384
[00000000] INFO: Original resolution 640x480, window size 1920x1080, output resolution 1440x1080, internal resolution 1920x1440
[00000000] INFO: Shader limits: varying 124, vert uniform 4096, frag uniform 2048
[00000000] ERROR: failed to stat file /shaders/main.vert
[00000000] ERROR: failed to load shaders

The game attempts to start up but gets to a black screen with the error that the shaders failed to load. I have tried putting the commands to not load shaders in the config file but that does not seem to be working. I have the newest driver version 8.1 and am using the ff8 launcher 1.4 to use the hard.dll for my play through. I have installed the eax properly and updated the game. Does it matter where the command (use_shaders = no) goes in the config file?
I am using a gtx 770 graphics card would there be any other things preventing the shaders from loading?

Vgr

  • Global moderator
  • No life
  • *
  • Posts: 2209
  • Karma: 35
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #163 on: 2014-06-22 22:55:46 »
Don't use the FF8Launcher. Add the "load_library = hard.dll" in your config file instead. Aali's driver overrides the obsolete launcher.

Iceboundphoenix

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 4
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #164 on: 2014-06-23 00:57:42 »
load_library = Hard.dll
load_library = Publish.dll
## ENHANCEMENTS ##
## All the little extras that weren't part of the original game, default options include only trivial bug fixes.

# post-processing shader, used to apply fullscreen effects
post_source = shaders/bloom2.post
enable_postprocessing = yes
load_shaders = no


This is just a small cutout of the cfg file for FF8 I have both of those commands placed into the file but from what I can tell its having no effect in booting the game up. I still am greeted with a failed to load shaders. Am I inputting the commands wrong? Do I need to have the commands inputted a certain way or in a certain location within the .cfg file?  I have the steam version of FF8, is this version incompatible with these mods? Is the launcher mod causing any kind of problem such that it would interfere with the shaders loading? So I should not use the launcher mod with this graphics driver gotcha. Does having the launcher mod already in the FF8 folder at this time make the graphics driver unstable or cease to work properly? I can't think of anything I missed to ask or touch on.

Edit: I have reinstalled FF8 and am no longer using the ff8 launcher 1.4. The Only mods that are in the folder are the roses and wine music mod, the hard.dll file along with the gl driver from aali. I am still receiving the same error message from the app.log about the shaders failing to load. Now this happens when I try to run the game right from the FF8.exe within the main directory. I can start the game up through the steam user interface without receiving the error failed to load shaders. Does starting the game up from the steam interface stop the gl driver from working? Does this gl driver work with the steam version? Is this error message that the shaders not loading stemming from me using the steam version and or booting the game from the FF8.exe from within the game directory?
« Last Edit: 2014-06-24 05:37:54 by Iceboundphoenix »

Vgr

  • Global moderator
  • No life
  • *
  • Posts: 2209
  • Karma: 35
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #165 on: 2014-06-24 17:11:55 »
I'm not sure, but I think you don't need Aali's driver with the Steam version.

Iceboundphoenix

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 4
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #166 on: 2014-06-24 19:25:07 »
So would the posts I have seen in some other threads hold some truth that square used aali's driver for the steam release? If I don't need to use the driver what will be the ramifications of trying to install or use other mods down the line if I don't have the driver? The game still says that its 1.1 which is curious because I put the 1.2 nividia patch into my folder when I tried to run the patch .exe that is when the game tries to load and fails to load shaders? Does it not matter where I place the .cfg commands in the file? I feel like something is amiss because if I put the command (use_shaders = no) it does not work because if the command worked why would I still be receiving a failed to load shaders error. I feel as if I am missing something with the command inputs that is causing the command not to be taken literally and thus why I still receive the failed to load shaders. I can still run the game through steam though which is the most curious thing about it.

Vgr

  • Global moderator
  • No life
  • *
  • Posts: 2209
  • Karma: 35
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #167 on: 2014-06-24 20:41:38 »
The Steam/Square Enix store versions are different than the 1998 release. I don't think Square used Aali's driver for the release, but it wouldn't surprise me either. I don't have the Steam game so someone else might be better than me to provide support.

Iceboundphoenix

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 4
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #168 on: 2014-06-24 22:20:14 »
Fair enough I can only go by what I have seen from other posts on the subject of the driver being used. I have already payed for the steam version and from what I can guess it would cost 20 something or more dollars to get the official version of FF8 PC version. Not really down for that so I am sure I can just wait for more support to come to the steam version. In all honesty I am really only interested in playing FF 8 with a hardcore mod of sorts installed. Whether I can figure out how to do that with the steam or psxe version I don't know. If I could figure out if the driver could work with the steam version and get the hard.dll thing to load it I could solve that dilemma that is bothering me.

Vgr

  • Global moderator
  • No life
  • *
  • Posts: 2209
  • Karma: 35
  • If it quacks like a duck, it must be a duck
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #169 on: 2014-06-24 23:50:26 »
There is the Hardcore Patch by Colly that works for the PC version of FF8, if that's what you're looking at.

Iceboundphoenix

  • Fast newbie
  • *
  • Posts: 35
  • Karma: 4
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #170 on: 2014-06-25 00:29:29 »
Would this patch work with the steam version though? Thats the kicker and the deciding factor I will leave an update after I uninstall FF 8 and reinstall fresh I will apply this mod and post my findings. Thank you for the link.

I installed FF8 steam fresh. I then installed roses and wine and after that replaced a few sound files with my own custom ogg looping ones. From there I used the nvidia 1.2 patch for FF8. Before I used this patch I tried to run the game from the FF8.exe file within the main directory but to no avail. Instead of failed load shaders it simply did not want to boot the game. After the patch was installed the same issue occurred with me unable to boot the game. I can boot the game from the steam user interface but what this does I don't know. The music mod works fine but whats the determining factor to finding out if the hardcore mod from colly even works? The flying beetles dealt 7 damage to me and I picked the omega diffculty sounds a little weak. Does booting the game from the steam interface cease this mod to work or does it only work if booted up from the actual .exe in the main directory? If the case is the later then would replacing the .exe with another make a difference? What could be causing such an issue from pretty much a fresh install of FF8 curious...... I know I ask a lot of questions heh
« Last Edit: 2014-06-25 03:00:18 by Iceboundphoenix »

Kaldarasha

  • No life
  • *
  • Posts: 2438
  • Karma: 153
  • Prince of Model Editing
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #171 on: 2014-07-04 10:55:34 »
I currently make a resume where we are with FF7 moding and there is a bug I haven't mentioned yet. The FPS in the Chocobo minigame goes wild: sometime the speed correct and is doubled after the finish, sometimes the whole race is at doubled speed, sometimes the race menu is to fast, but most times it's a mixture of all.
Is there a way to fix it?

ProtomanZxAdvent

  • Insane poster
  • *
  • Posts: 289
  • Karma: 7
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #172 on: 2014-07-09 00:55:13 »
I believe the yamp mini game patch can fix it with out needing v-snyc (which I like using) only thing is it forces 30fps on the mini games and in my opinion works well. I care less about Dan's 60 fps minigame mod which makes no sense due to the fact games back then were 30 fps max

DLPB

  • No life
  • *
  • Posts: 9842
  • Karma: 313
  • The ascension of the ordinary man
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #173 on: 2014-07-09 08:10:13 »
I believe the yamp mini game patch can fix it with out needing v-snyc (which I like using) only thing is it forces 30fps on the mini games and in my opinion works well. I care less about Dan's 60 fps minigame mod which makes no sense due to the fact games back then were 30 fps max

You're wrong.  :-P The playstation works internally at 60fps.  The coaster and snowboard are 60fps on the PSX.  The sub and bike games are 30 (frames are doubled up on the PSX for this to work).

You are making the mistake of not differentiating between the internal speed of the playstation, and the output of an interlaced television (that also works on fields, not frames).

The coaster and snowboard minigames are actually unplayable on PC when not 60.  Go and play the playstation versions, then try to play PC.  You'll find that the handling is all wrong in the PC version due to losing 30 frames a second.  I actually looked at this in an emulator.  You can record the minigames using Fraps, and actually SEE each individual frame of the 60. 

My mod isn't trying to do something that wasn't there originally, it is RESTORING the correct frame rate.  Aali simply made the mistake of limiting them wrong.  He has changed this for the next driver revision.  The other problem was that the coaster aimer speed is wrong on PC... I corrected this too.  I think Aali is also adding that to next driver revision.

On a related note, battles are 60fps on the PSX.  It's just the main visuals are quadrupled.  The menu part is not.  Hence why Cait's / Tifa's / Battle reels are much smoother in the PSX version, and why lining the reels up is harder on PC.

You can see this here:

https://www.youtube.com/watch?v=67MvmmgaRjw

What I am trying to say is, the whole game runs at 60fps on PSX.  It's just a matter of which parts the designers limited, and what they limited to.
« Last Edit: 2014-07-09 08:29:42 by DLPB »

Kaldarasha

  • No life
  • *
  • Posts: 2438
  • Karma: 153
  • Prince of Model Editing
    • View Profile
Re: Custom graphics driver for FF7/FF8 [v0.8.1b]
« Reply #174 on: 2014-07-09 17:12:23 »
So it seems that the internal renderer goes crazy in the Chocobo minigame, because the FPS are always 30.