Author Topic: [FF8PC-Steam] FF8 Controller Buttons v2.0 (Compatible with FF8_Buttons Patch)  (Read 175013 times)

Vaelar

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
I'm not sure what's going on with my set up but I can't get this mod to work. All my other graphics mods are fine.

I'm using a steam controller and steam link.

I actually think the mod is probably working tbh, but I can't get the game to realise I'm using a controller. So it's showing keyboard buttons.

Anyone seen this, or know how to force the game into using a controller setup instead of keyboard?

Thanks for the help!

I'm having this issue too, no matter what I do, I just get keyboard prompts and displays instead of icons, not even B1 B2 etc etc…


tried 5 or 6 times now but it either stays at keyboard or goes nuts and uses the hand icon for everything

using ps4 controller with no other apps or mods other than steam and lunatic pandora / raw.

thefunge

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Hello, thank you so much for your hard work on this mod. I think I'm almost there but I have run into an issue. Instead of mapping the green text to controller icons, it instead maps all green text to the cursor. I have tested it with the gunblade cursor in seeDReborn 4 and normal cursor in earlier versions. Would you have any advice for me?

Again, thank you so much.

EDIT: I've determined that this issue occurs when I place the FF8_Buttons_EN.txt file into RaW/GLOBAL/Hext folder. I tried a different langauge (Fr) and I still got green text, but of a different font I believe. Moving the FF8_Buttons{config}.txt file does not change.
« Last Edit: 2019-05-06 06:29:30 by thefunge »

onewingedang3l

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Hello Mcindus. I installed your mod with my FF8 steam version and the controller button mod doesn't work. When I installed the FF8_Buttons_Main for PS4 DS4, the game is still showing keybindings not the actual ps button. I also tried installing the Shunsq version but it shows a gunblade icon. Thank you.

PauloRaz3n

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Using Ds4 Controlller on steam, no program, this mod doens't show the icons. This show only keyboard

Mcindus

  • Freak
  • *
  • Posts: 846
  • Karma: 146
  • Artist, Modder, Musician.
    • View Profile
    • Lunatic Pandora
Using Ds4 Controlller on steam, no program, this mod doens't show the icons. This show only keyboard

Hello Mcindus. I installed your mod with my FF8 steam version and the controller button mod doesn't work. When I installed the FF8_Buttons_Main for PS4 DS4, the game is still showing keybindings not the actual ps button. I also tried installing the Shunsq version but it shows a gunblade icon. Thank you.

I'm having this issue too, no matter what I do, I just get keyboard prompts and displays instead of icons, not even B1 B2 etc etc…


tried 5 or 6 times now but it either stays at keyboard or goes nuts and uses the hand icon for everything

using ps4 controller with no other apps or mods other than steam and lunatic pandora / raw.

Make sure you use a file from the 'HID' folder. That folder is for keymapper programs.  If the buttons are wrong, try another file in that folder!
Sounds like you are trying to use the 'MAIN' folder, but you are mapping your controllers...

roxasdualsword

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Hi, i'm having some problems when I use the controller at the game, I use a ps2 controller with an adapter to PC: https://www.amazon.com/DUAL-CONTROLLER-ADAPTER-CONVERTER-80001/dp/B000SPA46M?language=en_US

Also  all the mods works great, except for controllers, I use this mod and specifically I use: FF8_Buttons_Main --> FF8_Buttons_PS_PS2 (The others doesn't work for the order). The icons dont match with the correctly configuration.

The inputs for the driver are (automatically):
Button 1 = Triangle
Button 2 = Circle
Button 3 = Cross
Button 4 = Square
Button 5 = L2
Button 6 = R2
Button 7 = L1
Button 8 = R1
Button 9 = Select
Button 10 = Start
Button 11 = L3
Button 12 = R3

This is my configuration:


1. It is working perfect.
3. This is supposed to be L2 and R2 Buttons, but it appears like Select and Start.
4. I know about this bug of showing two buttons but it's not the problem.
5. Select and Start icons appears like L and R (L2 and R2).
2. The problem here is for the buttons because for the actions of rotate camera L2 and R2, It appears like L1 and R1, but If I configure it correctly for the buttons it appears like Select and Start.

I hope someone could help me with this, thanks in advance.