Author Topic: Red box crash upon start up  (Read 2254 times)


  • *
  • Posts: 37
    • View Profile
Red box crash upon start up
« on: 2016-05-12 00:35:51 »
[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF7 1.02 US English
[00000000] INFO: ATI Technologies Inc. ASUS R7 240 Series 4.2.12337 Compatibility Profile Context
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 16384x16384
[00000000] INFO: Original resolution 640x480, window size 640x480, output resolution 640x480, internal resolution 3840x2160
[00000000] INFO: Shader limits: varying 128, vert uniform 1024, frag uniform 1024
[00000000] INFO: FFMpeg movie player plugin loaded
[00000000] INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
[00000000] INFO: VGMStream music plugin loaded
[00000000] INFO: Loading external library Multi.dll
[00000001] initializing sound...
[00000001] creating dsound primary buffer
[00000001] reading audio file
[00000001] loading static sounds
[00000001] sound initialized
[00000001] set music volume: 127
[00000001] set music volume: 127
[00000001] Entering MAIN
[00000001] Exiting MAIN
[00000001] START OF CREDITS!!!
[00000001] INFO: C:\Games\Final Fantasy VII\data\movies\eidoslogo.avi; vp8/vorbis 1280x960, 30.000000 FPS, duration: 11.133000, frames: 334
[00000099] set music volume trans: 127->0, step=60
[00000164] END OF CREDITS!!!
[00000164] Entering MAIN
[00000164] set music volume: 127
[00000164] Exiting MAIN
[00000164] START OF MENU SYSTEM!!!
[00000307] WM_CLOSE
[00000307] END OF MENU SYSTEM!!!
[00000307] Field Quit

Steam 2013 version i believe.   
normal steam launcher launches game without a problem.   (via loading steam first them game from actual steam window)

7th heaven "Launch" after putting in any mod will cause game to load, show square enix, show ednos interactive,  then show a small red box in the middle...ish of the screen and rest will remain black.  Nothing else happens.  All attempts to push buttons (side alt ctrl & del) do nothing.

Non 7th heaven "Launch" but just normal loading up ff7.exe results in the same error.  It appears only way to get it to run properly is from the in steam launcher.  Please advise, been working on this for almost an hour now with different tests but same results.


Shows squaresoft/chocobos running around, then music starts to play.   as soon as i hit a button on the keyboard it goes to a red box in the middle then pitch black everywhere else.   also, music stops playing at same time.   a mix of squares black  & red on screen while music plays.


ok that's weird.. somehow mods/editor/thing got installed to wrong folder... operator error...?   (deleted the one not working entirely n steam version launcher still seems to load up without issues -.-...)

**Edit again**

thought I resolved the problem by realigning/redoing some stuff, turns out nothing changed >.>....  still red box -__-

Appears that ff7 normal launch without the launcher just (ff7.exe) is working fine, but it skips the intro videos (just goes to new/contine)

7th heaven "Launch" still does the same however...  (squaresoft, chocobos, to red box with black screen & stays there)

Also seems 7th is pulling the mod library from C:\Games\Final Fantasy VII\7th Heaven  while the game library is in C:\Program Files (x86)\Steam\steamapps\common\FINAL FANTASY VII\ff7.exe   I'm not sure if this matters or not though... 
« Last Edit: 2016-05-12 01:30:56 by Kurne »


  • *
  • Posts: 120
  • Star Platinum
    • View Profile
Re: Red box crash upon start up
« Reply #1 on: 2016-05-12 23:12:25 »
I'm not techy enough to know what your problem is exactly, but the fact that you're using Program Files (x86) is a red flag, so I'd try uninstalling the mods, unpatching FF7, moving it to a "C:\Games\Steam\steamapps\common\FINAL FANTASY VII\mods" path, or anything outside of a system folder, and then repatching and reinstalling the mods.
Of course, if there's a simpler way to do what I said, you should do that instead.
And, once done (with any method), post what you did and what happened so we can see what the problem is or was.


  • *
  • Posts: 37
    • View Profile
Re: Red box crash upon start up
« Reply #2 on: 2016-05-13 02:51:17 »
Yes I've taken that into consideration as well..  Steam makes it difficult to install ff7 into a different folder, but finally managed to get it outside of the steam base.  Now I have it on the D drive.  D:\SteamLibrary\steamapps\common\FINAL FANTASY VII   specially.

During the reinstallation I cleaned the registry,  followed everything from scratch, deleted all old content (7th heaven included) and ran the mod file to unpatch all old data.   I cleared everything related to ff7 from the system.

reinstalled on the d drive, ran the mod file, set it to the new location of the library on D.  It went through without issues, set the configuration (sound n midi test)   finished the mod file,  ran 7th heaven,  lined up the settings with the new d drive (midi/video/exe files)   downloaded music mod, video upgrade mod, & new threat gameplay mod.  Activated one/all.    Hit Launch game & got the same results (which at this point were soul crushing btw >_>....)  Starts up, shows squaresoft, ednos interactive, chocobos running around the logo, then goes to a pitch black screen with a random small red rectangular box near the center of the screen.  At this point, nothing else responds.

Ironically since I moved it to the D drive,   running the ff7.exe without 7th heaven by itself seems to have the same results (on C drive it just skipped everything and went to new game option screen)   

Running ff7 through the normal launcher appears to load everything fine & routine (although i've noticed the distinct lack of music in the background while playing the regular game)

any ideas anyone?  I've tried about everything I can think of with compatibility changes to 8 or 9 different reinstallations with different approaches.  I feel that something small is missing, but I've run out of ideas...


  • 7th Heaven Crew
  • Global moderator
  • *
  • Posts: 3198
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: Red box crash upon start up
« Reply #3 on: 2016-05-13 06:26:30 »
I believe you're suffering from a graphics driver issue. If you look here: --- you will see (about halfway through the FAQs) that in the days of modding with Bootleg Configurator, ATI users experienced the same black screen/red triangles with certain drivers. Updating them to what was linked in the FAQ fixed it. I wouldn't have a clue about what drivers would be needed now a days for 7H. You'll need to experiment on your own with that. But if you find a good result, please report back. That kind of information can be very helpful to anyone else in the future who have the same issue.


  • *
  • Posts: 37
    • View Profile
Re: Red box crash upon start up
« Reply #4 on: 2016-05-13 20:45:24 »
EQ2Alyza You are amazing.   Deleted everything related to the current amd catalyst, followed the link,  gave issues trying to download the original file you presented in the solution, but a link was on the page to find the updated drivers based upon your computers specs,  I clicked that one, rolled with it, loaded the game and it... actually launched O_o....    The irony is that It launched fine from the Launcher prior, but appearantly requires different drivers to launch without using the normal ff7 launcher O_o... Alliteration >,,>? 

I think only minor issues I've come across are 60fps battle glitching out the game in startup along with bacause & menu overhaul causing it to glitch out as well during game start up.   (doesn't matter which exe is used, all cause a crash upon start up).  May do more research on prior problems/resolutions with it later,  just enjoying the game right now :D  (also, new threat is amazing)