Author Topic: Trouble with 7th Heaven  (Read 359 times)

mcdooby

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Trouble with 7th Heaven
« on: 2018-03-07 17:43:06 »
So i dug out FF7 fo the first time in ages and wanted to try 7th heaven. First of it all so glad to see an awesome mod and how hard people are working on this so thank you. And now to the problems I'm having.

1. I've done a fresh install via orginal disks, and used to key remover to make sure I had no FF7 keys before install and mounted the image as per instrustions, then i run the convertor to which is says it has placed a movies folder in the data folder in my ff7 directory. No such folder gets created so when i try to put my movies folder path in like it asks it can't find it. I have tried running convertor in admin mode but no joy.

2.I start 7th heaven and have followed all the instructions to setting up and installing the mods then go and start the game with the mods on.( i had to move the music files manually to the right folder to get the sound to work but no biggie thats nice and simple. Though I know the app.log says its not loaded its beacause i haven't moved it yet as this was another try.) i start the game and the first thing I notice is that the mod i used to change the the menu hasn't loaded. Then i click start game and the opening movie doesn't play and all i hear is the train coming in and barrett and cloud jumping off and no picture just a black screen, to which barrett's chat box then appears. i run forward in the dark to first battle which loads up and then picture appears. But the atb gauge and hp/mp and not showing properly. Once the battle is over it then loads up the screen with the picture but when i select the menu all its all squished to once side and none of the mods have activated have loaded. I have tried installing and actvating 1 mod a a time to see if it was one of then not loading but nope same issue.

I have most likely forgotton to do something but i'm not sure what it is and was wondering if anyone had any ideas?

Many thanks in advance.

P.S this is my APP.Log

[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF7 1.02 US English
[00000000] INFO: NVIDIA Corporation GeForce GTX 770/PCIe/SSE2 4.6.0 NVIDIA 388.13
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Using PBO
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 16384x16384
[00000000] INFO: Original resolution 640x480, window size 2048x1152, output resolution 1536x1152, internal resolution 3840x2160
[00000000] INFO: Shader limits: varying 124, vert uniform 4096, frag uniform 4096
[00000000] INFO: postprocessing program link log:
Fragment info
-------------
0(133) : warning C7050: "refractedColor.w" might be used before being initialized

[00000000] INFO: FFMpeg movie player plugin loaded
[00000000] INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
[00000000] INFO: VGMStream music plugin loaded
[00000000] INFO: Loading external library Multi.dll
[00000000] LOCK UNLOCK TEST
[00000001] MATRIX INITIALIZE
[00000001] INITIALIZE DD/D3D END
[00000001] initializing sound...
[00000001] creating dsound primary buffer
[00000001] reading audio file
[00000001] loading static sounds
[00000001] sound initialized
[00000001] set music volume: 127
[00000001] set music volume: 127
[00000001] Entering MAIN
[00000001] Exiting MAIN
[00000001] START OF CREDITS!!!
[00000001] ERROR: couldn't open movie file: C:\Games\Square Soft, Inc.\Final Fantasy VII\movies\eidoslogo.avi
[00000001] ERROR: couldn't open movie file: C:\Games\Square Soft, Inc.\Final Fantasy VII\movies\sqlogo.avi
[00000002] set music volume: 127
[00000003] ERROR: couldn't open music file: C:\Games\Square Soft, Inc.\Final Fantasy VII\/music/vgmstream/PRE.ogg
[00000066] set music volume trans: 127->0, step=60
[00000131] END OF CREDITS!!!
[00000131] Entering MAIN
[00000131] set music volume: 127
[00000131] Exiting MAIN
[00000131] START OF MENU SYSTEM!!!
[00000221] END OF MENU SYSTEM!!!
[00000221] Entering MAIN
[00000225] Exiting MAIN
[00000225] Field Start
[00000226] ERROR: couldn't open movie file: C:\Games\Square Soft, Inc.\Final Fantasy VII\movies\opening.avi
[00000456] WM_CLOSE
[00000456] Field Quit
[00000456] UNINITIALIZE DD

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 2712
  • Karma: 188
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: Trouble with 7th Heaven
« Reply #1 on: 2018-03-08 12:37:01 »
I've noticed a lot of issues when users have C:\Games\Square Soft, Inc.\Final Fantasy VII as their game path. I don't think the spaces, comma and period play very well with the game converter. Try installing into a shorter path such as C:\Games\FF7

mcdooby

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: Trouble with 7th Heaven
« Reply #2 on: 2018-03-09 16:41:43 »
Thanks for the advice I gave it a go, fresh install, cleaned the keys but no luck. I'm still having the same problems. Here is my app log and GC log which may shed some light on the situation.

Code: [Select]
APP.LOG: [00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF7 1.02 US English
[00000000] INFO: NVIDIA Corporation GeForce GTX 770/PCIe/SSE2 4.6.0 NVIDIA 388.13
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 16384x16384
[00000000] INFO: Original resolution 640x480, window size 2048x1152, output resolution 1536x1152, internal resolution 3840x2160
[00000000] INFO: Shader limits: varying 124, vert uniform 4096, frag uniform 4096
[00000000] INFO: postprocessing program link log:
Fragment info
-------------
0(133) : warning C7050: "refractedColor.w" might be used before being initialized

[00000000] INFO: FFMpeg movie player plugin loaded
[00000000] INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
[00000000] INFO: VGMStream music plugin loaded
[00000000] INFO: Loading external library Multi.dll
[00000000] LOCK UNLOCK TEST
[00000001] MATRIX INITIALIZE
[00000001] INITIALIZE DD/D3D END
[00000001] initializing sound...
[00000001] creating dsound primary buffer
[00000001] reading audio file
[00000001] loading static sounds
[00000001] sound initialized
[00000001] set music volume: 127
[00000001] set music volume: 127
[00000001] Entering MAIN
[00000001] Exiting MAIN
[00000001] START OF CREDITS!!!
[00000001] ERROR: couldn't open movie file: C:\Games\FF7\data\movies\eidoslogo.avi
[00000001] ERROR: couldn't open movie file: C:\Games\FF7\data\movies\sqlogo.avi
[00000002] set music volume: 127
[00000003] ERROR: couldn't open music file: c:\games\FF7\/music/vgmstream/PRE.ogg
[00000084] set music volume trans: 127->0, step=60
[00000149] END OF CREDITS!!!
[00000149] Entering MAIN
[00000149] set music volume: 127
[00000149] Exiting MAIN
[00000149] START OF MENU SYSTEM!!!
[00000364] END OF MENU SYSTEM!!!
[00000364] Entering MAIN
[00000368] Exiting MAIN
[00000368] Field Start
[00000369] ERROR: couldn't open movie file: C:\Games\FF7\data\movies\opening.avi
[00000622] WM_CLOSE
[00000622] Field Quit
[00000622] UNINITIALIZE DD

Code: [Select]
FF7_CG.Log:  FF7 GameConverter, Version 7th Heaven
Creator: Kompass63
Editor: EQ2Alyza

Start running at    Date: 08/03/2018    Time: 20:53:01.73
Active code page: 850
ActualPath C:\Users\Administrator\AppData\Local\Temp\7ZipSfx.000


You are running "Windows 7 Professional" on a 64 Bit Operating System (AMD64)

Real Management 32Bit WOW64

This patch is already applied.
Variables are taken from GameConverterKeys.

Unpatch?
Overwrite?
End?
Selection is:   Overwrite


Patching...

Copying Registry Keys...

Setting GC Registry Keys...

HKLM\SOFTWARE\Square Soft, Inc.\Final Fantasy VII\GameConverterkeys


Setting language to en...

Detecting drive letter for FF7 Discs...

Drive letter for FF7DISC1 --- J:\


Original release detected...

A "movies" folder has been placed into the data folder of your game directory...
TYPE the path to this "movies" folder, then press ENTER.

EXAMPLE: "C:\Games\Final Fantasy VII\data\movies" (parenthesis included)


Movies not found...

If custom Movies are located somewhere, change the "MoviePath" Registry Key entry at:
HKLM\SOFTWARE\Square Soft, Inc.\Final Fantasy VII


Movies path found at...

"C:\Games\FF7\data\movies\"

Copying English Files...

Copying 1.02 patch for ff7.exe...

Copying Aali's Custom Driver, version 0.8.1b...

Moving OGG music files...

Adding more Registry Keys...
Adding Registry Keys to HKLM\SOFTWARE\Square Soft, Inc.\Final Fantasy VII
Adding Registry Keys to HKLM\SOFTWARE\Square Soft, Inc.\Final Fantasy VII\1.00\Graphics
Adding Registry Keys to HKLM\SOFTWARE\Square Soft, Inc.\Final Fantasy VII\1.00\MIDI
Adding Registry Keys to HKLM\SOFTWARE\Square Soft, Inc.\Final Fantasy VII\1.00\Sound
Adding Registry Key to HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\FF7app.exe

Please check over the settings for FF7Config...

1) Sound tab should have a Sound device set. Do NOT leave it blank.
2) Perform the Sound and MIDI tests.
3) Graphics tab can be ignored.
4) Click OK when finished.

Inserting Multi.dll, Hext.dll, and Languagefile...

Patching FF7anyCDv2...

Install the Laptop Keyboard Patch?
(Choose YES if keyboard does NOT have a NUMPAD)
NO

Patching complete.

Check FF7_GC.log for details.


called with ""C:\Users\Administrator\AppData\Local\Temp\7ZipSfx.000\FF7_GameConverter_7H.bat""
Arguments: "C:\Users\Administrator\AppData\Local\Temp\7ZipSfx.000\FF7_GameConverter_7H.bat"

PROCESSOR_ARCHITECTURE:          x86
PROCESSOR_ARCHITEW6432:          AMD64
Actual Path:                     C:\Users\Administrator\AppData\Local\Temp\7ZipSfx.000
Product Name:                    Windows 7 Professional
Architecture:                    AMD64
Running in Modus                 32Bit WOW64
OS Bit Version                   64
Reg-Keyname Steam                HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Steam App 39140
Reg-Keyname Re-Release           HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{141B8BA9-BFFD-4635-AF64-078E31010EC3}_is1
Reg-Keyname 1                    HKLM\SOFTWARE\Square Soft, Inc.
Reg-Keyname 2                    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\FF7app.exe
Reg-Keyname 3                    HKCU\SOFTWARE\Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Square Soft, Inc.
Steam Release is present:         
Steam Release Path:               
Re-Release is present:           
Re-Release Path:                 
Original Release is present:     Yes
Original Release Path:           c:\games\FF7
Destination Path:                c:\games\FF7
Source Path:                     c:\games\FF7
Videos Path:                     C:\Games\FF7\data\movies
Original Videos Path:            D:\FF7\Movies
Original Language                en
Converted Language               en
Original Drive Letter:           D:\
Converted Drive Letter:          J:\
and now clear up Variables...
Ending at           Date: 08/03/2018    Time: 20:54:07.50

I only have 1 mod installed the field objects mod. I hope this helps and again many thanks :)
« Last Edit: 2018-03-09 17:44:41 by Covarr »

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 2712
  • Karma: 188
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: Trouble with 7th Heaven
« Reply #3 on: 2018-03-09 20:41:26 »
Well, I don't believe the original release installs any of the movies from the CDs, so the movies folder created by the game converter is left empty. You will either need to download the movies category from the Catalog or place the movie files manually into C:\Games\FF7\data\movies

Btw, you say you cleaned the keys, but if that were the case then the game converter would not detect the patch already applied. Not sure why it does, but just wanted to point that out.
« Last Edit: 2018-03-09 20:46:56 by EQ2Alyza »

mcdooby

  • Fast newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: Trouble with 7th Heaven
« Reply #4 on: 2018-03-11 12:57:21 »
So after finally getting some time to play around with it. I finally got it all working :) believe or not once I put all the movie files in the folder bang everything just worked :) no idea why but i'm not complaing. Thanks again for your help its appricated :) the mod is awesome, love playing FF7 again.