Author Topic: Vsync+60FPS causes massive battle lag for me.  (Read 400 times)

deano35

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Vsync+60FPS causes massive battle lag for me.
« on: 2018-06-29 16:03:37 »
If I turn off vsync I am able to achieve a full 60fps in battles using the Animation mod. However in other areas, I have significant screen tearing. If I run vsync the tearing stops but in battle, my max frames are 30/31 but the lag is significant, feels like the game is running at a quarter of that framerate despite my framerate counter saying otherwise. Does anyone have any experience with this, haven't been able to find much online so far. Thank you in advance.

Nephalis

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Vsync+60FPS causes massive battle lag for me.
« Reply #1 on: 2018-07-27 04:00:04 »
Hello everyone! I have exactly the same problem as described above on my notebook (GPU is GTX960m). On my Desktop PC it's working fine though on same settings in 7th Heaven config. Any help/tips would be much appreciated. Is there maybe some setting in the Nvidia Control Panel which could cause this issue? I tried to fix this for the last few hours but gave up for now, as I am unable to fix it. Only workaround is disabling the 60 fps battles as playing without Vsync looks just plain terrible.

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3995
  • Karma: 122
  • Just Covarr. No "n".
    • View Profile
Re: Vsync+60FPS causes massive battle lag for me.
« Reply #2 on: 2018-07-27 16:29:55 »
FF7's frame limiter is pretty much completely broken. As I recall, DLPB is working on a new one that will show up in the next version of Reunion.

Nephalis

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Vsync+60FPS causes massive battle lag for me.
« Reply #3 on: 2018-07-28 04:11:49 »
Today i tried again to find a solution. Looks like 2 apps on my notebook caused problems.

1) RivaTuner Statistics Server
2) Nvidia Geforce Experience Ingame Overlay (Display fps)

When i disabled the first one, i noticed a much smoother menu (opening animation), but combat still felt like 5 fps, even though the Nvidia Geforce Experience Overlay showed 30 fps in combat (with 60 fps battles enabled). Then i disabled the Geforce Overlay as well and now combat is as smooth as on my Desktop PC.

It looks like there was some kind of conflict with those apps. The funny thing is, that they are installed and running on my Desktop PC as well, but there i had no problems at all. I'm looking forward to the next update regardless. I really appreciate all the work the community has accomplished.


DLPB

  • No life
  • *
  • Posts: 9256
  • Karma: 301
  • For I realized that God's a young man, too.
    • View Profile
Re: Vsync+60FPS causes massive battle lag for me.
« Reply #4 on: 2018-07-29 20:01:28 »
As Covarr said.