Author Topic: Slowdown problem in FF8  (Read 285 times)

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Slowdown problem in FF8
« on: 2018-10-04 17:41:12 »
I hope this is the correct place to ask this.

So in certain places of FF8, there is a lot of slowdown (Gilgamesh appearences, Rinoa's Wishing Star etc.)
Did anyone find a fix for this other than enabling "Original Graphic Mode"?

I'm playing the Steam version.

Thanks in advance.

EDIT: Lowering the resolution helps too but I would rather play at 1080p
« Last Edit: 2018-10-04 22:13:40 by Opaque79 »

Covarr

  • Covarr-Let
  • Administrator
  • No life
  • *
  • Posts: 3985
  • Karma: 122
  • Just Covarr. No "n".
    • View Profile
Re: Slowdown problem in FF8
« Reply #1 on: 2018-10-05 15:37:00 »
What are your computer's specs? Slowdown depends a lot of the machine running the game (not that a game this old should have any slowdown at all on any remotely modern machine, but from what I understand the rerelease has higher requirements).

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Re: Slowdown problem in FF8
« Reply #2 on: 2018-10-05 16:02:34 »
My PC specs are as follows

OS - Windows 10 Home 64-bit
CPU - AMD FX-8350 8-Core 4Ghz
GPU - AMD Radeon RX 560
RAM 16GB DDR3

It's only during parts like Gilgamesh appearing and Rinoa's Wishing Star which I have heard is common.

If anything else is needed, please let me know.

DLPB

  • No life
  • *
  • Posts: 9238
  • Karma: 297
  • For I realized that God's a young man, too.
    • View Profile
Re: Slowdown problem in FF8
« Reply #3 on: 2018-10-05 19:25:42 »
The frame limiter in ff8 is poor but not totally broken like ff7.  That's part of it.,

 - Second, if using the speed up option in Steam, that can have issues.

 - Failing that - try forcing 1 CPU and not multiple cores, by going to task manager and selecting affinity option to use ONLY 'CPU 0'.

- You could always also try with Aero or whatever bells and whistles ff10 uses in the background.

 - Look at task manager cpu usage and see what else is eating processor power.

- Try without any antivirus software running

- Try setting graphic card to use max performance instead of power saving

- Make sure CPU setting is set to performance and not a saving mode.
« Last Edit: 2018-10-05 19:29:27 by DLPB »

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Re: Slowdown problem in FF8
« Reply #4 on: 2018-10-05 19:42:59 »
The frame limiter in ff8 is poor but not totally broken like ff7.  That's part of it.,

 - Second, if using the speed up option in Steam, that can have issues.

 - Failing that - try forcing 1 CPU and not multiple cores, by going to task manager and selecting affinity option to use ONLY 'CPU 0'.

- You could always also try with Aero or whatever bells and whistles ff10 uses in the background.

 - Look at task manager cpu usage and see what else is eating processor power.

- Try without any antivirus software running

- Try setting graphic card to use max performance instead of power saving

- Make sure CPU setting is set to performance and not a saving mode.

All of those suggestions made no difference.

Original Graphic Mode and low resolution (one or the other) gets rid of it but it makes the game look bad.
Taking off the graphical mods doesn't help either.

I wish to play at 1080p without Original Graphic Mode.

For testing, I tried my original disc copy of FF8 and the problem doesn't occur there. It only appears on the Steam version, even without using the speed up option.

It occurs in areas that have a kind of blur effect on screen like in the before mentioned areas.


DLPB

  • No life
  • *
  • Posts: 9238
  • Karma: 297
  • For I realized that God's a young man, too.
    • View Profile
Re: Slowdown problem in FF8
« Reply #5 on: 2018-10-05 21:08:24 »
May just be that the game doesn't like that resolution..  to be fair it was never meant for it and it looks like dogshit on 1080p.

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Re: Slowdown problem in FF8
« Reply #6 on: 2018-10-05 21:10:33 »
I am also using mods with Tonberry (which has nothing to do with the slowdown) so 1080p is preferred.

Looks like I am stuck. Thanks for the help.

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Re: Slowdown problem in FF8
« Reply #7 on: 2018-10-09 21:20:36 »
Apologies for double post but despite numerous possibilities, there is still no fix.

Here is a video of the issue
https://streamable.com/nznqr

I have sent a message to Square Enix for assistance but I may not get anywhere.

Cicciolo

  • Crazy poster
  • *
  • Posts: 122
  • Karma: 4
    • View Profile
Re: Slowdown problem in FF8
« Reply #8 on: 2018-10-10 09:45:51 »
It's a common bug that will probably never ever be fixed. I also remember the game lagging when Sorceress Adel uses the Quake magic. But that was also on PSX.

Read here: https://steamcommunity.com/app/39150/discussions/0/648816742961672333/

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Re: Slowdown problem in FF8
« Reply #9 on: 2018-10-10 11:50:17 »
Which is a shame. The description of the linked video below by FatedCourage claims to have fixed the lag issue and the video shows no slowdown
https://www.youtube.com/watch?v=GLdEJpiBC5I

An older video of his does show slowdown which led me to believe it was fixable.

DLPB

  • No life
  • *
  • Posts: 9238
  • Karma: 297
  • For I realized that God's a young man, too.
    • View Profile
Re: Slowdown problem in FF8
« Reply #10 on: 2018-10-10 11:59:06 »
It will be the frame limiter code.  The porting team didnt make a total tits of it like ff7 - but it's still crap.

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Re: Slowdown problem in FF8
« Reply #11 on: 2018-10-11 14:32:55 »
It turns out it is all down to CPU. The faster the CPU, the less lag those effects have.

However, it is still a game issue. It is countered by a very powerful PC

DLPB

  • No life
  • *
  • Posts: 9238
  • Karma: 297
  • For I realized that God's a young man, too.
    • View Profile
Re: Slowdown problem in FF8
« Reply #12 on: 2018-10-11 14:45:05 »
I doubt it...  FF8 should not need an i7 to run properly.  At the root is poor coding.

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Re: Slowdown problem in FF8
« Reply #13 on: 2018-10-11 15:22:30 »
I doubt it...  FF8 should not need an i7 to run properly.  At the root is poor coding.

Agreed. I'm just saying what FatedCourage said to me which is a game problem and it runs fine for him on an i7

Yagami Light

  • Cool newbie
  • *
  • Posts: 76
  • Karma: 15
    • View Profile
Re: Slowdown problem in FF8
« Reply #14 on: 2018-10-12 12:39:11 »
The pc version is definitely broken and not as smooth as the ps1 version at the intentional slowed down parts regardless if you have an i7 or not, but that amount of delay suggests either ram issues from using tonberry, or weak cpu.

Kaldarasha

  • No life
  • *
  • Posts: 2259
  • Karma: 134
  • Prince of Model Editing
    • View Profile
Re: Slowdown problem in FF8
« Reply #15 on: 2018-10-12 12:49:01 »
It can't be the CPU if the original graphics mode does fix his problem. As far as I know if you lower the resolution the more stress you take from GPU and put a bit of it on the CPU. 

DLPB

  • No life
  • *
  • Posts: 9238
  • Karma: 297
  • For I realized that God's a young man, too.
    • View Profile
Re: Slowdown problem in FF8
« Reply #16 on: 2018-10-12 12:54:51 »
It's the frame limiter and the code itself. It's not a good port.

Opaque79

  • Fast newbie
  • *
  • Posts: 12
  • Karma: 1
    • View Profile
Re: Slowdown problem in FF8
« Reply #17 on: 2018-10-12 14:52:09 »
It's the frame limiter and the code itself. It's not a good port.

I can't disagree now as nothing is fixing it outside of lower resolution or original graphic mode