Author Topic: [Solved] FF7 crashes, while running 7th Heaven  (Read 367 times)

AprilDruid

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
[Solved] FF7 crashes, while running 7th Heaven
« on: 2019-01-27 19:29:10 »
So I followed the instructions for 7th Heaven and the mods...don't work? Game runs fine and there are no issues, but none of my installed mods are working.


Edit: Thanks to Kaldarasha on the Discord, I was able to solve this.


If you're having an issue like mine where it's spitting out a Code 5, try downloading the latest version of 7th Heaven. https://github.com/TurBoss/7h/releases
« Last Edit: 2019-01-31 21:31:21 by AprilDruid »

marksmango

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Trouble with FF7 Mods.
« Reply #1 on: 2019-01-27 21:29:43 »
I had the same issue when I tried to start the game for the first time. What fixed it for me was running the Game Converter again, selecting the right audio device again, and then using the 'Launch Game' button in 7th Heaven to run the game.

AprilDruid

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
Re: Trouble with FF7 Mods.
« Reply #2 on: 2019-01-28 01:36:03 »
I had the same issue when I tried to start the game for the first time. What fixed it for me was running the Game Converter again, selecting the right audio device again, and then using the 'Launch Game' button in 7th Heaven to run the game.

Tried that, says it can't find any languages.

AprilDruid

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
FF7 crashes, while running 7th Heaven
« Reply #3 on: 2019-01-28 18:04:02 »
ok so after trying a fresh install, launching 7 through 7th Heaven now gives me a new error asking me to insert Game Disc 1, 2, or 3.


From there I re-did the bootloader since I changed my thumb drive letter, but still nothing.

I'm running the steam version of 7, so I'm lost.


unwrote the converter patch, installed it again and then ran 7th Heaven as Admin. It plays the squaresoft movie, but then freezes and crashes.

I'm stumped.

Edit again: This time I did a fresh install, 1 mod downloaded(Dynamic Cloud Weapons), it now gets to the menu and then it just hangs. I can't load my game or start a new one. So it's literally unplayable with 7th Heaven. The root cause of my issue is 7th heaven, I don't know why it's causing this, nor do I really care, but the mods are useless as a result.


Edit: I still don't know what's causing this. I use 1 mod, it doesn't work. I use multiple mods, it doesn't work. I've tried fresh installs(at least 3 times), I've tried overwriting the conversion with a new one, I've tried renaming my thumb drive to "FF7DISC1" and renaming the drive itself to F. I've tried messing with the sound. I've even tried fresh versions of 7th Heaven, and not updating it. I even tried adding a save into every slot.



Nothing works.

The game will either crash on the opening credits, or just hang on the menu, not allowing me to actually do anything.




If someone has a solution, I'd love to hear it.

Edit 3: Did a fresh install, ran everything as admin. Crashes on the opening credits still.
« Last Edit: 2019-01-29 21:52:45 by AprilDruid »

pixelporsche

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: [Solved] FF7 crashes, while running 7th Heaven
« Reply #4 on: 2019-02-05 15:21:21 »
Ahh! I haven't used FF7 mods since Bootloader. Now trying 7th Heaven with the Remako mod, I get a Code 5 EasyHook error. I have tried this on two machines, fresh installs of everything, all being run as admin. I've tracked down all the Easyhook errors on forums I could... just can't get the game to launch.

I tried using the latest version of 7th Heaven to no avail. Bummer :(