Author Topic: Apparent issue unpacking downloaded mods  (Read 196 times)

drougnor

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Apparent issue unpacking downloaded mods
« on: 2019-03-17 15:37:45 »
No matter which mod I download, it appears that when the program goes to unpack the downloaded .iro file, something crashes in the SharpCompress process.

Here's the error message

Code: [Select]
System.IO.FileLoadException: Could not load file or assembly 'SharpCompress, Version=0.22.0.0, Culture=neutral, PublicKeyToken=afb0a02973931d96' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'SharpCompress, Version=0.22.0.0, Culture=neutral, PublicKeyToken=afb0a02973931d96'
   at Iros._7th.Workshop.Install.InstallModProcedure.ProcessDownload(Object state)
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

=== Pre-bind state information ===
LOG: DisplayName = SharpCompress, Version=0.22.0.0, Culture=neutral, PublicKeyToken=afb0a02973931d96
 (Fully-specified)
LOG: Appbase = file:///C:/Users/drougnor/Desktop/FF7HDmods/7H_1.56_RC7/
LOG: Initial PrivatePath = NULL
Calling assembly : 7thHeaven.Code, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null.
===
LOG: This bind starts in default load context.
LOG: Using application configuration file: C:\Users\drougnor\Desktop\FF7HDmods\7H_1.56_RC7\7thHeaven.exe.Config
LOG: Using host configuration file:
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config.
LOG: Post-policy reference: SharpCompress, Version=0.22.0.0, Culture=neutral, PublicKeyToken=afb0a02973931d96
LOG: Attempting download of new URL file:///C:/Users/drougnor/Desktop/FF7HDmods/7H_1.56_RC7/SharpCompress.DLL.
WRN: Comparing the assembly name resulted in the mismatch: Minor Version
ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing terminated.

Many thanks in advance for any assistance.


UpRisen

  • Crazy poster
  • *
  • Posts: 194
  • Karma: 5
  • Again... AVALANCHE is born again!
    • View Profile
Re: Apparent issue unpacking downloaded mods
« Reply #1 on: 2019-03-18 14:13:02 »
Go to the settings part of 7th heaven and refresh the catalogue. If that doesnt work delete your 7thWorkshop folder located in your 7th heaven folder and in %appdata%, relaunch 7th heaven and refresh the catalogue and try again.

LordUrQuan

  • Crazy poster
  • *
  • Posts: 140
  • Karma: 2
    • View Profile
Re: Apparent issue unpacking downloaded mods
« Reply #2 on: 2019-03-28 21:18:48 »
Having a similar issue with 1.56_rc7 on a new VM I slapped on my laptop to play with while on vacation...  This time it's Win7 x32 (rather than my desktop's x64), fully patched.  Error as follows:

System.IO.FileLoadException: Could not load file or assembly 'SharpCompress, Version=0.22.0.0, Culture=neutral, PublicKeyToken=afb0a02973931d96' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'SharpCompress, Version=0.22.0.0, Culture=neutral, PublicKeyToken=afb0a02973931d96'
   at Iros._7th.Workshop.Install.InstallModProcedure.ProcessDownload(Object state)
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


UpRisen:  I tried your suggestion already, no dice.

Edit:  Stepping back to RC6 solves the issue
« Last Edit: 2019-03-28 22:09:14 by LordUrQuan »