Author Topic: init_postprocessing failed, postprocessing will be disabled  (Read 1124 times)

rambokev

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
I received a postprocessing error upon launching the game. The messageBox says "Postprocessing initialization failed, check APP.LOG for more information."

APP.LOG shows a path that mixes forward and backward slashes at line 9. Line 10 looks similar to the dialog box error. What's the fix?

[00000000] INFO: FF7/FF8 OpenGL driver version 0.8.1b
[00000000] INFO: Auto-detected version: FF7 1.02 US English
[00000000] INFO: NVIDIA Corporation GeForce GTX 1080/PCIe/SSE2 4.6.0 NVIDIA 416.94
[00000000] INFO: OpenGL 2.0 support detected
[00000000] INFO: Found swap_control extension
[00000000] INFO: Max texture size: 32768x32768
[00000000] INFO: Original resolution 640x480, window size 3440x1440, output resolution 1920x1440, internal resolution 3840x2160
[00000000] INFO: Shader limits: varying 124, vert uniform 4096, frag uniform 4096
[00000000] : failed to stat file D:\gaming\games\steamapps\common\FINAL FANTASY VII\/shaders/Nvidia_ComplexMultiShader/ComplexMultiShader.post
[00000000] : init_postprocessing failed, postprocessing will be disabled
[00000000] INFO: FFMpeg movie player plugin loaded
[00000000] INFO: FFMpeg version SVN-r25886, Copyright (c) 2000-2010 Fabrice Bellard, et al.
[00000000] INFO: VGMStream music plugin loaded
[00000000] INFO: Loading external library Multi.dll
[00000000] LOCK UNLOCK TEST
[00000001] MATRIX INITIALIZE
[00000001] INITIALIZE DD/D3D END
[00000001] initializing sound...
[00000001] creating dsound primary buffer
[00000001] reading audio file
[00000001] loading static sounds
[00000001] sound initialized
[00000001] set music volume: 127
[00000001] set music volume: 127
[00000001] Entering MAIN
[00000001] Exiting MAIN
[00000001] START OF CREDITS!!!
[00000001] INFO: D:\gaming\games\steamapps\common\FINAL FANTASY VII\data\movies\eidoslogo.avi; h264/aac 1280x960, 15.000000 FPS, duration: 10.193000, frames: 153
[00000052] WM_CLOSE
[00000052] END OF CREDITS!!!
[00000052] Field Quit
[00000052] UNINITIALIZE DD
« Last Edit: 2019-03-20 05:48:54 by rambokev »

satsuki

  • Insane poster
  • *
  • Posts: 293
  • Karma: 47
    • View Profile
    • My softs (french only)
"D:\gaming\games\steamapps\common\FINAL FANTASY VII\/shaders/Nvidia_ComplexMultiShader/ComplexMultiShader.post"
>seems not right
try "D:\gaming\games\steamapps\common\FINAL FANTASY VII\shaders\Nvidia_ComplexMultiShader\ComplexMultiShader.post" instead
and check you have the shader in the folder used ^^

paladin181

  • Crazy poster
  • *
  • Posts: 109
  • Karma: 0
    • View Profile
"D:\gaming\games\steamapps\common\FINAL FANTASY VII\/shaders/Nvidia_ComplexMultiShader/ComplexMultiShader.post"
>seems not right
try "D:\gaming\games\steamapps\common\FINAL FANTASY VII\shaders\Nvidia_ComplexMultiShader\ComplexMultiShader.post" instead
and check you have the shader in the folder used ^^
How would you change that? I ran into the same issue when trying to use the post processing shader setup through the mod. The shaders were in the folder but always failed.

satsuki

  • Insane poster
  • *
  • Posts: 293
  • Karma: 47
    • View Profile
    • My softs (french only)
Edit the ff7_opengl.cfg with notepad (don't know if 7thHeaven will overwrite it after, if yes, i don't know how to solve)

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 2967
  • Karma: 206
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
7H only overwrites when you open Workshop -> Aali Driver Settings and then click the OK button after choosing your options.

Shaders are highly untested and not fully compatible with all GPUs, so they're difficult to problem solve.

Shino

  • Fast newbie
  • *
  • Posts: 10
  • Karma: 1
    • View Profile
I had the same problem, at the specified path the required file does not exist.

I create the folder path and then it works. But i don´t have the Nvidia ComplexMultiShader.
I tested this with the Bloom2 Shader and this works.


tracido

  • Cool newbie
  • *
  • Posts: 74
  • Karma: 1
    • View Profile
I had the same problem, at the specified path the required file does not exist.

I create the folder path and then it works. But i don´t have the Nvidia ComplexMultiShader.
I tested this with the Bloom2 Shader and this works.

This solves it for all of them if you can find the missing files..

shaders/All_SmartShader2/SmartShaderPost.fx

shaders/All_SmartShader/SmartShaderPost.fx

shaders/ATI_ComplexMultiShader/ComplexMultiShader.post

shaders/Nvidia_ComplexMultiShader/ComplexMultiShader.post

Those are the only four not functional because of those missing files, ComplexMultiShader.post & SmartShaderPost.fx.

Thanks for finding that.. 
« Last Edit: 2019-04-28 17:16:06 by tracido »

tracido

  • Cool newbie
  • *
  • Posts: 74
  • Karma: 1
    • View Profile
How would you change that? I ran into the same issue when trying to use the post processing shader setup through the mod. The shaders were in the folder but always failed.

You have to put all the shader files in those folders, I just made mass copies in each folder to save time. Make the folders like this: "All_*" "ATI_*" "Nvidia_*" The problem with Nvidia is, there is no ComplexMultiShader.post file for the shader