Author Topic: Music not playing on VGM  (Read 378 times)

Sobadx

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Music not playing on VGM
« on: 2019-04-22 14:04:34 »
So if I set my driver Aali settings to VGMstream I get no sounds and my mods work yet if I change it to none it comes up with an error saying media plugin failed to load however the music and sounds work but all the other mods don't, I couldn't find an answer to fix this anywhere so here I am posting. I have uninstalled and redone the whole installation process again and that didn't fix it.

Edit1: there is now a sharp sound when I open the game yet to figure this out, I checked my gamedir and all my .ogg music files are there under FINALFANTASYVII\music\vgmstream. just in case i copied all the music files into my data\music and data\music.ogg folders however both of those didn't produce sound either.
« Last Edit: 2019-04-23 07:29:18 by Sobadx »

Sobadx

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Re: Music not playing on VGM
« Reply #1 on: 2019-05-12 10:14:51 »
Just did the whole uninstall Reinstall and still the same problem, sharp sound on start-up and no sound plays, when I did the converter I tested and there was sound, after downloading
Media - Music and Sound I left it all as was after activating it, my load order is the exact same as the tutorial. really want to play this game again but with better field models and a bit harder difficulty yet having no sound is really annoying. also I have tried all my sound options (headset, monitor) and same problem, please if anyone has ANY suggestions I would love to hear them as noone has replied for a month.

Just tried all the FF7.exe's and it's only FF7_bc.exe that has no sound
« Last Edit: 2019-05-12 12:18:08 by Sobadx »

LordUrQuan

  • VirtualBox dweller
  • Insane poster
  • *
  • Posts: 293
  • Karma: 3
  • LOAD "FF2J",8,1
    • View Profile
Re: Music not playing on VGM
« Reply #2 on: 2019-05-13 02:40:50 »
also I have tried all my sound options (headset, monitor) and same problem
How are you changing your sound driver?  Running FF7_Config, or 7HConverter?

Sobadx

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Re: Music not playing on VGM
« Reply #3 on: 2019-05-13 08:33:53 »
I set my sound to headphones during the ff7 game converter but was just trying my monitor via volume mixer to see if that changed anything (which it didn't) however since i get game sounds (nomusic) via ff7mo.exe  I think there is something wrong with because and menu overhaul and it's BC.exe but I can't figure it out. I have both music and game sounds with the unedited ff7.exe
P.S I have done the whole activate mods to update the ff7.exe then changed the ff7.exe to ff7_bc.exe as stated in the walk through just so no one recommends that
« Last Edit: 2019-05-13 09:21:52 by Sobadx »

aodev

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Music not playing on VGM
« Reply #4 on: 2019-06-18 17:38:13 »
Hello, I have the exact same problem. Short sound when the game starts then nothing. Like you, if I start the game through Steam, I do have sound.

LordUrQuan

  • VirtualBox dweller
  • Insane poster
  • *
  • Posts: 293
  • Karma: 3
  • LOAD "FF2J",8,1
    • View Profile
Re: Music not playing on VGM
« Reply #5 on: 2019-06-18 22:26:05 »
Missed the 5/13 post, but if you are using FF7_Config to change your sound settings, the necessary registry entries aren't being updated to match.  Changing output device requires re-running the converter, and choosing "Overwrite" when prompted at the beginning.

aodev

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Music not playing on VGM
« Reply #6 on: 2019-06-19 13:04:15 »
I managed to get the sound by switching the audio device to my TV HDMI.

I am running the game with HDPI compatibility mode to avoid having the screen split in half. It lead me to think that maybe it's an issue with the HDMI sound output. That said it is weird, normally the PC simply send the sound to the TV. (and I dont have this issue with the normal game)