Author Topic: SeeDReborn v4.1 half the textures not working? <Solved>  (Read 623 times)

Hazedge

  • Crazy poster
  • *
  • Posts: 108
  • Karma: 1
    • View Profile
S'up guys, quick problem here that I hope its easy to solve (well, I hope)
I've installed the SeeDReborn v4.1 that was recently posted here. The Tonberry v2.04 and Microsoft Visual C++ are all installed and updated, but theres something wrong going on...

Below is a print of the menu screen, the navigator did not change to the gunblade one. LV, HP and their values, Play Time, SeeD rank and Gil did not changed as well.


Most of the new icons did not change in the print below


In-battle you can see the damage's value did not change, only the characters names and the command action/options.


Even the in-battle HP values ​​(like the menu ones) did not change


I did everything that instructed in the mod's post, copyed and pasted the "texture" folder to FFVIII root, alongside tonberry and some other mods (as you can see in the prints, I modded their clothes and the 3D character face on menu and its working correctly)
« Last Edit: 2019-06-17 13:07:54 by Hazedge »

Mcindus

  • Freak
  • *
  • Posts: 810
  • Karma: 133
  • Artist, Modder, Musician.
    • View Profile
    • Lunatic Pandora
Re: SeeDReborn v4.1 half the textures not working?
« Reply #1 on: 2019-05-30 17:14:59 »
Hello!  This may be due in part to the indexing of the pngs listed in /ic/iconflmaster/  -- do you have photoshop?  If so, could you open the images from the iconflmaster section and see if any of them are 'background' layers that are locked?  If so, they need to be saved as a png with transparency, and this should fix the issue.  If these files look fine, then there may be an issue with the hashmap file I provided with the mod.  Do you have the right hashmap file in your tonberry/hashmap file for the Spanish version?  Can you try a different save that is on a different disc and let me know if the issue persists?

Hazedge

  • Crazy poster
  • *
  • Posts: 108
  • Karma: 1
    • View Profile
Re: SeeDReborn v4.1 half the textures not working?
« Reply #2 on: 2019-05-30 22:03:54 »
I've opened the iconflmaster_13 and iconflmaster_15 with photoshop and both have a transparent background (tried putting a black background in a layer below and it looks fine)
Strange that the _13 have modded only 1/4 the img, but maybe its necessary to make it work, I don't know

iconflmaster_13


iconflmaster_15


Tried a new game and the problem still remains.
I'm using a translated data to portuguese from Brazil overwriting the lang_en so I'm using the mod's english hashmap on FINAL FANTASY VIII\tonberry\hashmap
« Last Edit: 2019-05-31 02:40:23 by Hazedge »

Sebanisu

  • Crazy poster
  • *
  • Posts: 108
  • Karma: 6
    • View Profile
Re: SeeDReborn v4.1 half the textures not working?
« Reply #3 on: 2019-06-01 07:21:46 »
You could enable debug mode for tonberry and see which images are not being replaced then post the relevant ones here, and then he can get the hash and check the map to see if it's missing.

Sent from my Pixel XL using Tapatalk


Hazedge

  • Crazy poster
  • *
  • Posts: 108
  • Karma: 1
    • View Profile
Re: SeeDReborn v4.1 half the textures not working?
« Reply #4 on: 2019-06-01 13:27:01 »
Oh, I can do that? I'll check the files on the Tonberry folder and follow its tutorial. I'll try sending the info here.

EDIT:
Played for a while trying to trigger the scenes where the textures didnt worked, don't know if its relevant but the ones that showed up on noreplace folder thats similar to iconflmaster_13 and iconflmaster_15 were:

019.bmp
175.bmp
270.bmp
303.bmp
1281.bmp
1299.bmp
1345.bmp
1363.bmp
1581.bmp
1633.bmp (they all look the same)


288.bmp
290.bmp
1597.bmp
1599.bmp (same story here)


« Last Edit: 2019-06-01 13:55:09 by Hazedge »

Mcindus

  • Freak
  • *
  • Posts: 810
  • Karma: 133
  • Artist, Modder, Musician.
    • View Profile
    • Lunatic Pandora
Re: SeeDReborn v4.1 half the textures not working?
« Reply #5 on: 2019-06-01 18:14:34 »
Can you send me a file with all of those .bmps?  i'll run them through berrymapper and make a portuguese release!  Also, that iconflmaster_13 looks incorrect, so i'll have to fix that.  thanks for your feedback!  you can email the file to mcindusmods @ gmail

Hazedge

  • Crazy poster
  • *
  • Posts: 108
  • Karma: 1
    • View Profile
Re: SeeDReborn v4.1 half the textures not working?
« Reply #6 on: 2019-06-02 01:47:50 »
Can you send me a file with all of those .bmps?  i'll run them through berrymapper and make a portuguese release!  Also, that iconflmaster_13 looks incorrect, so i'll have to fix that.  thanks for your feedback!  you can email the file to mcindusmods @ gmail

Done! E-mail name BMPs NOREPLACE.
All that was done was using the Translator Tool, Carbuncle and others text mods to translate the dialogue and options to portuguese using the lang-en as base.
You think the language could be part of the problem?
Making iconflmaster_13 and iconflmaster_15 look the same can solve the problem? iconflmaster_15 appears with low opacity, maybe I could multiply it to make it look opacity 100%?
« Last Edit: 2019-06-02 01:50:54 by Hazedge »

Hazedge

  • Crazy poster
  • *
  • Posts: 108
  • Karma: 1
    • View Profile
Re: SeeDReborn v4.1 half the textures not working?
« Reply #7 on: 2019-06-17 12:33:28 »
Its been a long time (long time testing every single file) and finally I've found the culprit!!
I have bought "Mcindu's Lunatic Pandora" and installed in a fresh FFVIII folder, everything worked just fine. So bit by bit I started applying my mods and other stuff until I got to Data folder.
The culprit is "menu" in "FINAL FANTASY VIII/Data/land-en" folder
Now I'm going to try using "FF8 Archive Commander" to extract Lunatic Pandora's TEX from its menu and insert inside the new FFVIII folder one. I'll edit this post for the results.

EDIT:

And thats it folks!! Everything working just fine!!
I wanted to thank everyone who tried to help me in this post and hope this community grows even more with the FFVIII Remaster coming up! (hope there will be a convertion for our mods to use in the Remaster o/)
« Last Edit: 2019-06-17 13:06:54 by Hazedge »

Sebanisu

  • Crazy poster
  • *
  • Posts: 108
  • Karma: 6
    • View Profile
Re: SeeDReborn v4.1 half the textures not working? <Solved>
« Reply #8 on: 2019-06-17 21:47:22 »
that makes sense if the menu.tex is different then the hash would change