Author Topic: Random 7th Heaven Injection Eeors  (Read 328 times)

Ender

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
Random 7th Heaven Injection Eeors
« on: 2019-06-14 13:30:42 »
So, I've been getting Code 5 injection errors at random since I've been using the program.



I have tried all manner of mod combinations, but even a mod combination that works fine several times in a row will then not work several times in a row. I'm talking about launching, immediately closing, changing nothing, then launching again. Sometimes it will only work two times of out of ten. Some times more, sometimes less. it's completely random, and not at all dependent on mods. I have tried it with no mods installed. I have tried it with damn near every combination possible. I have tried changing the .exe as specified in the tutorial. I have tried using different .exe than specified in tutorial. I've tried damn near everything.

1) Running the .exe directly does not have this issue. This is only a problem with 7th Heaven.
2) I have disabled (but not uninstalled) my Antivirus, which is AVG. I have added exceptions to Final Fantasy VII.
3) I have set all .exe to run in administrator modes.
4) I have enabled/disabled several combinations in OpenGL settings.
5) I have re-run Game Converter multiple times.

Nothing has worked so far. I love 7th Heaven soooooo much (Thanks Guys!!!) but I'd also love to be able to use it without spending ten minutes to get it to launch.
« Last Edit: 2019-06-14 14:35:13 by Ender »

demanson

  • Fast newbie
  • *
  • Posts: 19
  • Karma: 0
    • View Profile
Re: Random 7th Heaven Injection Eeors
« Reply #1 on: 2019-06-15 00:42:52 »
Try this:
    Error when launching game

         Right click your 7th Heaven.exe and select properties, compatibility tab and set it to run as admin.

         Go to the same tab but for FF7.exe (Right click your FF7.exe and select properties, compatibility tab) and tick the box that say "Run in 640x480"(Do the same for all other exe's).
         This will not actually affect your gameplay as 7th Heaven takes over it anyway.
         https://imgur.com/yI30qaq
         https://imgur.com/qkW7VfI

Ender

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
Re: Random 7th Heaven Injection Eeors
« Reply #2 on: 2019-06-15 11:31:54 »
I had actually tried that before many times. However, last night, I ran 7th Heaven itself through a shortcut with parameters instead of the .exe with properties settings and it worked several times in a row. I'll test it more tonight. It may have been solved. Thanks!!!

demanson

  • Fast newbie
  • *
  • Posts: 19
  • Karma: 0
    • View Profile
Re: Random 7th Heaven Injection Eeors
« Reply #3 on: 2019-06-15 22:41:45 »
Ah, I think I get it now, I normally open 7th heaven thru a shortcut so there may be a problem with the normal .exe running with admin rights not sure why or how that would be but it might be one of those win10 quirks.

Ender

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
Re: Random 7th Heaven Injection Eeors
« Reply #4 on: 2019-06-16 01:49:45 »
So running through a shortcut does infact get rid of the error message. However, not it just beeps and crashes back to desktop immediately. Again, this is why numerous combinations of mods, or no mods at all.

Apparently this problem has spread to .exe's themselves as running the unmodded .exe crasesh to desktop. I swear, this makes no sense. I leave my computer on, unused, untouched, and it changes the problem while I'm away and is completely random each time I press launch. Grrrrrrrrrrrr
« Last Edit: 2019-06-16 01:55:29 by Ender »

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 3034
  • Karma: 208
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: Random 7th Heaven Injection Eeors
« Reply #5 on: 2019-06-16 02:58:39 »
I swear, this makes no sense. I leave my computer on, unused, untouched, and it changes the problem while I'm away and is completely random each time I press launch. Grrrrrrrrrrrr

Slow breathes. Don't let a video game consume you. Windows updated while you were away, which often breaks the registry. It's an old game from the Windows 95 era, so it's gonna have its headaches to get running.

Explain your "crash to desktop" please. Is there a beep a second or two after the game window opens? Does it open and close immediately without a beep? Is there an "Oops..." message after the game window opens?

Ender

  • Fast newbie
  • *
  • Posts: 5
  • Karma: 0
    • View Profile
Re: Random 7th Heaven Injection Eeors
« Reply #6 on: 2019-06-17 22:10:56 »
I wasn't as upset as it sounded :P Windows didn't update because I have them disabled. There was a beep, but no message.

Whatever the problem was, it's back to working fine. I've been able to get it to run fairly consistently, and when it does run, I just leave it open. So I'ma call it magically 'fixed'.

Just theorycrasfting here, but It's possible that it was a multiple hard drive issue, since I consolidated them onto my SSD to decrease load times (which were getting large because of repeatedly adding extra folders) to save space on my small SSD but large 10TB secondary, and since then no issues, but I haven't been testing that long.

Either way, 7th Heaven and the mods are wonderful things. Thank you all so much. I am enjoying them immensely. I remember back in the days before 7th Heaven manually installing mods and how difficult is was then, even with these problems, 7th Heaven is much simpler.

Also, since the beginning, I have assumed that this difficulty stemmed from Windows-related strangeness or third-party application interference. Nothing against those who worked on this terrific software.
« Last Edit: 2019-06-17 22:58:11 by Ender »