Author Topic: About the ff7input.cfg file for Laptops and mods  (Read 144 times)

Lunos

  • Newbie
  • *
  • Posts: 4
  • Karma: 1
    • View Profile
About the ff7input.cfg file for Laptops and mods
« on: 2019-06-19 12:31:03 »
Hey guys, how's all?
After going through a few hardships, I finally managed to turn my Steam release of FFVII into the old 1998 release so I can use mods.
Before diving into that territory though, I wanted to ask if there was a way to edit the ff7input.cfg file to one's liking.

I got mine from this post written by the user PitBrat, but I noticed a problem in which going diagonally in certain directions doesn't really seem to work.
For example, if I hold the right arrow key and then press the up arrow key, Cloud keeps walking to the right instead of going upwards diagonally.
That's kind of annoying and I'd like to know if there was a way to fix it. I thought that maybe I could edit the ff7input.cfg file and figure something out, but when I tried to open it with Notepad++, this is what I got:


I also don't quite like the way in which the controls are set. I had to try every single key of my keyboard to find out that the Escape key was used to confirm a character's name, lmao. I was avoiding it until the very last moment because I thought it would force close the game, so if I could change that too somehow, that would be awesome.

Naturally, if there's no other choice, I guess I'll just have to get used to this control layout, but I'd really really like to fix the issue with the movement, because oof, that one is pretty annoying.

Thanks in advance for reading :)!

EDIT: About modding.
Spoiler: show
In the meantime, I'm trying to get used to my current situation and started to get into modding a little bit.
Right now, the only single mod I have downloaded was Beacause straight from 7th Heaven.
I enabled it after the download was complete, I also enabled "Break 9999 Limit" and I've set the head indicator to "Remove" too.
When I booted up the game after that though, the font looked weird and the battle UI looked pretty glitchy.


Right now, this is how I have 7th Heaven's OGL Driver Configuration Set:

Resolution:
Window Size - 640x480
Internal Size - Blank

Graphics:
Linear Filter - Checked

Rendering:
New Timer - Checked

Everything else is unchecked or set to the default value. New Timer was checked by default too actually, but I wanted to clarify that I haven't unchecked it.

Suggestions? My desktop resolution is 1360x768.


EDIT2: About modding, again.
Spoiler: show
If I try to run the game using the ff7_bc.exe file instead of ff7_mo.exe, the font looks more correct, but a few options overlap or go out of the menu interfaces. The battle UI still looks glitchy, sadly.



EDIT3: About modding, I fixed my problem.
Spoiler: show
I don't know what exactly was causing it, but I simply decided to try out the configuration that user MrZeffy posted here, and after booting up the game I was able to see that my problems just vanished.



Of course, I had to turn VSync off because otherwise the overworld ran at 20 FPS just like it happened to him.


EDIT4: Alright, I think I was able to fix my issue. I just... modified the controls In-Game.
Last time I tried to do that, the controls stopped working, so I was avoiding it like the plague, lol.
« Last Edit: 2019-06-20 10:55:11 by Lunos »