Author Topic: Strange vertical lines when using custom textures  (Read 206 times)

jacquelineadelia

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Hey everyone, I have been having an issue with these strange vertical lines appearing onscreen whenever I use custom textures. I'm using 7th Heaven and a bunch of different mods, but this is an issue I've found occurs even when I don't have anything enabled but the custom textures, and it's happened with multiple different custom texture releases.

I've taken a short video of what these lines look like (they're most visible when you are climbing up the stairs after Jessie in the video), and tested many different OpenGL settings, but nothing has had any effect.

Here's the video: https://drive.google.com/open?id=138ozlauryFTyHR5QU--IqBqriR4WVdwh

And here's a screenshot of the lines I also took for quick reference (though it's more obvious in motion):



Is there any way for me to stop these vertical lines from appearing? At this point, it's my only problem, so if there isn't a solution, I can live with them, but I would like to get rid of them if possible, as they are pretty distracting in gameplay.

Worth noting, these lines only appear when traversing a field with a pre-rendered background; they haven't appeared in battle and I haven't tested in the world map yet either, though I'd guess the world map is probably fine if the battle screen is fine.

jacquelineadelia

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Strange vertical lines when using custom textures
« Reply #1 on: 2019-07-27 19:02:29 »
Well nevermind, it seems I solved it! For those wondering how, my issue here was from lowering the Internal Resolution 7th Heaven forced the game to display at to the resolution I wanted my window to be, 1400x1050. I solved the issue by changing the internal resolution back to 3840x2160, without needing to change the size of my window. I believe that the issue has been occurring because the game was having trouble adaptively scaling the custom textures, which are at 4k resolution, to the game, but it was able to do so without issue when the internal resolution matched the textures it was trying to display.

EQ2Alyza

  • 7th Heaven Crew
  • Global moderator
  • No life
  • *
  • Posts: 3063
  • Karma: 213
  • Dilly-Dally Shilly-Shally
    • View Profile
    • EQ2Alyza - YouTube Channel
Re: Strange vertical lines when using custom textures
« Reply #2 on: 2019-07-28 03:19:52 »
7H doesn't "force" an internal resolution. It's only set by what the user types in the Workshop -> Aali Driver Settings, which then sends and saves those settings to the ff7_opengl.cfg file. This file is installed by FF7_GameConverter_7H.exe with the default setting of 3840x2160. How that was changed to 1400x1050 remains a mystery, especially considering that the settings window states the internal resolution should be multiples of 320x240