Author Topic: [FF8:R] Demaster unofficial patch- HD fields, monsters, fixes + launcher 1.2.8a  (Read 21896 times)

Yagami Light

  • *
  • Posts: 157
    • View Profile
Do not update using the launcher it will give errors, use this link to download, copy and paste the files over. If you are using mods, use them one at a time to see which one is giving errors.

This tool will not work if you are using pirated copies of the game, buy it officially on steam for the mods to work.

https://github.com/MaKiPL/FF8_demastered/releases
« Last Edit: 2020-06-21 18:35:07 by Yagami Light »

Rikku

  • *
  • Posts: 27
    • View Profile
Hi everyone !!

I just saw this and i want to try the FF8 remastered with Ragnarok mod, which sent me to this page

Can this tool work as Roses and Wine, some like altering some things like no consume magic when you cast them ? or maybe have 1 magic the stat effect of 100 ?

Or is this tool different in another way ?

Thanks

hekaton

  • *
  • Posts: 3
    • View Profile
Hi guys, i was finally able to get it to work by getting the latest version of the game, but now i am encountering a new problem where in certain areas of the game as i advance, it crashes on me with this error regarding an image being out of bounds. I have attached a link to the problem. what can i do in such situations? Thanks

https://imgur.com/a/ircMFV0

Fel_Noctus

  • *
  • Posts: 2
    • View Profile
Hey everyone, wanted to point out an issue with Demaster 1.2.8a and Horizonpack 1.1a. When I leave Deling City the textures for the world map, namely, cliffsides, cities and certain sections of the ground are black boxes. It can be fixed by simply going into another area (tomb of the unknown king) and then returning to the world map but I can replicate it every time I enter Deling and then leave.

Ozerflip

  • *
  • Posts: 5
    • View Profile
The PDF manual was removed in later releases, you can download the first version https://github.com/MaKiPL/FF8_demastered/releases/tag/1.1.1

To use field files you need to download FatedCourages angelwing gigapixel version, then use the textureModHelper included which automatically renames all the field names to be compatible with the demastered version. However some fields are named incorrectly and FatedCourage hasn't released his own fields for remastered yet so you have to rename them manually.

@Temujin64 you need to replace the xbox button textures in 4_xinput PNG inside iconfl03 folder.


Hi,
First I have to thank you all and especially Maki to make the modding of the remastered possible, you're great!

I tried to put the FatedCourages's angelwing megapixel on the demaster, but the textureModHelper found in the first version doesn't seem to work (nothing happens when I launch "ff8demaster_textureModder.exe"... It's written in the PDF to lanch "demaster_BGtextureWorker.exe", but I could not find it anywhere...

A bit help please ?   ;D

Yagami Light

  • *
  • Posts: 157
    • View Profile
The exe is insider the texturemodhelper folder, if it doesn't run, update .Net framework to the latest version, try running the program as admin or see if windows/anti virus is blocking the program from running. 

Ozerflip

  • *
  • Posts: 5
    • View Profile
The exe is insider the texturemodhelper folder, if it doesn't run, update .Net framework to the latest version, try running the program as admin or see if windows/anti virus is blocking the program from running.

Still doesn't run... Please could you send me the corrected "field_bg" folder if you already have it ? Then I won't have to use the textureModHelper...

MartinThor

  • *
  • Posts: 3
    • View Profile
Does somebody have the correct filenames for the backgrounds in the remaster? I know screen 2 and forward in the fire cavern loads wrong due to naming schemes, but would be nice if somebody had the correct names for them and other instances later in the game, if any? :)

MartinThor

  • *
  • Posts: 3
    • View Profile
Still doesn't run... Please could you send me the corrected "field_bg" folder if you already have it ? Then I won't have to use the textureModHelper...

I figured out what might be the problem from checking the event viewer when attempting to launch, you have to D/L .NET Core, not framework to get it to launch (worked for me at least).
Only problem after that is there's still the wrong filenames on some bg's

Yagami Light

  • *
  • Posts: 157
    • View Profile
I've changed some of the fire cavern field names,  there are some errors in the final room and a small error in the room before. Heres the link to the updated fields
https://drive.google.com/file/d/1bVX2yYvJaGayrmLSkLYLYxoiNQIPnugr/view?usp=sharing

Ozerflip

  • *
  • Posts: 5
    • View Profile
Thank you so much!  ;D

makinator

  • *
  • Posts: 2
    • View Profile
The fights turn at 15 fps with demaster ...
Is this normal?

Strife03

  • *
  • Posts: 1
    • View Profile
Hello very nice job. Unfortunately i encounter some problems.

common_load_texture: tex_type: FIELDBG, pal: 0, unk: 00000000, bHaveHD: FALSE, Tpage: 19
common_load_texture: tex_type: FIELDBG, pal: 0, unk: 00000000, bHaveHD: FALSE, Tpage: 16
common_load_texture: tex_type: FIELDBG, pal: 2, unk: 00000000, bHaveHD: FALSE, Tpage: 16
common_load_texture: tex_type: FIELDBG, pal: 4, unk: 00000000, bHaveHD: FALSE, Tpage: 16
common_load_texture: tex_type: FIELDBG, pal: 6, unk: 00000000, bHaveHD: FALSE, Tpage: 16
common_load_texture: tex_type: FIELDBG, pal: 8, unk: 00000000, bHaveHD: FALSE, Tpage: 16
common_load_texture: tex_type: FIELDBG, pal: 0, unk: 00000000, bHaveHD: FALSE, Tpage: 17
common_load_texture: tex_type: FIELDBG, pal: 2, unk: 00000000, bHaveHD: FALSE, Tpage: 17
common_load_texture: tex_type: FIELDBG, pal: 4, unk: 00000000, bHaveHD: FALSE, Tpage: 17
common_load_texture: tex_type: FIELDBG, pal: 6, unk: 00000000, bHaveHD: FALSE, Tpage: 17
common_load_texture: tex_type: FIELDBG, pal: 8, unk: 00000000, bHaveHD: FALSE, Tpage: 17
common_load_texture: tex_type: FIELDBG, pal: 0, unk: 00000000, bHaveHD: FALSE, Tpage: 18
common_load_texture: tex_type: FIELDBG, pal: 2, unk: 00000000, bHaveHD: FALSE, Tpage: 18
common_load_texture: tex_type: FIELDBG, pal: 0, unk: 00000000, bHaveHD: FALSE, Tpage: 19
common_load_texture: tex_type: FIELDBG, pal: 2, unk: 00000000, bHaveHD: FALSE, Tpage: 19
common_load_texture: tex_type: FIELDBG, pal: 4, unk: 00000000, bHaveHD: FALSE, Tpage: 19
common_load_texture: tex_type: FIELDBG, pal: 6, unk: 00000000, bHaveHD: FALSE, Tpage: 19

How can I fix it ?