Author Topic: FF8 Registry right after install (problem)  (Read 11004 times)

gig4ls

  • Guest
FF8 Registry right after install (problem)
« on: 2007-05-07 03:36:48 »
Just noticed something interesting about my registry keys after install of ff8 which could be the reason why it's not working.
The following keys have a value of 0:
Graphics, MIDIGUID, MidiOptions, SoundOptions

This is on vista. I was wondering why it was black screening, but I guess this makes sense. I'm going to try uninstall/reinstall and double click on ff8.exe without configuring to see what will happen.

EDIT: No dice, probably too much to expect Vista to play nice w/ games this old. I do remember getting it working before in Vista x64...I also noticed for some reason it thinks that the data path should be c:\ instead of d:\. I compared it to my install on the xp machine and d:\ (or rather, just CD drive) should be the path.



MOD EDIT: This belongs in Tech Support. Moving.
« Last Edit: 2007-05-08 03:56:28 by gig4ls »

Prince Lex

  • Freak
  • *
  • Posts: 883
  • Karma: 1
  • Opinionfact is Redundancy
    • View Profile
    • Myspace Profile
Re: FF8 Registry right after install (problem)
« Reply #1 on: 2007-05-31 12:38:36 »
I installed it on vista last night and I was getting the black screen too. I had the FF8 Configurator in my install directory with the original FF8Config that comes with the game, and then when I removed the FF8Config it worked fine. If you make any changes to the registry I think it resets at some point? For example I made copies of my discs to run the game faster so I had to change DataDrive to "g:" instead of "d:" and that was fine, then when I ran the game after fixing blackscreen-crapness it asked me to insert disc one. So I went back to my registry and it had changed back to d: - no idea why. I changed it and it worked fine. I'm not even going to attempt to install FF7 at the moment, I used to spend hours getting that to work properly and I shudder now at the thought of it on vista. *shudders some more*

kraziinewb

  • Guest
Re: FF8 Registry right after install (problem)
« Reply #2 on: 2007-12-19 08:19:51 »
ummm try this site for ff7 www.ff7citadel.com it should work it has latest patches how to play as sephiroth patch so take a look around and for ff 7 hmmmmmmm lemme c                                                                                                                                                                                                              Here's what I did:

1) Install FF8.
2) Download the FF8 Official Patch (http://www.gamespot.com/pc/rpg/finalfantasy8/index.html) and OVERWRITE the files.
3) Create a new folder called "Game" in your FF8 folder.
4) CUT & PASTE (do NOT drag & drop, it won't work) ff8.exe and binkw32.dll into the Game folder.
5) Run the game (no compatibility mode, no Administrator access, none of that crap is needed) and it SHOULD work okay.

If you get a "Please Insert Disc 1" error...

1) Look up the "FF8 1.2 No CD patch" and download it. (Note that there are 2 versions of this out... one for the NVidia FF8 Patch and one for the default FF8 patch, so get the right one!)
2) Extract the file "Crack12.exe" to your GAME folder (Not the FF8 folder like the readme says)
3) Copy the following files from your FF8 discs:
From Disc 1: "FIELD.FI", "FIELD.FL", "FIELD.FS", "DISC1.PAK", "DISK1"
From Disc 2: "DISC2.PAK", "DISK2"
From Disc 3: "DISC3.PAK", "DISK3"
From Disc 4: "DISC4.PAK", "DISK4"
4) Run Crack12.exe. This will patch FF8 to read the files from the "GAME" directory instead of the CD.
5) Run FF8.exe and it SHOULD let you play it fine.

Note that I've just started playing, but everything works fine so far... the only problem I can forsee is that "Eyes On Me" probably won't play because the CD Audio track can't be read. I don't think the game will crash because of that, though.

Lucleonhart

  • Fast newbie
  • *
  • Posts: 40
  • Karma: 0
    • View Profile
    • Lucleonhart.de
Re: FF8 Registry right after install (problem)
« Reply #3 on: 2007-12-20 08:51:38 »
Vista + FF8 + Configurator!

Hey there. I've done the above, and it works so far... BUT: the ff8 configurator doe not work, cause it want to start the ff8.exe from the main game directory.
I've changed the AppPath in the registry, but then the game does not work any more.

Any ideas?

Ossott

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: FF8 Registry right after install (problem)
« Reply #4 on: 2007-12-27 16:34:06 »
If you want to get it working, you can open a command prompt and do a mklink

ie: mklink C:\FF8\FF8.exe C:\FF8\GAME\FF8.EXE

That will create what i'll just call a better shortcut to your actual application. However, I've yet to get ff8 Configurator, or any other 3rd party app to start FF8 correctly (in Vista). Whether it's the ff8 loader, or the ff8 configurator, i end up with just a black screen. I'm thinkin it has something to do with their hooks or the way they start the game.

If your configurator was actually working before you followed the directions above, do let me know. I've tried everything I can think of :(

Ossott

  • Fast newbie
  • *
  • Posts: 18
  • Karma: 0
    • View Profile
Re: FF8 Registry right after install (problem)
« Reply #5 on: 2007-12-28 16:32:57 »
Completely wrong topic.. i'm an idiot, mod can delete this a-ok.

sodoff21

  • Guest
Re: FF8 Registry right after install (problem)
« Reply #6 on: 2008-01-13 12:25:48 »
I'm probably missing something really obvious here, but I can't seem to find that patch anywhere on Gamespot.

Plus, when searching for it on Google it only seems to be available for download through paid membership sites. Can anyone point me in the right direction?