Author Topic: Movie Tweaking  (Read 17546 times)

Agent009

  • Guest
Movie Tweaking
« on: 2007-07-27 01:44:45 »
Hi Everyone.

I'm new to this forum and have used it to get my Final Fantasy 7 game running better than I ever thought possible on my current machine. I've downloaded various mods that I am using and so since this forum has been so helpful to me, I've decided to give something back in return.

I've gone through many different topics on how to get the final fantasy 7 movies running better and it would seem no one has had any luck. Well, look no further, I have found a solution.

Here is a very simple step by step procedure that will increase the quality of the FMV sequences in game. (Please note that I cannot be 100% certain this will work for everyone.)

Step 1: Copy all movies to your hard drive (location is not important, however keep note of the path as it will be needed next.)

Step 2: Open up regedit (Start>Run>regedit) and search for "Final Fantasy VII" (without Quotes) keep pressing F3 if needed to find MoviePath which should have an entry of *drive letter*:\FF7\movies\   Right click on MoviePath and click "modify." Change this to the path that you placed your movies in. In my case it was C:\Program Files\Square Soft, Inc\Final Fantasy VII\data\movies\  (notice that I added an extra slash at the end. This is very important or else the movies will not play.)

These first steps might not be neccesary to get the desired result, and although I now this part is mentioned in another topic, I felt it is neccesary to add here as well just in case. Regardless, it does make the movies run better even on my machine which is pretty fast.

Step 3: Download ffdshow -link: http://sourceforge.net/project/showfiles.php?group_id=53761 or alternatively, you can download the K-Lite Codec Pack which includes ffdshow as well. -Link: http://www.free-codecs.com/download/K_Lite_Codec_Pack.htm

Step 4: Once you have FFDShow installed, you need to open the ffdshow Video Decoder. Under the very first option in the list, "Codecs" you need to right click on the right side where the various types of codecs are listed, and a popup will be displayed that has two options, 1: set all stable formats to libavcodec and 2: Set all supported formats to Xvid. Choose the first option.

Step 5: Then scroll down to the bottom, and disable Truemotion 1,2, ultimotion, Winnov V1, Snow, and AviSynth, if any of these are set to libavcodec the must be disabled.

Step 6: The last option in this list is Raw Video. This one has many choices, for me most don't seem to work at all for FF7, however, the all RGB option is the one we are looking for here, so select that, click apply and close ffdshow.


If you follow these instructions your movies will play without all the grainyness. There will still not be any FSAA unfortunately, so some areas will have pixel showing instead of being smooth, but that can't be avoided I don't think. What will improve is the apparent color depth of the movies and so when you look closely at any character's face with these options, they won't be all freckled or dotted. :D

Again, I cannot guarantee that this process will work for everyone. It worked for me I just hope you all have the same luck. The movies haven't looked better. :D

Good luck to you all. ;)

If anyone has any problems feel free to post here and I'll try to assist in any way possible. ;)
« Last Edit: 2007-07-27 04:31:31 by Agent009 »

Zack

  • Crazy poster
  • *
  • Posts: 223
  • Karma: 0
    • View Profile
Re: Movie Tweaking
« Reply #1 on: 2007-07-29 14:38:15 »
I don't currently have FF7 installed so I can't try it out. Has anyone else had some luck with this tweak?

ultima espio

  • No life
  • *
  • Posts: 1359
  • Karma: 20
    • View Profile
Re: Movie Tweaking
« Reply #2 on: 2007-07-29 15:04:58 »
Nah it looks the same for me, and made the movies play upside down in-game even with the upside down patch installed.

Agent009

  • Guest
Re: Movie Tweaking
« Reply #3 on: 2007-07-29 16:16:03 »
 :-o That makes no sense.  :?

All this procedure does is it make raw video play with RGB values, so since the movies are in 24-bit color, having this codec enabled allows videos to play in their original color format instead of 16-bit color which is what causes all the graineyness.

Try checking your fddshow settings for the effects and such you can set as well. There is an option there to flip the image, perhaps that was turned on. Although that particular option doesn't work for me. :S

This also works if you set the Raw Video option to RGB24 as that is the format of the FF7 FMV's.

If that isn't the problem at all, perhaps it's your PC specs or video card/drivers.

This is what I have:

Pentium IV 3.0Ghz
Nvidia GeForce 6600GT (Forceware 93.71 Drivers)
1.5 GB of RAM
Windows XP
Final Fantasy VII Platinum Collection.

If it isn't your PC specs, it might have something to do with the FF7 version you have, or maybe it's the mods.

These are the mods I am using.

High Res Patch (using 1280x960 version)
NPC reconstruction Patch
9999 Limit Breaking Patch
Advent Children Avatars

Obviously you aren't about to go make drastic changes to your PC just to get this to work, so instead I'll suggest trying the high res patch if you aren't and maybe that will work for you. I don't think the other mods would have any effect on the movies. ;)

EmperorSteele

  • Freak
  • *
  • Posts: 931
  • Karma: 1
    • View Profile
Re: Movie Tweaking
« Reply #4 on: 2007-08-02 17:55:14 »
yeah dude, your instructions don't work.  I'm stuck on this step:

Step 4: Once you have FFDShow installed, you need to open the ffdshow Video Decoder. Under the very first option in the list, "Codecs" you need to right click on the right side where the various types of codecs are listed, and a popup will be displayed that has two options, 1: set all stable formats to libavcodec and 2: Set all supported formats to Xvid. Choose the first option.

I can't right-click anywhere to get any options.

Then again, i don't even have a decoder: i just have a configuration menu

Which version EXACTLY did -you- download?  The Alpha?

Agent009

  • Guest
Re: Movie Tweaking
« Reply #5 on: 2007-08-02 19:30:18 »
Ok here's a screenshot that might help.



All you need to do is right click in the decoder column and it will display this pop up list as shown in the screenshot. ;)

As for the version. There is an "about" option at the bottom of the left list that shows info there. I suppose that's what you are referring to. It says at the top: ffdshow tryouts revision 1320 June 24 2007 17:02:06 (msvc 2003, x86, unicode)

I got this version with the K-Lite Codec Pack. However, I would be surprised if it is any different than the version you would get of just ffdshow alone.

I hope this is a little more clear.

EmperorSteele

  • Freak
  • *
  • Posts: 931
  • Karma: 1
    • View Profile
Re: Movie Tweaking
« Reply #6 on: 2007-08-02 19:38:41 »
Yeah, that looks nothing like the version I have.  I hate codec packs with a passion, but I want to try this trick... hmmm

Luckily,a  google search is my friend =)

hmm, doesn't work, in fact, now i don't get video. =(

What are your other settings?
« Last Edit: 2007-08-02 19:53:19 by EmperorSteele »

Agent009

  • Guest
Re: Movie Tweaking
« Reply #7 on: 2007-08-03 03:10:20 »
Hmmm... are any of the other settings being used in your ffdshow? It is possible the only change needed is the Raw video one and have that set to All RGB.

There are quite a few if enabled will make FF7 videoless, which will make you need to reboot your PC. :(

If you did do the "set all stable formats to libavcodec", then scroll down and make sure these following ones are not enabled as I have found some if not all will cause the videoless problem.

MPEG1
MPEG2
WMV1/7
WMV2/8
WMV3/9
WVC1
WMVP
MSS1/2
Trumotion 1,2
Unltimotion
Winnov V1
Snow
AviSynth

All these should be disabled as far as I know. Alternatively, you can try going back to the factory defaults and just enabling the All RGB option for Raw Video as it may be the only option that needs to be changed.

Make sure you don't have any of the other options used, lik,e sharpen or blur and NR, because some of them produce the videoless result as well.

Sorry for the long wait for a reply, but I went to sleep just after posting my last post, and just woke up.

I hope this helps. Good luck. ;)

 - Edit -
Ok I decided to do a quick test to see whether or not the All RGB option is really the only one that's needed or not, and with success I must add.

Here are a couple of pics I've taken to show the difference.

http://img123.imageshack.us/my.php?image=aerisoriginalgt6.jpg <---- The original with the Raw Video option disabled. You can plainly see a lot of graineyness in this pic.

http://img292.imageshack.us/my.php?image=aeriswithallrgboptioncw3.jpg <---- This one is with the Raw Video option set to All RGB. As you can see, no more graineyness.

These pics are in 1280x960 so you can click on them to make them fullscreen.

So, I suggest trying just this option alone as it works for me perfectly. I would be surprised if no one else can get it to work. I don't know if this has anything to do with the High Resolution Patch or not. So if you are not using it, and this doesn't work, then try applying the High Res patch of 1280x960 and it should work. ;)

Mod Edit: Do not double-post.
« Last Edit: 2007-08-03 12:38:00 by Alhexx »

EmperorSteele

  • Freak
  • *
  • Posts: 931
  • Karma: 1
    • View Profile
Re: Movie Tweaking
« Reply #8 on: 2007-08-03 04:46:23 »
hmm...

Well, i had to uninstall then reinstall, tehn just go by normal settings (with just the rbg mode applied) and, well, i dint notice TOO much of a visual difference (a tiny bit,..

BUT!!!

I noticed something very much mroe awesome.

The sound in the beginning video NEVER synched right for me before: Now it synchs perfectly!  I mean, it could be other things that i've done since the last time i viewed the vid, but still, nice improvement there!

I'm gonna play with this proggy, see if we can do something about the aliasing =)

Agent009

  • Guest
Re: Movie Tweaking
« Reply #9 on: 2007-08-03 05:09:46 »
Cool, I hope you are successful, as I've never been able to get FSAA working for FMV's for any of my games. I think it's because the FMV's are just video data and not actually 3d images that are being produced by the video card. I have FSAA working on all my other games, except the movies for this reason.

So, if you do get it to work somehow, I'd loved to know how. :D

EmperorSteele

  • Freak
  • *
  • Posts: 931
  • Karma: 1
    • View Profile
Re: Movie Tweaking
« Reply #10 on: 2007-08-03 22:24:36 »
Well, i realize i cant anti-alaise it, but maybe apply a blur or something... maybe the movies themselves can be edited *shrug*

TG_Sock

  • Guest
Re: Movie Tweaking
« Reply #11 on: 2007-08-04 14:23:18 »
This was an interesting and worthwile exercise, but sadly didnt work for me after following the guide (and additional notes) to a tee.
Please keep the updates coming though guys.
« Last Edit: 2007-08-04 15:31:34 by TG_Sock »

2Mourty

  • Guest
Re: Movie Tweaking
« Reply #12 on: 2007-08-07 01:18:17 »
I running ff7 on a vintage rig I built this summer.  The "video card" are 2 voodoo2's running in sli.  Thought that I would try your tips.  I do see a bit of a difference.  The movies don't seem as pixly, but they do seem a little more blurred, overall I think that there is a little improvement. 

Agent009

  • Guest
Re: Movie Tweaking
« Reply #13 on: 2007-08-20 12:42:55 »
Ok, I think I found the reason why some of you guys didn't get this to work.

Along with the other settings, this following setting might also be needed. Here's a screenshot to show what I mean.




Where it says uncompressed is probably what needs to be selected, as by pure chance, I discovered if I set it to Xvid, the in game movies will not run, so I get the game crashing at the Eidos Interactive Movie. With it set to Uncompressed, this might allow the movie to run without the graineyness as well. Although I haven't tested any other settings, I did originally have it set at uncompressed and only changed it to encode a new opening video in Xvid format which unfortuntely didn't work.

Suffice it to say, following that screenshot, set the encoder to uncompressed, and the colorspace to RGB24, and hopefully it should work. ;)

On another note: There is also another option in this encoder that might need to be set as well.

-Click on Input (It's the 5th one from the bottom. Shown in the screenshot)
-It will have 5 check boxes with the last one probably greyed out. Check the first one marked force input colorspace.
-That option has a dropdown menu. Select AllRGB from that list and then click apply.

If all was done correctly along with the other options in my first post. Then you're movies should run without all the graineyness.

So guys, let me know if this works for you because I am sure a lot of you are just dying to get this to work. If it doesn't, then I'll look into more of the settings to see if I can trace down exactly what else it is that helps make the movies clearer. :D
« Last Edit: 2007-08-20 12:49:41 by Agent009 »

rugbykid

  • Fast newbie
  • *
  • Posts: 30
  • Karma: 0
  • [URL=http://www.ff-fan.com][IMG]http://www.ff-fan.
    • View Profile
Re: Movie Tweaking
« Reply #14 on: 2007-09-01 07:14:57 »
I really like this! The best is that you can use your own vids! I use the ps3 ff7 intro instead of the old one!

miracle.flame

  • Crazy poster
  • *
  • Posts: 164
  • Karma: 0
  • ^_^
    • View Profile
Re: Movie Tweaking
« Reply #15 on: 2007-09-02 12:37:36 »
Well, Agent009 (what does the code 009 mean in the world of agents if I may ask?)

You seem to have no idea what are you tweaking and furthermore advise others to do so likewise, you know, most folks would like fine settings not only for FF7 videos but for overall use as well. Setting anything under encoding options should have absolutely no impact on playback unless an encoder is used as a direcshow filter which is very unlikely. Decoding options are used for playback but I see no sense in turning off ffdshow processing for video formats other than TrueMotion2 which is the one FF7 videos use.

I've compared the pictures you've posted and neither look okay to me. The "after" one has contrasting colors, you may see that on Aeris' shoulders..there are sharp steps in varying colors.

Making the videos look as good as possible was discussed a few times already. Mostly of all it involves reencodint the original videos with Indeo5. You may look into that in this older thread.

twipley

  • Cool newbie
  • *
  • Posts: 51
  • Karma: 0
    • View Profile
    • custom user page on wikipedia
Re: Movie Tweaking
« Reply #16 on: 2007-09-09 17:28:05 »
Just follow his t5hread.
The tech FAQ should also be updated to reflect teh
« Last Edit: 2007-09-11 00:30:29 by twipley »

Moi_Rama

  • Guest
Re: Movie Tweaking
« Reply #17 on: 2007-09-16 18:04:41 »
Hi, I'm a newcomer...
I also have a serious problem w/ my FF7 (XP), especially that I couldn't see any CG's at all

I've read all the description from Agent009, but damn, it didn't work. In fact, the problem occurred when I selected the "all RGB" or "RGB 24" for the "Raw Video". Well, every time I set to it, n then I tried to play the game or play the video, BANG!!! 

An error like this occurred:

"Media Player Classic has encountered a problem and needs to close.  We are sorry for the inconvenience."

Of course, when I selected "disabled" for the "Raw Video", there's no error notification; and still there's no CG... :cry:

Can you solve this problem, Sir...? :|

twipley

  • Cool newbie
  • *
  • Posts: 51
  • Karma: 0
    • View Profile
    • custom user page on wikipedia
Re: Movie Tweaking
« Reply #18 on: 2007-09-17 23:39:17 »
If you only have problems playing FF7 movies, use the TrueMotion DirectShow Filter (ask miracle.flame).

If you want to improve the quality of the movies, read miracle.flame's thread. that's it

Moi_Rama

  • Guest
Re: Movie Tweaking
« Reply #19 on: 2007-09-18 10:27:38 »
Yeah, first of all, thanx dude for reading my problem...Well, I'd downloaded the Duck Truemotion. But, how come every time I tried to install it, always ended before 100% (around 50% or sumthin', n then I got the error message...bla..bla..."send error report/don't send")? :? :-o


Well, I guess enough is enough. I'm sick playin' this game on the PC version. In fact, I've figured it out how to manage the Duck Truemotion problem, but still, my registry didn't recognize the file so I have to registered it manually....but damn, still not working :x

Hmmph, so I decided to play FF7 & FF8 using ePSXe n download the ISOs. Thanx anyway for all your guides :lol:

PS: I wish Qhimm could make the JENOVA (save editor) for the emulator version :wink: 
« Last Edit: 2007-09-22 07:53:48 by Moi_Rama »

aragonsr

  • Guest
Re: Movie Tweaking
« Reply #20 on: 2008-07-28 08:49:34 »
I just installed k-lite codec pack and all the settings that I set didn't modify anything and I couldn't figure out why.
To actually get the setting adjustments mentioned above to actually work, do the following:
1) On the left side click "DirectShow Control".
2) In the text box that says "Don't use ffdshow in", search for ff7.exe and remove it.
I'm not sure why they thought it was a good idea to put that in there.
Done.

Rufus95

  • Cool newbie
  • *
  • Posts: 97
  • Karma: -1
  • ....
    • View Profile
Re: Movie Tweaking
« Reply #21 on: 2008-11-02 19:29:34 »
thanks this realy made a difference

Movian

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Re: Movie Tweaking
« Reply #22 on: 2009-01-24 15:19:08 »
am hoping you guys can help....

i have so far tried a variety of things to try and get the vids working in FF7 (English Version) however i am at a loss.

I have a attempted all of the settings you guys have recommended + a variety of others to no avail. I have (through trial and error) found the high res patch does not work on my system and am not using it. I currently have the videos playing correctly in WMP with the settings stated here (with duck True motion, ffdshow (with settings stated) ) Yet the videos still refuse to play at all in the game. Are there any other settings or options i can try ? any other patches i can use to try and get these fecking videos to play!!!!

i am on Vista Home Premium and am willing to provide any screen shots/photos that you might need to try and help me fix this problem.

dziugo

  • No life
  • *
  • Posts: 1474
  • Karma: 4
    • View Profile
    • A new copy of FF7 thanks to Salk. Pack (zip/rar/etc) your saved game before sending it to me.
Re: Movie Tweaking
« Reply #23 on: 2009-01-24 16:56:33 »
Did you, by any chance, try to use the "videos to the HDD" trick?

Movian

  • Fast newbie
  • *
  • Posts: 7
  • Karma: 0
    • View Profile
Re: Movie Tweaking
« Reply #24 on: 2009-01-24 22:02:31 »
yes i did, although it also does not work from the cd's