Author Topic: FF8 Wrong Disc Error - RegEdit Troubles  (Read 18895 times)

SilentDreams769

  • Guest
FF8 Wrong Disc Error - RegEdit Troubles
« on: 2009-06-14 10:56:27 »
Hi everyone, I'm a new member to the forums, but a long time fan of everyones work on FFVII and VIII. I think you all have done a great job. I have a small problem though.

I own the legit copies of FFVII and FFVIII for PC and have installed and played both of them on my old Windows XP laptop with no problems (I actually used a lot of your tweaks for FFVII). Both worked flawlessly and everything was dandy.

However, I just recently purchased a new laptop with Vista Home 64 and decided to install these two classic games on my new laptop and FFVII installs and works with no problems, however, FFVIII installs fine but when I try to start a new game I get the message "Wrong Disc!" When I hit x, it still says Error! Wrong Disc!

Now... Before I get flammed, I have read and searched and looked and pondered almost every topic I could find on the internet about this and there have been a few solutions but the one I keep seeing is the RegEdit trick where you just switch the drive letter in RegEdit.

This is a problem for me because my regedit only goes to here: HKEY_LOCAL_MACHINE\SOFTWARE\Square Soft, Inc\FINAL FANTASY VIII

Whereas everyone else says it's supposed to be: HKEY_LOCAL_MACHINE\SOFTWARE\Square Soft, Inc\FINAL FANTASY VIII\1.00

I have updated the 1.2 patch, I have run in Administrator mode, I have uninstalled and reinstalled but to no avail, my regedit only shows FFVIII but with no subkey of 1.00. I'm wondering why this is and what the problem may be. As I said, I have not had this problem with my laptop running XP but I can't seem to find out what's wrong with Vista.

Since there is no 1.00 subkey, I can't change the DataDrive to my DVD-Rom drive where my CD is. I've tried adding my own registry but it didn't work and I didn't want to screw up my new laptop too much. So I was wondering if someone could help me out with a solution or knows of a reason why I have no 1.00 folder in my regedit. Or how I could fix this wrong disc issue.
Thanks.

zerotheblackmage

  • Guest
Re: FF8 Wrong Disc Error - RegEdit Troubles
« Reply #1 on: 2009-07-03 14:01:05 »
For the first time ever, I can be useful in a forum (even though you've probably given up, there will be undoubtedly someone else with the same problem who will stumble across this)

I had a similar problem, where not even the Square Soft Inc. part was not in my HKEY_LOCAL_MACHINE/SOFTWARE. However Regedit has a search option. I searched for "Square Soft Inc" and It lead to a completely separate section of the registry
(wasting time at work right now... I'd be more precise, but that will have to wait for when I get access to my lappy at home).
However, this registry entry had the drive subkey, and when I changed it, the game ran like a charm.

Hopefully this helps people get on the right track

Hellbringer616

  • No life
  • *
  • Posts: 1915
  • Karma: 12
    • View Profile
Re: FF8 Wrong Disc Error - RegEdit Troubles
« Reply #2 on: 2009-07-03 16:30:00 »
Instead of HKEY_LOCAL_MACHINE\SOFTWARE\Square Soft, Inc\FINAL FANTASY VIII\1.00 like it says. Look in
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Square Soft, Inc\FINAL FANTASY VIII\1.00

EDIT: for future notice. Anything that is Vista/Seven 64bit (x64) after SOFTWARE add Wow6432Node between it and whatever else is there (in this case Square Soft, Inc)
« Last Edit: 2009-07-03 17:18:50 by hellbringer616 »