Final Fantasy 9 > FF9 Tools

[PSX/PC] General editor - Hades Workshop (0.43)

<< < (378/379) > >>

rassellek:
Thank you again! I thought about it, tried it, and everything worked.

My code:
StartThread: Condition=CasterWeaponId == 8 ; LoopCount=1 ; Chain ; Sync
   Wait: Time=1
   WaitSFXLoaded: SFX=Player_Attack_Zidane_Sword
   PlaySFX: SFX=Player_Attack_Zidane_Sword
   EffectPoint: Char=AllTargets ; Type=Effect
   PlaySound: Sound=WeaponAttack
   StartThread: Condition=!IsAttackMiss
      PlaySound: Sound=WeaponHit
   EndThread
   StartThread
      Wait: Time=4
      EffectPoint: Char=Everyone ; Type=Figure
      WaitSFXDone: SFX=Player_Attack_Zidane_Sword
   EndThread
   PlayAnimation: Char=Caster ; Anim=MP_ATTACK
    WaitAnimation: Char=Caster
EndThread

ChikoLad:
Hey, I've been doing a little messing around with the Playable Character Pack (Fratley, Lani, and Kuja) and wanted to do a playthrough with it. However I also want Freya in my party at all times as well.

A while ago, I did actually make a mod that forced a solo Freya into every party call and also into every battle as a fail safe. I used this to do a true solo run with Freya before. The way it worked was essentially just using an AddParty call for Freya and RemoveParty for every other character from the vanilla game (including the guest characters), and this would run whenever there was a party call in a Field Script, as well as at the beginning of every enemy script.

I assumed using this mod in combination with Playable Character Pack would allow me to essentially force Freya into the party at all times, but then the Playable Character Pack party members wouldn't be removed since they would have to have unique character IDs that weren't accounted for when I made the Freya solo mod, so they should be there with her and wouldn't be removed.

Problem is if I use Alt + F2 to bring up the party menu and put the Playable Character Pack party members into the party, they will appear in battle, but instead, Freya gets removed from the party for some reason. My Freya solo mod still works as intended if I don't put any of the Playable Character Pack party members into the party, or if I put only one of the Playable Character Pack party members in (Freya will be inserted into the party at the start of the battle as intended, but the other character will be there with her, which is what I would expect to happen). It's only if all three of the custom characters are there, then Freya gets removed. The mod priority order didn't seem to matter either.

Just curious as to why that would be? Moreover, is there a Discord or something where there is more FFIX modding discussion? I feel like there have been a lot of awesome advances in FFIX modding lately but I don't know where I can discuss it, I'd love to get a better understanding on how these recent mods are being achieved so I can make my own mods that work well in tandem with them.

Tirlititi:
There has been several reports yesterday of weird things like that happening. That is very strange.
Normally, the Character Pack shouldn't mess at all with the way you did your Freya Solo mod: there is no "AddParty" or "RemoveParty" in any script that points to the added characters.

The problem is, I fail to reproduce any of these weird bugs and thus I struggle to find out what could be the cause.

Someone said that the bug triggered only if the "[Import]" section of the Memoria.ini is enabled. Indeed, that feature preceeds mod folders, it uses different formats for many files, it messes a lot with other things and I never really cared maintaining it or looking at how it worked. However, even enabling it, I fail to reproduce your bug (Freya is in the party if I use her + the 3 new characters, and I don't see why your mod would make any difference regarding that).

I don't understand though "[It worked by running a script] at the beginning of every enemy script". Do you use "AddParty" in enemy scripts? Maybe that's not the cause of the problem (or maybe it is), but it would be an incorrect behaviour. I don't advise messing with the party members in-battle. Besides, if you've spotted all the places where the party members are changed (including before scripted fights) and added your "AddParty(4)" script there, you shouldn't need to add anything in battles.

You can reach me on Qhimm's discord.

Seramera:
Hello Tirlititi,
i am now working on generalising the fieldscripts to have a raw engine to work with. (delete the story)
therefore extract vars like camerabounds, regiondata, fieldexits, tileanimations, soundcodes, treasures etc and parse them generalised. 

1. priority goal is to implement a new roguelike gamemode.
2. more far away goal is to get an editor going, with which you can insert objects and behaviour into fieldscripts handily.

i target steam only.

now the extraction and editing is going forward (im using python), and i will use commandshell to import the fieldscripts all at once.
the problem is, that the import function from HadesWorkShop doesnt implement deleting and creating entries and functions. I looked into HWS SourceCode
and i'm a bit blown away by all the c++-libraries i dont know. I wanted to write an import function that adjusts the entries and functions of the field to the fieldscript read.

I will have to look into your tools source code later a lot more, but i thought i might as well ask you now for help.

Thank you

Tirlititi:
Hello,
Good luck, that's an exciting project :D

I thought that you could add/remove entries and functions with the "Batch -> Import" (or "import script" in the commandshell version). Maybe I misremember and I didn't make it possible, but it shouldn't be too hard to add it then if you edit HW's source code or use it for your own project.
What is the error that you get if you try to add eg. a function that doesn't exist yet?

I'm glad that the commandshell is useful to someone ^^'

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version