Final Fantasy 7 > Troubleshooting

Installation and Game application on windows 10


Bob Strife:
Hey everyone,

Another question regarding the issue with running Final Fantasy 7 on windows 10.
So i have the original 1998 discs and tried to install them on my win 10 pc.
I use an external usb hard drive to read the discs.
It accepts the discs - reads them and i can access the first window where i can press: install game, direct x, etc.
If i try to install the game - my screen fades for a second to black and closes the exe.
Installing direct x and the other additions is possible.

So i tried a workaround and installed the game via Tom’s Installer. But the game exe has the same issue - the screen becomes dark for a secone and the app closes. Doesn’t matter if i run it as admin or regular.
I tried all possible config settings, but nothing seems to work.
Regarding the config setting - there is the „fail“ notice on the 8 bit option - everything else has a pass. Couldn‘t find a fix for that.

Also my driver might be to advanced, but nvidia doesn‘t provide any support vor the riva 128 - so i dunno how to update it otherwise.
Also i wanted the vanilla experience and get the thing to work without aalis launcher or something. So that i could play regular with my old discs.

Has someone encountered similar or even the same issues?
Happy about any sugguestion and tipps :)
Please let me know if and when, which information do you guys need regarding my pc to fully get the picture.

Kind regards


Bob Strife:
Hey I literally tried everything for days and hours and after nothing helped and I was about to give up ... I checked the simplest solution ever ... Task Manager...

Thanks to this comment: I checked that something was simply blocking my exe from executing ...

Well everything works fine now - thanks guys :D

Topic can be closed :)


[0] Message Index

Go to full version