Final Fantasy 7 > Troubleshooting

7th Heaven 2.3 not working


Hi there.

All of my mods work fine in 7th Heaven 2.2 without issue, but whenever I try to update to either the canary builds or the stable build of 2.3, the game refuses to launch. While I could just continue to keep using 2.2, what I really wanted to try was using SYW's 30 FPS cutscenes, which requires a newer version to be installed. I've tried doing a completely fresh install of FF7, disabling all mods except just the latest version of SYW IROs (which I presume should support 2.3 seeing as that's what it's specifically designed for), doing the 640x480 compatibility trick as suggested by Chrysalis in other threads, aaaaaaannd nothing works.

It's strange because I'm using pretty much the exact same installation process as I do for 2.2, while downloading the latest FFNx update from the General Settings menu in 7H. There should be no reason theoretically that it doesn't work. This is a Windows 10 64-bit build, Core i7-6700K, 16 GB RAM, GTX 1070, 1998 disc-based install of FF7.

Anyone have ideas? Was the 7thWorkshop folder restructured in any way since moving to 2.3 that might cause issues copying old profiles over to it?


I personally managed to migrate my 7thworkshop folder over but it isnt supported practice, so if you do have problems set it up again from scratch.

If the game fails to load you can click on the bottom border of 7th heaven and it should popup the log inside notepad, you can attach that log here and hopefully someone can figure out whats going on.

Hi, sorry it took so long to get back on this. I continued on version 2.2 for a while so that I could keep working on my own mod project, but recently decided to try version 2.5 today and still having the same issue. Gives a code 5 error it seems. Tried the 640x480 compatibility fix, still a no-go. Any guidance would be appreciated.

Logs are attached.

EDIT: After some more experimentation, I've found that the only way I can get it to launch is if I literally disable all mods, which of course defeats the purpose of using 7H. I downloaded the latest SYW V5 updates and tried just enabling those and nothing else, but still no launch. It's very strange. I'm sure there's probably just one settings or compatibility tweak that might be able to get it to run, but I'm at a loss as to what that is.

If you're getting a code 5 error, have you tried the code 5 fix in launcher settings?


[0] Message Index

Go to full version