Author Topic: Having semi-random crashes while running 7th Heaven when entering a new room.g  (Read 1893 times)

DrDastardly

  • *
  • Posts: 13
    • View Profile
The problem is, unfortunately, that the crashes happen completely at random.  Well, not completely, it's always when loading a new screen, but it can be in the world map, after/before a fight, or just walking from one room to the other.  Of course, however, it does not always happen, and a place where it crashed once can work the next time.  I have a pretty big list of mods, and since the problem is difficult to replicate, I've been having a hard time narrowing down which mod it is/what's contradicting what.

Here's a Google Drive of APP.log and crash.cmp: https://drive.google.com/open?id=1DUNGzGmPCqs3SVxng3kfCM7SCyKIV9qR

darxide

  • *
  • Posts: 21
    • View Profile
Wait for 7H 2.1 to come out.

OatBran

  • *
  • Posts: 52
  • moop all day skeent all night
    • View Profile
    • Discord
you could wait weeks/months for 7H 2.2 to come out, or you could install FFNx and it will fix the random crashes. read my faq here if you want a walkthrough on how to install it

http://forums.qhimm.com/index.php?topic=19932.0

DrDastardly

  • *
  • Posts: 13
    • View Profile
So, firstly, should I download FFNx-Steam-v1.06 or FFNx-FF7_1998-v1.06?  I'm running FF7 on Steam, so I'm confused by the names.

DrDastardly

  • *
  • Posts: 13
    • View Profile
I got this error when trying to run 7th Heaven after extracting the files:

### Launching Final Fantasy VII ###
Checking FF7 is not running ...
Checking FF7 .exe exists at E:\Games\Game Files\steamapps\common\FINAL FANTASY VII\FF7.exe ...
Verifying installed game is compatible ...
Verifying game is not installed in a System/Protected folder ...
Verifying game is full/max install ...
Creating missing required directories ...
Verifying additional files for 'battle' & 'kernel' folders exist ...
Verifying all movie files exist ...
Verifying music files exist ...
Verifying latest game driver is installed ...
Unknown error when launching the game: Value cannot be null.
Parameter name: input

EDIT: NVM you mention it in the readme.

DrDastardly

  • *
  • Posts: 13
    • View Profile
Okay, so FFNx is installed.  Hopefully that fixes my issue.  Thanks!

DrDastardly

  • *
  • Posts: 13
    • View Profile
So I know this was from a few days ago, but I'm still having crashes, but in a different way.  It's no longer when I load a new screen.  Now, the screen will load, but my character will be the only thing on a black screen, aside from some "blocks" of the background.