Author Topic: Aali's driver [v 0.7.7] Help/Bugs/Suggestions  (Read 89251 times)

AngeBleu

  • *
  • Posts: 68
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #75 on: 2010-04-25 21:11:52 »
how to correct all Glitch that we can see in APP.LOG ? It says that some files are broken  ???

Zen

  • *
  • Posts: 403
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #76 on: 2010-04-25 23:50:33 »
Hey Aali, just want to report something that's been bothering me since release 0.76b. The fmvs in FF7 now have a thin vertical gray line on the right side. They don't have this line when I use 7.5b, did you start applying filtering to the videos or something?

Also, I suggest you to not get rid of the black bar in the new battle interface. That bar hides some ugly stuff that you weren't supposed to be seeing (try summoning Odin to see what I'm talking about).


« Last Edit: 2010-04-26 02:20:30 by Terid__K »

willis936

  • *
  • Posts: 370
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #77 on: 2010-04-26 12:26:34 »
I got everything running on my new laptop perfectly.  A few strange things:  the volume in the cfg for ff7music had to be turned down from 125 to 50 to match the sound effects (an issue I've never had before), there's now a gray line to the right of the videos, and there are artifacts over the damage numbers in battle (and during some animations, summons were mentioned above).  I'm using .7.7b and haven't tried rolling back.
« Last Edit: 2010-04-26 22:08:43 by willis936 »

therage800

  • *
  • Posts: 172
    • View Profile
    • TheRage800
Re: Custom graphics driver for FF7/FF8
« Reply #78 on: 2010-04-27 06:43:42 »
I'm also getting the gray line during FMVs. :-\

Colonel Ramsay

  • *
  • Posts: 114
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #79 on: 2010-04-27 06:49:54 »
Some of these problems are not being directly caused by the driver and so there should be a bug report page, and not this one being swamped.

Timber

  • *
  • Posts: 386
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #80 on: 2010-04-27 13:25:40 »
Also, I suggest you to not get rid of the black bar in the new battle interface. That bar hides some ugly stuff that you weren't supposed to be seeing (try summoning Odin to see what I'm talking about).

That's a bit drastic isn't it? Actually I'm surprised at how well the new battle interface holds up, considering how much more of the screen shows.
I'm sure if we ask Aali nicely he would probably be able to fix some of these errors.
Also it isn't just the black bar that shows problems.

For example:


You can see that the Ultima 'white glow' effect cuts off at Tifas name.
Perhaps Aali could make the texture go full screen instead.

therage800

  • *
  • Posts: 172
    • View Profile
    • TheRage800
Re: Custom graphics driver for FF7/FF8
« Reply #81 on: 2010-04-27 18:01:34 »
Whenever wind.wav is played after about 30 seconds the game freezes. I have confirmed that it happens with 0.7.7b but not 0.7.5b, I have not tested 0.7.6b

Quote from: app.log
INFO: FF7/FF8 OpenGL driver version 0.7.7b
INFO: Auto-detected version: FF7 1.02 US English
ERROR: failed to set fullscreen mode
INFO: ATI Technologies Inc. ATI Radeon HD 4800 Series  2.1.8787
INFO: OpenGL 2.0 support detected
INFO: Found swap_control extension
INFO: Original resolution 640x480, window size 640x480, output resolution 640x480, internal resolution 640x480
INFO: Fragment shader(s) linked, vertex shader(s) linked.
 
INFO: FFMpeg movie player plugin loaded
INFO: FFMpeg version SVN-r21874, Copyright (c) 2000-2010 Fabrice Bellard, et al.
INFO: FF7Music helper plugin loaded
LOCK UNLOCK TEST
MATRIX INITIALIZE
INITIALIZE DD/D3D END
initializing sound...
creating dsound primary buffer
reading audio file
loading static sounds
sound initialized
set music volume: 127
set music volume: 127
Entering MAIN
Exiting MAIN
START OF CREDITS!!!
INFO: C:\FFVIIMovies\eidoslogo.avi; rawvideo/null 364x353, 15.000000 FPS, duration: 0.066667, frames: 1
INFO: C:\FFVIIMovies\sqlogo.avi; mpeg4/mp3 640x480, 15.000000 FPS, duration: 247.466667, frames: 3712
INFO: Fragment shader(s) linked, vertex shader(s) linked.
 
set music volume trans: 127->0, step=60
END OF CREDITS!!!
Entering MAIN
set music volume: 127
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
ERROR: could not read from file C:\Program Files (x86)\Square Soft, Inc.\Final Fantasy VII\Data\music\wind.wav
song is already playing...
Entering MAIN
Exiting MAIN
START OF MENU SYSTEM!!!
END OF MENU SYSTEM!!!
Entering MAIN
Exiting MAIN
Field Start
ERROR: could not read from file C:\Program Files (x86)\Square Soft, Inc.\Final Fantasy VII\Data\music\wind.wav
ERROR: could not read from file C:\Program Files (x86)\Square Soft, Inc.\Final Fantasy VII\Data\music\wind.wav
ERROR: could not read from file C:\Program Files (x86)\Square Soft, Inc.\Final Fantasy VII\Data\music\wind.wav
ERROR: could not read from file C:\Program Files (x86)\Square Soft, Inc.\Final Fantasy VII\Data\music\wind.wav
ERROR: could not read from file C:\Program Files (x86)\Square Soft, Inc.\Final Fantasy VII\Data\music\wind.wav  This repeats about 800,000 more times
WM_CLOSE
Field Quit
UNINITIALIZE DD
END UNINITIALIZE DD
« Last Edit: 2010-04-27 18:08:40 by therage800 »

dziugas

  • Guest
Re: Custom graphics driver for FF7/FF8
« Reply #82 on: 2010-04-27 18:13:38 »
Bug Report

Me and Kranmer have discovered a bug in the game just before the battle with Dyne, there are numerous errors about not being able to open Wind.wav and then shortly afterwards a few dialogues before the battle, the game simply freezes up and crashes.

Corel Desert Save here (slot 4 I think):

https://docs.google.com/leaf?id=0B1JH_wU1qqN4ZjMwZWQ0ODctYzZlMy00NjIzLTk0YWEtOGI3MzJkZjhlMTYw&hl=en

0.7.3 seems to play the scene properly.



i recently started playing ff7, and got only this graphical mod. here are the bugs i found:

1. this has already been mentioned, but i needed to duplicate my save files (i figured this out all by myself 8))
2. at a few scenes i get an onscreen error message, that the game couldnt READ wind.wav file. the scene, where barret meets his friend crashes, depending on how fast you kill the game, app.log file might become over 100mb size. removing the file wind.wav file didnt help (app.log stated, that it could open the file wind.wav). the only way to get past that scene was to use original ff7config.exe file. (i figured that all by myself too 8)).
3 later i got few similar errors with sound.dat(i guess) file, scenes where you get bronco plane and in the ancient ruins where cloud is talking to sephiroth crash because of this error.

actually, bug 2 and 3 behave identically, only diffirent sound files are involved there.

no more bugs found, since i still havent got past ancient temple, or ruins(whatever)

i hope this is readable, understandable and helps you in some way


EDIT: the scene, where you have to pick up the black materia crashes because of wind.wav file. (app.log size - 42 megs, full of "ERROR: could not read from file F:\Program Files (x86)\Square Soft, Inc.\Final Fantasy VII\Data\music\wind.wav" lines)

need to fight that boss monster yet again... :)
« Last Edit: 2010-04-27 19:54:44 by dziugas »

myst6re

  • *
  • Posts: 617
  • Light King of the Savegame - Field Master - FF8.fr
    • View Profile
    • FF8.fr
Re: Custom graphics driver for FF7/FF8
« Reply #83 on: 2010-04-27 20:05:45 »
Quote
2. at a few scenes i get an onscreen error message, that the game couldnt READ wind.wav file. the scene, where barret meets his friend crashes, depending on how fast you kill the game, app.log file might become over 100mb size. removing the file wind.wav file didnt help (app.log stated, that it could open the file wind.wav). the only way to get past that scene was to use original ff7config.exe file. (i figured that all by myself too 8)).

This is a problem with the ff7config? I thought it was a bug in the game
« Last Edit: 2010-04-27 20:07:24 by myst6re »

therage800

  • *
  • Posts: 172
    • View Profile
    • TheRage800
Re: Custom graphics driver for FF7/FF8
« Reply #84 on: 2010-04-27 20:31:26 »
I think he meant that he disabled Aali's driver by using the original config file.

Zen

  • *
  • Posts: 403
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #85 on: 2010-04-27 20:39:48 »
Aali is already aware of the wind.wav loading error. He said it's because of the improved direct mode feature. He also said it should be fixed next version, so patience  :-)



dziugas

  • Guest
Re: Custom graphics driver for FF7/FF8
« Reply #86 on: 2010-04-27 21:05:46 »
I think he meant that he disabled Aali's driver by using the original config file.


exactly


Aali is already aware of the wind.wav loading error. He said it's because of the improved direct mode feature. He also said it should be fixed next version, so patience  :-)


but there are similar problems with other files too

indrema

  • *
  • Posts: 67
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #87 on: 2010-04-27 22:49:30 »
Why the linear_filter don't work on in-game 2D field?
I've notice that work very well on start 2D background, but when play the effect is apply only on 3D models.
Is possible fix it?

titeguy3

  • *
  • Posts: 1283
  • A jack of all trades
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #88 on: 2010-04-28 01:43:32 »
@Timber That *may* be fixable by editing the texture itself...not sure though.

refoopseman

  • *
  • Posts: 21
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #89 on: 2010-04-29 06:23:12 »
Models using the wrong vertex type are handled a bit differently, instead of complaining once when the first such model is drawn the driver will instead produce a glitch message whenever such a .p file is loaded, also printing the name of the file in question. I'm aware of the fact that this is really annoying to some people but hopefully some of these models will actually be fixed now.

Can you instead turn this into an option whether you can choose to turn on and off? Thank you very much  ;)

Millenia

  • *
  • Posts: 244
  • wireframe
    • View Profile
    • My portfolio
Re: Custom graphics driver for FF7/FF8
« Reply #90 on: 2010-04-29 17:01:21 »
Yeah I'm getting the broken model error with mine, it's fucking annoying when you have no idea wtf you're supposed to do about it >_>

obesebear

  • Administrator
  • *
  • Posts: 1383
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #91 on: 2010-04-29 17:11:04 »
Same here as with Refoopseman and Millenia.  I've got a model in game that tells me it has a bad vertex.  So I reopen it in 3DSMax and set the weld level ridiculously high.  Yet still I get the error.   If I set it even higher the model becomes EXTREMELY distorted. 

It's a nice option to have, but if we don't know what's wrong or can't fix it, it becomes an inconvenience.

Halp

  • *
  • Posts: 12
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #92 on: 2010-04-29 17:39:09 »

Quote
2. at a few scenes i get an onscreen error message, that the game couldnt READ wind.wav file. the scene, where barret meets his friend crashes, depending on how fast you kill the game, app.log file might become over 100mb size. removing the file wind.wav file didnt help (app.log stated, that it could open the file wind.wav). the only way to get past that scene was to use original ff7config.exe file. (i figured that all by myself too 8)).

having the same problem, but when I replaced the ff7config.exe file with the official patch ff7config.exe, it still froze. Or did you use the one that came with installation of the game / not the official patch ff7config.exe?

therage800

  • *
  • Posts: 172
    • View Profile
    • TheRage800
Re: Custom graphics driver for FF7/FF8
« Reply #93 on: 2010-04-30 03:34:04 »
Use the one that came with the game. But remember that this will disable Aali's driver so run his config file after you get past the problem area.

Aali

  • *
  • Posts: 1196
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #94 on: 2010-04-30 15:20:07 »
Millenia, obesebear:
Complain to the author of whichever program created the .p file. If they don't know what to do to fix it they can contact me.
If you just want to fix the file, open it in a hex editor and change 4 bytes at offset 8 from 00 00 00 00 to 01 00 00 00.

Halp

  • *
  • Posts: 12
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #95 on: 2010-04-30 17:31:00 »
Use the one that came with the game. But remember that this will disable Aali's driver so run his config file after you get past the problem area.

Just tried it three times with that one. If I don't set or replace anything, it's set as Unknown Renderer on the original config after I replace the aali's driver config with the original ff7 config. It runs fine then at the Dyne (I think that's his name) scene, it doesn't say Cannot Read Wind.wav or something but still crashes at the same exact part. On another try, it started saying the "cannot read wind.wav" again. When set to Software Renderer, I can't even zone. It crashes at the change of screen. Any ideas?

willis936

  • *
  • Posts: 370
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #96 on: 2010-04-30 17:45:01 »
Is there anyway to customize the input.cfg?  I'd like to modify the controls a smidgen because some buttons act as two (like menu and switch on the right shift key).

titeguy3

  • *
  • Posts: 1283
  • A jack of all trades
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #97 on: 2010-04-30 17:51:36 »
Is there anyway to customize the input.cfg?  I'd like to modify the controls a smidgen because some buttons act as two (like menu and switch on the right shift key).

Err um, uh..can't you configure the controls in game?
That should update input.cfg.

You can also open it in notepad.

Halp

  • *
  • Posts: 12
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #98 on: 2010-04-30 18:09:38 »
Use the one that came with the game. But remember that this will disable Aali's driver so run his config file after you get past the problem area.

Just tried it three times with that one. If I don't set or replace anything, it's set as Unknown Renderer on the original config after I replace the aali's driver config with the original ff7 config. It runs fine then at the Dyne (I think that's his name) scene, it doesn't say Cannot Read Wind.wav or something but still crashes at the same exact part. On another try, it started saying the "cannot read wind.wav" again. When set to Software Renderer, I can't even zone. It crashes at the change of screen. Any ideas?

Fixed it :)
Installed another FF7 as Square Soft Inc2 (in program files) and Final Fantasy VII2 (in start menu) and moved a copy of my save games into it. Got past the area, got the buggy outside, saved, copied the new "saves" (the save games) folder, replaced the "saves" (the save games) folder to the real/first/one-with-aali's-custom-driver Square Soft Inc/Final Fantasy VII and uninstalled Square Soft Inc2.
« Last Edit: 2010-04-30 18:12:00 by Halp »

willis936

  • *
  • Posts: 370
    • View Profile
Re: Custom graphics driver for FF7/FF8
« Reply #99 on: 2010-04-30 18:17:32 »
There's no option for that I don't think I'll check in a second but the input.cfg file looks like this
Code: [Select]
Ç   Ã   Ã‰   Ã‘   6      9   Â   Ã“           Ã’   Ãˆ   Ã   Ã   Ã‹      Ãˆ   Ã   Ã‹   Ã      ÃŸ   Ã«   Ã­   Ã±   Ã²   Ã¯   Ã°   Ã®   Ã­   Ã¬   Ã«   Ã³           Ã´   Ã£   Ã¦   Ã¤   Ã¥   Ã¬   Ã£   Ã¤   Ã¥   Ã¦       Ã