Author Topic: 7th Heaven Mod Loader Insanity  (Read 1718 times)

Dynamartist

  • *
  • Posts: 1
    • View Profile
7th Heaven Mod Loader Insanity
« on: 2024-03-26 07:58:12 »
The 7th Heaven Mod Loader is permanently broken for me. I've looked on every forum post for a solution to these errors but none of them work. I've documented the full timeline of events:

- Started playing modded FF7 yesterday.
- Followed up to date 7th Heaven install guides, didn't mess with settings or toggled on/off the mods I downloaded. (All the mods being the well known upscaling, widescreen, FPS, FMV and ninostyle model mods that are compatible with each other)
- Reached Junon, saved the game and quit for the night.
- Woke up this morning and the application just refused to run at all.
- Checked the FAQ and tried one of the solutions which was to delete the workshop folder, it started running but now there were errors when clicking play.
- "Unknown error when launching the game: Object reference not set to an instance of an object."
- The workshop folder was back but the loader couldn't find FFNx.toml despite it being in the game driver folder and working completely fine for 10 hours before.
- Checked the paths to see if there was a mistake and they were exactly the same as before.
- Used the uninstaller and reinstalled the mod loader, now there was an error message on startup.
- "Something went wrong while parsing "C:\Games\Final Fantasy VII\FFNx.toml". and "The document has errors: (1,1) : error : Unexpected token {\u0;} found" underneath.
- Scroll down the error message, it repeated "error : Unexpected token {\u0;} found" 130,000 more times???
- Thoroughly deleted everything I could find related to the steam install and mod loader.
- Reinstalled everything, nothing changed and I've even got a new error that forces the configuration of the application window to default settings.

I was really impressed by this mod loader at first but now I'm not so sure. Dunno why it would just crumble apart after 10 hours of working seamlessly because a laptop booted up in the morning. I feel like the only solution at this point would be to wipe my whole computer lol.

carchan

  • *
  • Posts: 1
    • View Profile
Re: 7th Heaven Mod Loader Insanity
« Reply #1 on: 2024-04-10 04:08:38 »
I found this post because I was having the exact same issue.  I found that, somehow, FFNx.toml had been overwritten and was completely blank.  I was able to resolve this by opening FFNx.toml in Notepad, copying and pasting the text of FFNx.toml from github (https://github.com/julianxhokaxhiu/FFNx/blob/master/misc/FFNx.toml), and re-saving it.  Next time I ran 7th Heaven it worked without any issues.  Hope this is helpful to you or the next person who has this issue!