Miscellaneous Forums > Troubleshooting

The 'Circle' button will not work in one case


I've searched for another thread on this but can't find one.

I am playing FF7 Steam version through 7th heaven, using the Remako and New Threat mods, on a ps4 controller. All working perfectly, until I get to the part where I am climbing out from the slums up onto the plate. Halfway up, the game tells me to hit the 'Circle' button to jump onto the swinging pole. When I hit 'Circle' - nothing happens, and no other buttons will make Cloud jump.

I've also tried playing with a keyboard just to get past this bit but the game won't recognise my keyboard.

I've also tried going into the in game configs to switch around the buttons, but I end up making a mess of all the controls because it doesn't recognise most of the buttons.

I really want to keep playing  :-[ Help appreciated!

Sega Chief:
I checked into the field script. The code for the swinging bar is the same as default, but I noticed something unusual with the way it's been set up.

--- Code: ---Label 1
If key [CAMERA|L2] or [TARGET|R2] or [PAGE UP|L1] or [PAGE DOWN|R1] or [MENU|TRIANGLE] or [OK|CIRCLE] or [CANCEL|CROSS] or [SWITCH|SQUARE] or [ASSIST|SELECT] or [???] or [???] or [START] or [UP] or [RIGHT] or [DOWN] or [LEFT] pressed once (else go to label 4)
If key [OK|CIRCLE] or [???] pressed once (else go to label 2)
Var[5][29] = 0 (8-bit)
Go to label 3
Label 2
Var[5][29] = 1 (8-bit)
Label 3
Go to label 5
Label 4
Go to label 1

--- End code ---

Before the listener for the OK/Circle button, it has another listener that's checking for all the buttons; if any of them except for OK/Confirm are detected then it cancels the script and you're unable to jump onto the swinging bar. It's a bit like allowing the player to move away from the jump zone in order to cancel it, but they've included every single button instead of just the directional buttons.

So when I press, say, L2 or Start before jumping then I'm no longer able to jump and have to re-trigger the jump event again. If this is happening to you when all you're pressing is Confirm (not moving the character at all, just pressing Confirm to close the text window then Confirm again to jump with no other inputs), then it means that your controller may be continually registering input on one of the buttons. Could be something you wouldn't otherwise notice, like a shoulder button.

It's probably worth trying a keyboard for that part just to advance, as controllers tend to be finicky with this game.

Edit: Noticed you said keyboard doesn't work. I'll adjust this script in NT so that it avoids the issue in the future, but you'll likely run into this problem when playing vanilla until the underlying controls issue is resolved.

Edit2: Deactivate/Uninstall your current NT IRO and import this one to 7h: https://mega.nz/file/n5ESSaAZ#440wlSd2_cf1Zh3mOhToh0vIVsrbGiHQhgsh59puT_c

At the swinging bar, it'll keep you in place until the Confirm button is pressed with no inputs able to cancel it. I also added an additional handler; if you press Square/Switch then Cloud will jump to the other side and skip the bar.

Thank you so much for this, that all makes sense to me - I will be playing later today so will try the new IRO and see how I get on.


It worked! Thanks so much - you just made my quarantine life a bit more easy to bear. I'll try and get that keyboard issue sorted too.


[0] Message Index

Go to full version