Author Topic: FFVII starting problem (solved)  (Read 2882 times)

secondadvent

  • *
  • Posts: 287
    • View Profile
FFVII starting problem (solved)
« on: 2009-04-28 21:43:46 »
ok, to start off, the game will start up, but remain black, no sound or music. if i press enter, it sometimes makes a sound similar to that of an error message (i think a dialog box is popping up with an error of some kind, but i cannot see it to figure out the problem, even setting my desktop's resolution to it's lowest, to try and see if the box was just outside of the resolution's view didnt work), then continues to play the eidos/square/credits movies.

the thing here is that none of the buttons work at this point, except the right mouse button, which acts as the enter button, and kicks me to the new game/continue screen, where i can advance no farther, even with a save file (the pointer hovers over continue at the start, and no buttons other than the right mouse button works, so no progress can be made). I even have a numpad on my laptop's keyboard (like any regular desktop keyboard, no fn button required to use them), and none of the buttons will work in the game, but do outside of the game, with or without num lock on. i have tried the laptop patch, to no avail. also, i cannot initially alt+f4 out of the program, until after i press enter to see the eidos movie, and if i press ctrl+q, the quit screen comes up, but i get stuck there, and not even alt+f4 gets me out, but alt+f4 works fine to exit.

ok, here are some things i have tried to solve this issue:
1. removed all codecs, and started from scratch, first only using the truemotion 2.0 codec, then adding the k-lite later and trying then.
2. removed gabest's avi splitter
3. tested out the game with lowered hardware acceleration, as well as sound acceleration in dxdiag
4. reinstalled ffvii multiple times
5. tried running in software, as well as in every combo of the nvidia setting in 1.02 config
6. tried the original (not 1.02) exe/config
7. put all of my movies on my hard drive, and had them successfully run (still with above issues, but they DID run)
8. tried pretty much every key combo possible, and only the ones to exit the program (after pressing enter to get rid of the dialog box), and the right mouse button work
9. all the movies play in MPC, so i know all the movies work, and in-game shows that as well
10. tried to run in windowed with cetra, to see if the dialog box appeared so i could see it there, but oddly the box didnt appear, and the game ran on its own, but black bars occurred in the movie, and keys still didnt work
11. tried various nvidia settings, such as disabling sli/physx, using rivatuner to disable 8-bit palletted textures, and disable AA
12. added the upside down patch in the hopes of somehow fixing the problem
13. multiple other things that i cannot remember off the top of my head

note: i have had this game working before a while ago, but with things constantly being added, such as newer drivers, my current ones being needed for performance in other games, many things could be at fault (probably drivers though, or some weird codec issue, though the movies and sound runs fine, and as of yet no graphical errors).

Before i resort to downgrading my driver to one that i know worked with ffvii, i was hoping for some more ideas on how to fix this problem. no patches were added at all, other than the updated config/exe, but that is all. i had originally thought it was from the PRP patch, which i had added before (put on all of my normally added patches, except for the PRP, which i had substituted for the reconstruction one), but after uninstalling everything and then starting from a clean install, the problem remained. If you can give any insight into the solution/cause of my problem, i would be thrilled, since i am trying to hack ffvii to be harder, yet the scene.bin file became too big to import back into the iso, and i cannot figure out how to make it so i can add the larger file and still run the game (got it to run once, but battles wouldnt start >_>), so i fell back onto the pc version.

PC specs:
windows xp sp3
intel core2 quad q6700 @ 2.66ghz
4gb ram
dual nvidia geforce 8700m gt (dox optimised 185.68 drivers), sli capable

my computer is definitely capable of handling ffvii, but since somebody did a craptastic porting job, as well as nvidia's lovely old game support (not), i have had, as well as many others, a super phun tyme solving all of it's problems. if you could fix this issue, i would make you my hero of the week >:D
« Last Edit: 2009-05-02 14:29:20 by secondadvent »

dziugo

  • *
  • Posts: 1470
    • View Profile
    • A new copy of FF7 thanks to Salk. Pack (zip/rar/etc) your saved game before sending it to me.
I'd go with the drivers. As you said, it was working before.

secondadvent

  • *
  • Posts: 287
    • View Profile
yeah i was thinking about it... i have the drivers that they worked with last, but i'd have to reinstall the drivers any time i wanted to play ffvii, and reinstall the newer ones for anything else >_>

i would have hoped you, of all people would have more advice... too bad :'(

i'll install them in a little while and come back here with the results. however with those drivers, i have either the black texture problem with hardware, where all of the vertex shaded things are black, or i get slow movies in software... cant win for losing i guess.

secondadvent

  • *
  • Posts: 287
    • View Profile
Re: FFVII starting problem (solved)
« Reply #3 on: 2009-05-02 14:16:11 »
ok, i have now found the sloution to this problem, it was not the driver that did it (in fact, my vertex shaded problems are now fixed in hardware mode with dox's drivers XD), it was zonealarm that caused the problem. the invisible popup during the start of the game was apparently one of it's allow/deny notifications, and having game mode on solved the problem by choosing "always allow". my keys all worked, and i was successfully able to run the game with no problems (other than any normal problems ffvii will probably have >_>).

for those who had the same problem starting as me, check to see if there is a similar mode in your firewall, or if it is zonealarm you have, problem solved already XD. also, if anybody with a nvidia 8xxx card, and are experiencing the black character (vertex shaded area) problem, try out one of dox's customized forceware release drivers, as it has fixed my issue.

i guess i just had to experiment more on my end than just the usual things... i didnt expect zonealarm to be the culprit, but i guess i learned from that mistake.

edit: whoops, forgot mine was the last post, or i'd have just modified it *facepalm*